Linux.com

nVidia Drivers

Link to this post 01 May 11

G'Day; I have Ubuntu 10.10 installed.
My PC = VGA; Gigabyte 1Gb ddr3, GT440
PCU = Intel i5 Quadcore 3.33Ghz
MOBO ; Gigabyte H55
Now the problem is that when I try to load the nVidia drivers, through the terminal with;

Re: nVidia Drivers
sudo rm /etc/X11/xorg.conf

sudo apt-get update
sudo apt-get install -f
sudo dpkg --configure -a

sudo apt-get install nvidia-current
sudo apt-get install nvidia-common
sudo apt-get install nvidia-settings

reboot (sudo shutdown -r now)

or through the Additional Drivers App.'
I end up at the shell with no GUI nothing and can't do anything but reboot into W7, delete the partition and reinstall 10.10.
I was told, in one forum, to run telinit 3 but when I run that command nothing happens, also to remove the nouveau drivers, but when I run that command it returns "cannot fine nouveau package",
Can anyone help please.
Kind regards Miykel

Link to this post 01 May 11

I don't have a running Ubuntu install at the moment, maybe some who has will offer up some wisdom. But, in fedora, one must add rdblacklist=nouveau and nouveau.modeset=0 to the kernel line in grub in order to stop the nouveau drivers from loading. You can't really delete the nouveau drivers because they are embedded in the kernel. What the commands in fedora do is blacklist the module so it doesn't load. I would think if you installed the drivers through Ubuntu's hardware setup, it would add the commands and module blacklists for you. I haven't used the nvidia driver for over a year now, since the advancements in nouveau perform nicely for what I need them to do.
According to this, your card should be supported:
ftp://download.nvidia.com/XFree86/Linux-x86_64/270.41.06/README/supportedchips.html
but, as stated in that list:
Some designs incorporating supported GPUs may not be compatible with the NVIDIA Linux driver: in particular, notebook and all-in-one desktop designs with switchable (hybrid) or Optimus graphics will not work if means to disable the integrated graphics in hardware are not available. Hardware designs will vary from manufacturer to manufacturer, so please consult with a system's manufacturer to determine whether that particular system is compatible.
You machine is fairly new, and might have the switchable Optimus grahics, that I don't know. What is most likely is that you borked your nvidia install, tried to remove the nvidia cruft and left some things behind, because, removing the drivers with apt-get doesn't purge all of the extras that the installation deposits.
Hopefully, one of our Ubuntu users will be along and can give you more precise help, because things have changed since I've borked my last nvidia install, and any instructions I come up with may be out of date, and hence, may make things worse.

Edit: I found this website that explains how to install the nvidia driver by downloading it directly from the nvidia website. It was done with Ubuntu 10.10, it is an alternate way of doing the installation. I also see that it tells you how to blacklist the nouveau driver in grub2 that Ubuntu uses. You may want to give it a look.
It also explains how to get into recovery mode and fix grub etc.
http://www.socialblogr.com/2010/10/how-to-install-nvidia-graphic-card-driver-on-ubuntu-10-10.html

If your not comfortable with following that how-to, and would like to wait for someone who actually runs Ubuntu to correct me or make other suggestions, just be patient. This is the weekend and things slow down here a bit on Saturday night.

Careful about one thing though. If you use grub to boot your windows7, don't remove the partition. It may also remove the bootloader for windows. Don't do anything until you know exactly what state your in. Not getting a GUI booting Ubuntu just means that your graphic drivers are borked, not your whole install. Giving us more info about how you set up your dual boot, whether your machine uses Optimus graphics and any other info you can think of, could help us zero in on a solution for you.
Now I'm just thinking/typing out loud, so I'll stop until I get some more info from you or someone else here chimes in with more help.

Link to this post 01 May 11

G'Day Going easy9; Thanks for the link, all went well until I got to installing the nVidia drivers, then I got a message "could not open nVidia-Linux etc etc.
This is the code I in the link
#sh NVIDIA-XXXXXX.run
I Assumed the X was the rest of the file name so I entered
#sh NVIDIA-Linux-x86-270.41.06.run
Is this correct or should I have just left the xxxxxx ?
Kind Regards Miykel

Link to this post 01 May 11

You're correct, the driver name/number needs to be there not the X's. Good luck.

Link to this post 01 May 11

Now that is a problem, when I entered the whole file name I was told "could not open NVIDIA-Linux-etc"'
so now I'm not sure what to do , maybe the files corrupt or something,
kind regards Miykel

Link to this post 01 May 11

G'Day again guys; Well I tried the post in the link provided but no good, after install, I didn't have the nVidia file in Home earlier, I still end at the shell log in ,This is the 4th method I've tried with the same result, this time I got to look at a log which said,
16.313 Failed to initialize nVidia graphics device PCI : 1.0.0
Lower Down
16.313 Screen found but none have a usable configuration

Can anyone make head or tail of this please ???
Kind regards

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board