Problem with APT-GET

Link to this post 01 May 12

Hello people,

I use Ubuntu 11.10.

I wanted to delete the contents of /var/cache/apt/archives/ so I taped sudo rm * -R
But now, each time I want to install anything with sudo apt-get install 'packagename' the installation process does not launch and I receive this message:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

Can you help me to fix this and explain me what happened ?

Thank you.


Link to this post 01 May 12

You probably deleted something you shouldn't have :S

Next time just delete the *.rpm files ;)

I'm not an apt-get guy but you should probably look at rebuilding the database or something like that...


PS: did you run the command that you were suggested?

Link to this post 01 May 12

Hello Marc,

Thank you for your answer but how can I rebuild database for what ?

Yes, I run sudo rm * -R.


Link to this post 01 May 12

Well, apt-get uses .deb files not .rpm files, but, that's neither here or there. I'm wondering, just as Marc is, what you could have deleted.

Did you run "apt-get update" before you tried "apt-get install packagename"? apt-get update synchronizes the package list that apt uses. That might restore the database that you might have deleted. Also, one should always do apt-get update before installing an application or doing a dist-upgrade to make sure that the package database is up to date.

BTW - Running "sudo dpkg --configure -a" is a good way of fixing problems that arise during the use of apt. Did you try that command, and, if so, did it help?

Link to this post 02 May 12

Thank you for your answer GoinEasy9 and Mark: I did sudo apt-get update before apt-get install and everything works again just as fine as before.


Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board