Home Linux Community Forums Linux Distributions Ubuntu Ubuntu, 11.04 (fully updated)

Ubuntu, 11.04 (fully updated)

Link to this post 31 Aug 11

My main PC seem to have caught galloping bit-rot.
It's been working perfectly for two months but, in the last week or so it's started spontaneously hanging. I was just filing some emails in gmail (via Chrome browser - v13.0.782.218) and the whole system just hung; not even mouse movement. I haven't added any hardware recently. the hardware is only a couple of months old and I'm not running anything particularly weird except (maybe) VirtualBox (non OSE version).

There's nothing I can see in the logs (kern.log and syslog - excerpts below) and I can't find anything on the Ubuntu bug list which might affect me.

Any ideas about where I can look trace-wise and/or if some of the latest updates have caused any grief? :(

kern.log (excerpt)
Aug 30 13:17:45 Silver-Streak2 kernel: [ 217.244605] wlan0: no IPv6 routers present
Aug 30 13:23:26 Silver-Streak2 kernel: [ 547.393520] exe (2370): /proc/2370/oom_adj is deprecated, please use /proc/2370/oom_score_adj instead.
Aug 30 21:16:37 Silver-Streak2 kernel: [28857.348446] warning: `VirtualBox' uses 32-bit capabilities (legacy support in use)

/* crashed here */ (at 10:24)

Aug 31 10:25:58 Silver-Streak2 kernel: imklog 4.6.4, log source = /proc/kmsg started.
Aug 31 10:25:58 Silver-Streak2 kernel: [ 0.000000] Initializing cgroup subsys cpuset
Aug 31 10:25:58 Silver-Streak2 kernel: [ 0.000000] Initializing cgroup subsys cpu

syslog (excerpt)
Aug 31 09:17:01 Silver-Streak2 CRON[5384]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Aug 31 10:17:01 Silver-Streak2 CRON[5538]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)

/* crashed here */ (at 10:24)

Aug 31 10:25:58 Silver-Streak2 kernel: imklog 4.6.4, log source = /proc/kmsg started.
Aug 31 10:25:58 Silver-Streak2 rsyslogd: [origin software="rsyslogd" swVersion="4.6.4" x-pid="426" x-info=""] (re)start
Aug 31 10:25:58 Silver-Streak2 rsyslogd: rsyslogd's groupid changed to 103
Aug 31 10:25:58 Silver-Streak2 rsyslogd: rsyslogd's userid changed to 101

Link to this post 03 Sep 11

I cannot find any hints in your logs that can point to the cause, except for possible memory issues due to the amount of memory that web browsers consume. Have you attempted to run memtest from the installation disk to test your RAM and see if it is bad?

Link to this post 10 Oct 11

Apologies for the delay in replying. The site outage precluded any reply.

Yes, I've checked the RAM and it's (allegedly) fine. The problem is fairly sporadic but always seems to happen around 13:00 which, in South Africa, usually means it's pretty hot. However, I've checked the CPU and board temperature and, if the values reported are correct, they're well within the operating limits.

I doubt if it's running out of memory, the unit has 16GB on board on I don't think its ever gone higher than 10GB in use even when I'm running 2 or 3 VMs.

It may be hardware but, if so, it's a weird problem. The only thing I can think of is that the board or one of the RAM chips has a microscopic crack which opens up when the system warms up. What is VERY odd is that, when it hangs, the mouse just stops moving and whatever was on the screen just prior to the crash remains there. I even tried to ssh into the unit after it had crashed to see if there was still any life behind the frozen display. Nothin'!

I think I'll just unplug everything inside and out and stick it back in again. Might just be a loose SATA cable or an intermittent short somewhere.

The reason I reported it is because I've NEVER seen a Linux installation do anything like this. Although I've had crashes in the past they've usually been picked up by the kernel and reported. Never had a straight 'freeze' like this.

But thanks anyway.

Link to this post 12 Oct 11

I also want to ask if you had checked your installation disk's md5sum prior to installing the system. If the disk or disk image was corrupt that might explain such a weird issue.

Link to this post 12 Oct 11

Hi again,
I must confess I didn't check the MD5 and I seem to have lost the disk I cut the ISO to. That said, I'd be surprised if it was a corruption of the installation as it worked perfectly for about 2 months without a problem. Still, I've seen weirder things so it's certainly possible.

I've got a bit too much work on at the moment but, when I've got a spare hour or two, I'll scrape the box and re-install it. If that doesn't rectify it, I'll swap out the RAM, motherboard etc. until the issue is resolved.

All that aside, I'm starting to suspect it's something to do with the sound module or driver. I use Banshee and I noticed the other day that the latter is a bit erratic (spontaneously exits with no error condition on a fairly regular basis). So it may be a prob with the sound hardware or driver.

I'll keep plugging away though.


Link to this post 13 Oct 11

Ubuntu 11.10 comes out in less then an hour, good time to give it a try.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board