Home Linux Community Forums Linux Distributions Ubuntu wifi on 12.04 and other questions

wifi on 12.04 and other questions

Link to this post 13 May 13

I have been using 12.04 happily since installing it. After a crash recently (from wubi) I reinstalled it with a usb stick. All works fine but suddenly, I can't use wifi. It recognizes the signal and shows that it is strong. But Wifi Radar also shows other signals. It just won't connect.
On Windows 7, however(which I also have for emergencies), all is well.
Is this an OS issue, am I missing something... that I also need to reinstall? Any commands that I could use? Or is it just that there is too much interference? (If so, why does it work with Windows?) Is there any way I could block these signals?
Also, I'd like to know which usb sticks are compatable with linux, and how many GB's are needed. I tried to load 13.04 on mine, 4GB and it wasn't eneough.
I know that these might sound like silly questions to those who are more experienced, but I would greatly appreciate any help. (My 60 yr. old brain is slow in learning )


Link to this post 14 May 13

Hi Estelle,

Ok, so this is probably out of my area of knowledge, but I'll give it a go anyway. (If I can't help, a moderator should be able to.)

So, first things first, can Ubuntu connect to a wi-fi signal on its native wi-fi client? (On the Unity interface). Also, what kind of modem are you using? it may be a compatibility problem with Wifi Radar. (Though, I do doubt that option). And, lastly, is everything updated?

Please give me as many details as humanly possible about your OS, modem, related apps, etc. The more we know, the faster this can get solved.

Thank You,

Link to this post 14 May 13

Hi Izzy,

Thanks for replying. As far as I know, Ubuntu worked fine on Unity from the beginning.
The modem that I am using is a wireless adsl2+ T&W matr-X 4ew, at least that is what it says
on the manual. Other than Wifi Radar, I also use Windows wireless drivers and Broadcam STA
wireless driver. I updated them when reinstalling 12.04.
The whole problem started about 2 weeks ago, when spring break began. Then I begaan getting different signals on my wifi. There are many hot spots here, and almost everybody has an iphone or ipad.
Also, in an attempt to upgrade to 13.04 everything crashed because wubi isn't supported by 13.04 and I had to reinstall again on wubi. I'd like to try 13.04 first from a usb stick, but mine is too small and I'm looking for one compatable with linux that I can use for this. I have tried various tweeks that I have read on different forums. Nothing works.
If it helps... my laptop is a Samsung RF711. It has NVIDA Optimus , intel core i5. originally with windows 7. (here the problem started ) which is why I want to make a clean install.
I can't understand why wifi works with Windows and not with Ubuntu. Especially since it worked before.
I hope that this is enough information.

Link to this post 15 May 13

Thanks Estelle,

Before we talk about wifi, here is my take on some of your other questions:

A) All modern USB's are compatible, and 4GB is more than enough. (I booted 12.04 on 2GB). I think the application process might have been wrong though. What did you use to "burn" the iso image? I would/have used pendrivelinux. ( at ) (I think that was the program, that was about a year ago for me.) Follow the instructions and you're good to go.

Now on to wifi

1) In my humble opinion, I would drop wifi radar, and let the wifi client in Unity (your default wifi client) work by itself. Wifi Radar's JOB is to find any and all wifi signals. (Which would explain the interference) Unity's wifi client is probably a bit more refined. (Windows is FAR more refined, explaining why this problem does not occur on 7).

So hopefully, Wifi radar is the problem as it's finding TOO MANY wifi signals, and not your OS/system.

And by the way, about that slow learning, 60 year old mind: you made ME Bing at least three things that you knew already. So, I don't think you get to claim that piece of grey matter as slow.

Have a good day. (Or night, whatever really. lol.)

Link to this post 15 May 13

Hello again,
So far tried removing everything except the wifi client, nothing there.
Then just removed and reinstalled wifi client, nothing.
Finally reinstalled whole OS, nothing.
Even tried creating new account, changing frequencies, running a diagnostic test of modem.
As far as trying usb again... everytime it says that there is not enough space. Even though it is empty. Maybe, I'll just buy a larger one, they're cheap enough.(Mine is old)
It could just be too much interference... it has happened before. But it solved itself,after a while. I'm in Greece.... we have this problem with infrastructure. The government hasn't done much to improve ISP service, which results in wired and wireless problems.. since practically everybody has some wireless device... they're quite affordable.
That however is an economic/ political problem.
Thanks anyways for all the help. Will let you know if I do find a solution. For now, will use ethernet... like my son suggests anyways.

Link to this post 16 May 13

I am hoping that your problem is with signal interference as it would show itself differently in linux than in windows because some manufacturer supplied drivers are instructed to ignore some types of errors. However, if the problem started with a kernel update then it may be a sign of a regression in the drivers for your wifi card to which I highly recommend plugging the device into the wired network and reporting the problem to ubuntu so see that they say since they also have kernel engineers and can work on a solution.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board