February 27, 2015

I need to update Ubuntu

I have followed most all instructions, copied and pasted and all but now I am getting this reponse when trying to update,
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
Can anyone help with this, I am new to Linux but learning more each day, bought an old laptop from a store and tried to upgrade UBUNTU from 12.04 to 14.04 because all other versions are not supported any longer if I have been researching correct, but I have also seen that 12.04 will be supported until 2017. any help would be great.

First and foremost, welcome to the world of Linux! Now, when you bought the...

First and foremost, welcome to the world of Linux! Now, when you bought the computer, did it already have Ubuntu installed? If so, you need to have admin rights to do things this is called sudo. You may want to try and do normal system updates by running sudo apt-get update. Then sudo apt-get upgrade, this should help correct any errors by installing any updates that my be needed for the upgrade.

Like  (0 likes)
Click Here!