July 24, 2018

Lab 2: Install exits with Error

The stack.sh exits with Error and I can't continue (i don't get the ens3 i/f and can't launch BUI). I've looked at Errata, but that creates errors too.
Is started by not getting any o/p for "apt-get install git" as shown in 2.2 step 1.
The install runs for about 20min and exits with an error.

From log:
2018-07-23 23:26:25.944 | uwsgi-2.0.17.1/core/errors.c
2018-07-23 23:26:26.034 | uwsgi-2.0.17.1/t/routing/errorlimiter.ini
2018-07-23 23:26:26.055 | /usr/share/apr-1.0/build/libtool --mode=compile --tag=disable-static x86_64-linux-gnu-gcc -prefer-pic -pipe -g -O2 -fstack-prot
ector-strong -Wformat -Werror=format-security -DBUILD_DATETIME='"2018-06-07T19:43:03"' -Wdate-time -D_FORTIFY_SOURCE=2 -DLINUX -D_REENTRANT -D_GNU_SOUR
CE -pthread -I/usr/include/apache2 -I/usr/include/apr-1.0 -I/usr/include/apr-1.0 -I/usr/include -c -o mod_proxy_uwsgi.lo mod_proxy_uwsgi.c && touch
mod_proxy_uwsgi.slo
2018-07-23 23:26:26.104 | libtool: compile: x86_64-linux-gnu-gcc -pipe -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -DBUILD_DATETIME=
\"2018-06-07T19:43:03\" -Wdate-time -D_FORTIFY_SOURCE=2 -DLINUX -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/apache2 -I/usr/include/apr-1.0 -I/usr/i
nclude/apr-1.0 -I/usr/include -c mod_proxy_uwsgi.c -fPIC -DPIC -o .libs/mod_proxy_uwsgi.o
2018-07-23 23:27:00.654 | +functions:setup_systemd_logging:650 iniset /etc/keystone/keystone.conf DEFAULT logging_exception_prefix 'ERROR %(name)s %
(instance)s'

2018-07-23 23:27:34.239 | +functions:setup_systemd_logging:650 iniset /etc/glance/glance-api.conf DEFAULT logging_exception_prefix 'ERROR %(name)s %
(instance)s'

2018-07-23 23:27:34.702 | +functions:setup_systemd_logging:650 iniset /etc/glance/glance-registry.conf DEFAULT logging_exception_prefix 'ERROR %(nam
e)s %(instance)s'
2018-07-23 23:28:09.592 | +functions:setup_systemd_logging:650 iniset /etc/cinder/cinder.conf DEFAULT logging_exception_prefix 'ERROR %(name)s %(ins
tance)s'

2018-07-23 23:29:29.097 | +functions:setup_systemd_logging:650 iniset /etc/nova/nova.conf DEFAULT logging_exception_prefix 'ERROR %(name)s %(instanc
e)s'

2018-07-23 23:31:40.473 | DEBUG oslo_db.sqlalchemy.engines [-] MySQL server mode set to STRICT_TRANS_TABLES,STRICT_ALL_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE
,ERROR_FOR_DIVISION_BY_ZERO,TRADITIONAL,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION {{(pid=13206) _check_effective_sql_mode /usr/local/lib/python2.7/dist-p
ackages/oslo_db/sqlalchemy/engines.py:285}}

2018-07-23 23:31:52.985 | DEBUG oslo_db.sqlalchemy.engines [-] MySQL server mode set to STRICT_TRANS_TABLES,STRICT_ALL_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE
,ERROR_FOR_DIVISION_BY_ZERO,TRADITIONAL,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION {{(pid=14271) _check_effective_sql_mode /usr/local/lib/python2.7/dist-p
ackages/oslo_db/sqlalchemy/engines.py:285}}

2018-07-23 23:37:45.544 | DEBUG oslo_db.sqlalchemy.engines [-] MySQL server mode set to STRICT_TRANS_TABLES,STRICT_ALL_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE
,ERROR_FOR_DIVISION_BY_ZERO,TRADITIONAL,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION {{(pid=29425) _check_effective_sql_mode /usr/local/lib/python2.7/dist-p
ackages/oslo_db/sqlalchemy/engines.py:285}}

2018-07-23 23:37:49.837 | DEBUG oslo_db.sqlalchemy.engines [-] MySQL server mode set to STRICT_TRANS_TABLES,STRICT_ALL_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE
,ERROR_FOR_DIVISION_BY_ZERO,TRADITIONAL,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION {{(pid=29436) _check_effective_sql_mode /usr/local/lib/python2.7/dist-p
ackages/oslo_db/sqlalchemy/engines.py:285}}

2018-07-23 23:38:27.431 | +functions:setup_systemd_logging:650 iniset /etc/neutron/neutron.conf DEFAULT logging_exception_prefix 'ERROR %(name)s %(i
nstance)s'

2018-07-23 23:38:51.462 | DEBUG oslo_db.sqlalchemy.engines [-] MySQL server mode set to STRICT_TRANS_TABLES,STRICT_ALL_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE
,ERROR_FOR_DIVISION_BY_ZERO,TRADITIONAL,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION {{(pid=2316) _check_effective_sql_mode /usr/local/lib/python2.7/dist-pa
ckages/oslo_db/sqlalchemy/engines.py:285}}

2018-07-23 23:39:17.907 | ERROR: Could not access cell0.
2018-07-23 23:39:17.908 | Error: No sql_connection parameter is established
2018-07-23 23:43:46.609 | [ERROR] /home/ubuntu/devstack/lib/glance:355 g-api did not start
2018-07-23 23:43:47.617 | Error on exit

Click Here!