Home Linux Community Community Blogs

Community Blogs

Linux vs Windows Data Servers (the bottom line)

Based on years of writing software within a network environment, and communicating with database servers running on both Microsoft Windows or Linux that provide access to databases like Microsoft SQL server and PostgreSQL  I have to say, Microsoft better look over their shoulders,  the competition is gaining a strong hold on corporate decision makers and how they foresee the future's bottom line.

At this point, the money paid out with setting up a Microsoft SQL data server by the time they factor in the cost of the operating system, the database software, the per-seat licensing, and support you almost have to take a step back and scratch your head with how much money it takes to put this in production.

Again, based on my own experience, I’m not sure why anyone would want their corporate data on a Windows-based server that requires a lot more money and maintenance to keep the server up and running, while maintaining availability, reliability, and security.

A well configured Linux data server provides a much better overall experience for a fraction of the cost.

With how companies are struggling to operate in the green, why anyone wouldn’t explore these open source options like PostgreSQL, MySQL, and operating systems like CentOS just doesn’t make any sense.


Recursion in Bash-Shell Script


## ----------
## This script will move all the TEXT files with name containing numeric only to path "/dump".
## If filename already exist at destination path, it will not move the file then.
## Log will be maintained containing path along with filename.
## ----------


LOG_NAME=$(date +"recursion_%d%m%Y_%H%M.log")

## ----------
## modify IF statement if
## source and destination path need to pass through arguments
## ----------

if [ $# -ge 1 ];then
    echo "wrong input, do not pass any argument"
    exit 1

function SCAN_DIR ()
    ls "${1}" | while read line

        if [ -d "$new_path" ];then
            SCAN_DIR "${new_path}"
            echo "$line" | grep -qE "^[0-9]+[0-9].txt"
            if [ $? -eq 0 ];then
                echo "$new_path" >> ${LOG_NAME}
                mv -n "$new_path" ${VAR_DUMP_PATH}/
#        sleep 1
##    echo "exiting function SCAN_DIR"


exit 0

## ---- END ---- ##


Steps to Hosting a Web Site on Ubuntu 11.04

1. install apache2 the go to /etc/apache2

2. cd sites-available

3. cp default  new_web_site_name_file

4. make the changes as follows this is for Name virtual hosting

NameVirtualHost IP  e.g.x.x.x.x
// this would already be there just change *

ServetrAdmin your mail id //this entry would also be there just change mail id

add the following three entries according to your need

 DocumentRoot /var/www/Your dir name/ // web site's root path
 DirectoryIndex login.php //default login page entry
 ServerName your web site //ur web site address

let other entries be there

save the file.


run the following commands as root user or use sudo

a2ensite name  new_web_site_name_file (file name used in step 3)

the restart the apache web server

/etc/init.d/apache2 restart/reload

you can acces the web site aftre making the necessary cahnges in the /etc/hosts file on your system or acess it on the interanet/internet after getting its entry done in the DNS



Harkamal Dadwal







The new way to be - KDE

After working with Ubuntu Linux since version 7.04 I have a lot of experiences that were not all good, but overall, the operating system has been stable up until the latest version 11.04.

Yes, I understand that canonical wants to offer this new experience that provides a new look-and-feel, but in my opinion,  jeopardizing stability by turning an operating system inside out just does not make sense.

I feel Ubuntu overall at one time provided a great Linux experiences for anyone; even people migrating from Windows, but now, I have one thing to say - I love Kubuntu 11.04 I call it "the new way to be - KDE"...



My linux diary!!

How to save youtube without any external software!!!
First make sure that the video you want to download is open in the browser(i have tried this with firefox and chrome)
Doing this in firefox is rather can be copied from the browser cache!! it is present in the home directory /home/user_name/.mozilla/firefox/(random_text).default/cache/ and then use find(search for .flv) to get the flash video!!
But in chrome its kinda earlier versions of flash players the vids used to be stored in the /tmp folder..but not anymore with the release of version 10.2 of  Adobe flash !!
anyways it can still be achieved
First open good ol' terminal and type either “lsof | grep Flash” or “ps x | grep flash”
The first command will give an output similar to the following

here you can see the process is “chrome” an the process ID (PID) is 4299 and the fd number is 33
now navigate to the file by typing
“cd /proc/process ID(the number)/fd(only fd not the value)”
here process id is 4299
now copy the file with fd 33 onto te desktop or the required destination with the command
“cp fd number /home/username/Desktop”
Thats now have the file!! it is better to do this after the whole video has buffered to get the whole video!!
Now coming to the second command
Open the terminal again and type
“ps x | grep flash”
the output will be similar to this

here you can see the results..the first one uses that is what we shall be using now!!
here u see only the PID this case 4299
so we need to navigate to that folder
“cd /proc/process id number/fd”
here the command would be “cd /proc/4299/fd”
now list the directory and grep the flash file
“ls -l | grep Flash”

the output will be similar to the one you can see that the fd 33 points to the deleted flashfile
in the tmp folder..this is the required file...copy it to the required destination!!!


First Post

Well ive been doing some reading trough the forums here aswell as the blogs for a while, about time for me to write something i guess :)

I actually have some questions someone hopefully can help me out with, atm my laptop is running Linux Mint11 with working proprietary drivers for the ATI gfx.

But i have also tried the Fedora livecd and i must say that i really like the interface, not to Unity-ish but instead nice looking and easy to use, but i tried a fresh install and ended upp with the black screen of death so i gave up.

Also had a look at Opensuse, but i cant really decide if i should do the switch from Ubuntu or Debian based if i should go Fedora or Opensuse, any pros and cons that can be good to know about them.

Or should i go with the one that feels best, i want a nice community if help is needed along the journey and ive bumped in to some really unfriendly ones during the years =D


How-to Virtualize a HP BL460c running SLES Linux 10 SP2

To begin with a bit of background on the environment may be helpful…

The need to virtualize my HP C7000 blade environment came from a requirement to consolidate our comms room estate, and retire out legacy hardware and achieve as good an occupancy on the remaining hardware as possible. The eventual plan for the left-over kit could be anything from a test-rig running Eucalyptus, or just a VMware ESXi environment running many virtual machines. – For now we are keeping it simple with a basic ESXi environment.

Most of my existing hardware is running on G1 or G2 blade kit, and I wanted to be able to just lift out the existing servers and place them in their new environment with as little disruption as possible, or developer time rewriting legacy code,etc, whilst I gave some thought to how I would rearrange my estate for maximum efficiency once all the services running in it had been virtualized, and made effectively hardware independent (within reason).
Here are the steps I went through, I’ve also listed a couple of gotcha’s that I wasted a bit of time on, but I’m glad I’ve thought of, so I wont be wasting time again!

I wanted to virtualize a system that was running on a HP BL460c(using its local storage not SAN or storage blades) and make it run under ESXi. I thought that this would be a simple case of connecting the ESXi cold clone CD to the blade and doing a few mouse clicks.

 This was how I proceeded, but I couldnt figure out initially why the blade was unable to see my ESXi server, even though all the correct routing between networks existed. - Then I remembered that I was running with 2 x Gb2EC network switches in the back of that c7000 chassis, and that I had had to use VLAN-tagging on all of the ports, this worked fine when the original blade OS  was ‘up’, but without the knowledge of the VLAN tags in the cold clone CD, this seemed to fail to work.

(If someone has done a cold clone in an environment where they have needed to tag the packets that are being sent from the cold clone mini-OS then I would love to have some feedback on how you did it.)

In the end I moved the blade from its original chassis and placed it in a c7000 enclosure with the VLAN-tagging disabled, and this worked great.

So I used the blade ‘SUV’ cable and connected a CD drive and keyboard and VGA screen to the blade and booted from the VMware ESXi cold clone CD, and went through the steps of identifying the ESXi system that I wanted to receive the image that the cold clone CD produced from the blade. 

I had a bit of a issue with the fact that parts of the configuration process for the cold clone environment seemed to require a mouse to click ‘Next’ as the tab key seemed to work intermittently (this could be a hardware/keyboard issue on my side), but just for reference its fine to disconnect the keyboard from the SUV cable and connect a mouse (and vice-versa) as many times as necessary throughout the installation. – Another approach which is probably possible is to connect the cold clone media using HP Virtual Media, but again I went for what was the most straightforward approach at the time.

Once the cloning process was complete I had the virtual version of the blade available on my ESXi host, but at this point it would still not boot successfully, as its expecting to see the Smart Array adapter in the blade, and so it tries to look for boot and root on /dev/cciss/c0d0pXX.
So from this point forward the files that I needed to edit on the Virtual machine image were the /etc/fstab, the /boot/grub/ and /boot/grub/menu.lst. 

You need to go through this and replace any reference to /dev/cciss/c0d0 with /dev/sdaX and so on. As an example here are some of my changes, which I applied by booting a liveCD and mounting each partition:
(hd0) /dev/cciss/c0d0  —-> changes to  —>>(hd0) /dev/sda (note that there is no partition number specified)
root (hd0,0)
kernel /vmlinuz-version root=/dev/cciss/c0d0p3 resume=/dev/cciss/c0d0p2
initrd /initrd-version
The above three lines changed to:
kernel /vmlinuz-version root=/dev/sda3 resume=/dev/sda2
initrd /initrd-version
/dev/cciss/c0d0p3 /  –>changes to –> /dev/sda3 /
/dev/cciss/c0d0p1 /boot –>changes to –> /dev/sda1 /boot
/dev/cciss/c0d0p2 swap –>changes to –> /dev/sda2 swap

Next, I grabbed the SLES install CD/DVD and booted as if I were going to do an installation. I proceeded through the normal install steps up to where you are asked whether you are doing a new install,an update or ‘other options’. From other options you can run the System Repair Tool, and this analyses the installed system and advises you of any missing kernel modules, or ones that are now defunct (amongst other things). My CD advised me to disable debugfs and usbfs. I did not select verify packages, but only ‘check partitions’, ‘fstab enties’ and the final step rewriting the boot loader if needed.

Once the newly imaged server had booted I needed to delete the old network interfaces, and delete all entries in the /etc/udev/rules.d/30-persistent-net-names.rule, do a reboot, which automatically entered the new MAC address details for the new VMware ethernet adapter, then readded the network adapter in YaST.

After that I did a reboot, ejected the Install CD, installed VMwareTools on the Guest and I had my newly virtualized system operational again!
Matt Palmer 30-Aug-2011


openSUSE Weekly News 190 is out!

I'm pleased to announce the openSUSE Weekly News 190.



In this Issue:

  • openSUSE Conference 2011
  • Google Summer of Code Reports
  • Linus Torvalds: Linux 3.1-rc3

You can download it there:

We hope you enjoy the reading :-)

If you want to help us collecting interesting articles for the openSUSE Weekly News, so you can all your stuff into our new ietherpad:

Found Bugs? Please place it in our Bugtracker:

Features, Ideas and Improvements can placed in our Featuretracker:

Older content can be found there.


Fake Ip address when use SSH with torify

When you try to connect to a server using SSH (secure shell) your ip will log in the server for example the log in here..


when our ip was log on targer server, its so dangerous, so know lets do a simple trick to fake our ip in the server log by using SSH, and the trick is we use Torify.. lets try

# torify ssh This e-mail address is being protected from spambots. You need JavaScript enabled to view it .1.7

So our Ip address will be anonymos, and lets check the log now

Aug 23 16:46:12 namaserver sshd[27034]: Invalid user admin from
Aug 23 16:46:12 namaserver sshd[27034]: Failed none for invalid user admin from port 44194 ssh2
Aug 23 16:47:19 namaserver sshd[27034]: pam_unix(sshd:auth): check pass; user unknown
Aug 23 16:47:21 namaserver sshd[27034]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=
Aug 23 10:32:05 namaserver sshd[27034]: Failed password for invalid user admin from port 44194 ssh2

and we succes to fake ip to login into a server using SSH, but our Ip still be logged in log, if we see in the red font its our IP, and the administartor of server know if our was log into his server, remeber,, use at your own risk, its only educational purpose :D



openSUSE Weekly News 189 is out!

I'm pleased to announce the openSUSE Weekly News 189.



In this Issue:

  • openSUSE Conference 2011
  • Google Summer of Code Reports
  • Sebastian Kügler: Plasma Active on OpenGL ES

You can download it there:

We hope you enjoy the reading :-)

If you want to help us collecting interesting articles for the openSUSE Weekly News, so you can all your stuff into our new ietherpad:

Found Bugs? Please place it in our Bugtracker:

Features, Ideas and Improvements can placed in our Featuretracker:

Older content can be found there.


SPI Board and Officer Elections - 2011

Software in the Public Interest (SPI) is pleased to announce the results of
the recent board and officer elections.

Board elections were held from July 14-28 2011.

The board terms of David Graham and Jimmy Kaplowitz expired at this
election. In addition one board seat was vacant at the time of the election,
for a total of three available seats. David Graham chose not to stand at
this election and has retired from the board. SPI would like to thank David
for his participation on the board from 2004 - 2011. Clint Adams, Robert
Brockway, Jimmy Kaplowitz and Trevor Walkley stood for election. Jimmy
Kaplowitz was reelected to the board and Clint Adams and Robert Brockway
were newly elected to the board. SPI would like to thank all candidates for
their participation in the election and congratulate Clint Adams, Robert
Brockway and Jimmy Kaplowitz for their election to the board.

The current directors are:

    * Bdale Garbee
    * Joerg Jaspert
    * Jonathan McDowell
    * Michael Schultheiss
    * Clint Adams
    * Robert Brockway
    * Joshua D. Drake
    * Jimmy Kaplowitz
    * Martin Zobel-Helas

Officer elections were held at the board meeting on August 10, 2011. All
existing board members were elected unopposed.

The officers for 2011-2012 are:

    * President: Bdale Garbee
    * Vice-President: Joerg Jaspert
    * Secretary: Jonathan McDowell
    * Treasurer: Michael Schultheiss

SPI associated projects include:

    * aptosid
    * Debian
    * Drizzle
    * Drupal
    * Fresco
    * Gallery
    * GNUstep
    * GNU TeXmacs
    * Jenkins
    * LibreOffice
    * OFTC
    * OpenVAS
    * Open Voting Foundation
    * Open64
    * OpenWrt
    * OSUNIX
    * Path64
    * PostgreSQL
    * Privoxy
    * The HeliOS Project
    * Tux4Kids
    * Yafaray

Software in the Public Interest, Inc. is a not-for-profit corporation under
the laws of New York State.

Read more... Comment (0)
Page 20 of 138

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board