Linux.com

Home Linux Community Forums Hardware Multimedia Sony Vaio CW - Incorporated mic doesn't work!

Sony Vaio CW - Incorporated mic doesn't work!

Link to this post 11 Feb 10

The incorporated mic in my new Sony Vaio CW doesn't works in Linux, but works well in Windows7.
I tried with Opensuse 11.2, Kubuntu Karmic, Linux Mint KDE 7 and 8, Fedora 12 KDE.

Can anyone help me?

Link to this post 12 Feb 10

well, start w/ a lshw so we can see what kind of hardware you have. The sounds card, in particular. Also, are you using ALSA or OSS? It may be something as trivial as turning up the volume of the mic in the alsa mixer.

Link to this post 12 Feb 10

from the Sony Vaio CW (not mine) with openSUSE 11.2

lshw    
sudo: lshw: command not found

lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 05ca:18b5 Ricoh Co., Ltd
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 002: ID 044e:3017 Alps Electric Co., Ltd

lspci                                                      
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation Device 0a2a (rev a2)
01:00.1 Audio device: nVidia Corporation Device 0be2 (rev a1)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. Device 4380 (rev 10)
03:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
04:00.0 SD Host controller: Ricoh Co Ltd Device e822
04:00.1 System peripheral: Ricoh Co Ltd Device e230
04:00.3 FireWire (IEEE 1394): Ricoh Co Ltd Device e832
04:00.4 SD Host controller: Ricoh Co Ltd Device e822

Link to this post 12 Feb 10

Some other details in the attached file

Link to this post 06 Mar 10

I had the similar problem with my Vaio CW. I added model toshiba-s06 in /etc/modprobe.d/sound.conf and it worked. Here is content of my sound.conf


options snd slots=snd-hda-intel
options snd-hda-intel model=toshiba-s06
alias snd-card-0 snd-hda-intel

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board