Linux.com

Apache - ModSSL (SSL Version?)

Link to this post 05 Jun 10

Does anyone know where Apache's use of SSL_VERSION_LIBRARY is defined and pulled from, in regard to headers? So far, I've tracked it down to mod_ssl. Which is fine, however, when I recompile mod_ssl with a new version of OpenSSL, and install the module, the request headers still report the old version of OpenSSL. Running strings on mod_ssl.so shows the correct version:

[modules]# strings mod_ssl.so | tail -n 1
OpenSSL 0.9.8o 01 Jun 2010

Basically, I'm trying to get Apache to use and report OpenSSL version 0.9.8o. I would like to avoid manipulating the variable from the configuration file to do so, if possible.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board