Linux.com

karmellove

karmellove

  • Linux.com Member
  • Posts: 2
  • Member Since: 23 Nov 12
  • Last Logged In: 24 Nov 12

Latest Posts

Posted by
Topic
Post Preview
Posted
  • karmellove
    RE: redhat 6.2 cluster
    Any Clue Gents?
    Link to this post 24 Nov 12

    Any Clue Gents?

  • karmellove
    redhat 6.2 cluster
    Hello Experts, Please help me with the exact steps on configuring two node cluster on RHEL 6.2, I failed to configure the simplest cluster by below steps, 1- install RHEL 6.2 64-bit on both nodes 2- add to hosts file of each server ( 1 IP in local NW and another in IP private NW). x.x.x.x node1-pub z.z.z.z node2-pub y.y.y.y node1-pvt t.t.t.t node2-pvt 3- yum install ricci ( on both nodes ) 4- yum install luci ( on 1 node ) 5- yum groupinstall "high availability" ( on both nodes ) 6- from browser, node1-pub:8084 ( login and create new cluster ) give cluster name, nodes name are (node1-pvt),(node2-pvt) 7- cluster is UP with two nodes, so far. ======================================================== Now: 8- configure failover domain and select both nodes. 9- configure resource(IP) and give IP in same range of public network. 10- configure servicegroup and assign the failover domain and the IP resource to the servicegroup. 11- IP doesn't start. ========== Nov 24 02:59:37 rgmanager start on ip "10.10.4.223/255.255.255.0" returned 1 (generic error) Nov 24 02:59:37 rgmanager #68: Failed to start service:vip; return value: 1 Nov 24 02:59:37 rgmanager Stopping service service:vip Nov 24 02:59:37 rgmanager [ip] 10.10.4.223/255.255.255.0 is not configured Nov 24 02:59:37 rgmanager Service service:vip is recovering Nov 24 02:59:38 rgmanager #71: Relocating failed service service:vip ========== from luci i get this error Starting cluster "cluname" service "vip" from node "node1-pvt" failed: vip is in unknown state 118 what did i miss? please help. thanks
    Link to this post 23 Nov 12

    Hello Experts,

    Please help me with the exact steps on configuring two node cluster on RHEL 6.2,
    I failed to configure the simplest cluster by below steps,

    1- install RHEL 6.2 64-bit on both nodes
    2- add to hosts file of each server ( 1 IP in local NW and another in IP private NW).
    x.x.x.x node1-pub
    z.z.z.z node2-pub
    y.y.y.y node1-pvt
    t.t.t.t node2-pvt

    3- yum install ricci ( on both nodes )
    4- yum install luci ( on 1 node )
    5- yum groupinstall "high availability" ( on both nodes )
    6- from browser, node1-pub:8084 ( login and create new cluster )
    give cluster name, nodes name are (node1-pvt),(node2-pvt)
    7- cluster is UP with two nodes, so far.
    ========================================================
    Now:
    8- configure failover domain and select both nodes.
    9- configure resource(IP) and give IP in same range of public network.
    10- configure servicegroup and assign the failover domain and the IP resource to the servicegroup.
    11- IP doesn't start.

    ==========
    Nov 24 02:59:37 rgmanager start on ip "10.10.4.223/255.255.255.0" returned 1 (generic error)
    Nov 24 02:59:37 rgmanager #68: Failed to start service:vip; return value: 1
    Nov 24 02:59:37 rgmanager Stopping service service:vip
    Nov 24 02:59:37 rgmanager [ip] 10.10.4.223/255.255.255.0 is not configured
    Nov 24 02:59:37 rgmanager Service service:vip is recovering
    Nov 24 02:59:38 rgmanager #71: Relocating failed service service:vip
    ==========
    from luci i get this error

    Starting cluster "cluname" service "vip" from node "node1-pvt" failed: vip is in unknown state 118

    what did i miss?

    please help.

    thanks

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board