February 25, 2017

I have a problem with Gigabit Ethernet on Forlinx i.MX6DL board with my own application in OS Linux and need your help

Forums: 

Dear all,

I'm new to OS Linux.

Resently we bought a Cortex-A9 single board computer/development board i.MX6DL from Forlinx Embedded Tech. Co., Ltd.

e65c0e31-9d38-46ae-9f9e-4e032ab1669f.jpg

The board is very nice and packed welled. We evaluated and tested the board with its original OS from Forlinx and it worked very well and we are very satisfied with both the product and their service. Then we programed and compiled our own OS Linux with our applications, but resently I got a problem that when we ping the board by a Gigabit Ethernet switch, I found that some packets lost (the Ethernet cable I use is also a Gigabit one), but before this, I ever tested our application by 100M Ethernet switch and it worked very well without any problem. I'm so curious about this. Because we'll soon have production on it, we must come up with a solution to solve the problem. Thus I asked the Forlinx techinical personal for help, they were very kind that tested their board at their side, they continue on testing it for a whole night but it works without any problem. So we doubt that the problem maybe with our application,I tried to learn about it but could not find any problem. Forlinx technical person also mention that they will keep in touch and try their best to help us to find out what caused the problem and solve it.

Kindly ask you all here who is good at OS Linux and have solution or suggestion to my problem. It will be much appreciated if who can help me to solve it so that we can step into the next production procedure.

Click Here!