March 5, 2011

NEdit and disabling auto indent

Forums: 

Heya,

Any NEdit pros out there? I have a NEdit issue and google has not helped me (rare). I checked the NEdit forum at sourceforge, but it looks inactive so I thought i'd try here. There is no NEdit users group here (first place i checked), so i created one (pending approval or something right now).

Anyway, my problem is with auto-indent. I can manually disable it via Preferences > Auto Indent > Off, but I cannot make the change persistent. If I do Preferences > Default Settings > Auto Indent > Off, the little Off radio button is checked and then I do Preferences > Save Defaults > OK and close NEdit. The next time I fire up NEdit, though, auto indent is back on. The weird thing, though, is that under Preferences > Default Settings > Auto Indent, it still reports as Off. What the dilly-o?

I tried running nedit from the command line with the -noautoindent option, too, but that does not seem to work: i still have to manually disable auto indent.

I'm on Fedora 8. I'm using nedit from nedit.org. This is the output of nedit -version:

NEdit 5.5
Sep 30, 2004

Built on: Linux, 386, GNU C
Built at: Oct 1 2004, 15:55:40
With Motif: 2.1.30 [@(#)Motif Version 2.1.30]
Running Motif: 2.1 [unknown]
Server: The X.Org Foundation 10300000
Visual: 32-bit TrueColor (ID 0x6b)
Locale: en_US

I also tried the nedit package made for Fedora 8, but it behaves exactly the same way.

I could find nothing about indent in my ~/.nedit/nedit.rc file either. Is there some X resource I can use for this?

thx,
-bill