August 23, 2009

64G ram support and i915 graphics driver



according to the following page there is a problem with highmemory support and certain intel graphic cards which also affects me. I read the page so I downloaded linux-2.6.31-rc1.tar.bz2 from then I did the following

# cd /usr/src/
# tar -xjf linux-2.6.31-rc1.tar.bz2
# cd linux-2.6.31-rc1
# make menuconfig

I navigated to "Device Drivers ---> Graphics Support ---> Support for frame buffer devices ---> " and to " Device Drivers ---> Graphics Support ---> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) ---> " but I can't see any options for

drm/i915: enable GEM on PAE.
agp: switch AGP to use page array instead of unsigned long array

Click Here!