A message for Linux.com registered users: We are in the process of making changes to the Linux forums. Starting Monday, 8/13/18 at 6:00 PM PT, you will be unable to access the forums. They will re-launch as soon as possible on Wednesday, 8/15/18 with new features and improved functionality. Thank you for your patience and stay tuned for the new improved forums.

August 15, 2009

Arch Won't Boot

Okay... Got a problem hope one of you can fix...

Hated Vista, so switched to Ubuntu, completely erasing Vista from existence. It was nice, but not quite what I wanted. So I changed to Kubuntu. Again, worked well, but not quite there. Decided to try Arch. Now I'm wishing I would've stuck with Kubuntu...

While attempting an install to my HP Pavillion dv7600, the Arch Install CD hanged. I let it work on itself for about an hour, but it did no good. Had to do a hard reboot.

Now, lo and behold, I go to start my computer and up pops the following:

Booting 'Arch Linux'

root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz26 root=/dev/disk/by-uuid/CE30-78B6 ro
[Linux-bzImage, setup=0x3600, size=0x1abaa0]
initrd /kernel126.img

Error 15: File not found

Press any key to continue...

There are three lines of code to edit, when I choose the "edit" option:

root (hd0,0)
kernel /vmlinuz26 root=/dev/disk/by-uuid/CE30-78B6 ro
initrd /kernel126.img

I only have one hard drive, so it should stay on (hd0). I have attempted to change the partitions, and received the following response:

root (hd0,1)
Filesystem type unknown, partition type 0x82
kernel /vmlinuz26 root=/dev/disk/by-uuid/CE30-78B6 ro

Error 17: Cannot mount selected partition

Press any key to continue...

This happens all the way up to partition 4, when it says "Error 22: No such partition.

I have tried to reinstall Arch, using ISO's with versions i686 and x86_64, with no luck.

I have also tried ISO's with Mint 7 and Ubuntu 9.04. Again, no joy. I even tried systemrescuecd-x86-1.2.3. Nada.

I still get that first "Error 15" screen. Arch Fallback does the same thing. I believe it is because Arch is booting to the hard drive first. That is what "initrd" is, correct? I enter BIOS at startup and changed the boot order - multiple, multiple times - and get the same "Error 15" message. I have spent about 30 hours over the past 4 days trying to fix this. Any help you can give would be appreciated. Otherwise, I am afraid I am "Fracked".

Click Here!