A message for Linux.com registered users: We are in the process of making changes to the Linux forums. Starting Monday, 8/13/18 at 6:00 PM PT, you will be unable to access the forums. They will re-launch as soon as possible on Wednesday, 8/15/18 with new features and improved functionality. Thank you for your patience and stay tuned for the new improved forums.

January 16, 2014

Black screen, blinking cursor, 'asking for cache data failed';after Ubuntu update

Hi all,
New to linux, ubuntu, and this forum.
I have enjoyed ubuntu for the past few months, but after my last update installation ubuntu would boot to a black screen and blinking cursor. If I let it sit for a while it would give the following:
12.3456789 sd 6:0:0:0 [sdb] assuming drive cache: write through
.............................asking for cache data failed
It would then repeat the lines above but the numbers would get higher.
It would never boot.

I tried a live backtrack and knoppix usbs, and when trying to access my ubuntu files I get:
THIS DIRECTORY HAS BEEN UNMOUNTED TO PROTECT YOUR DATA.

From the graphical desktop, click on:
"Access Your Private Data"

or

From the command line, run:
ecryptfs-mount-private

---
Running the above in a terminal gave me this:ERROR: Encrypted private directory is not setup properly

I would ideally want to solve this problem and boot back into ubuntu, but if not, I really want to get my files off the hard drive so I can save them before I wipe and reinstall(yes, I should have backed up:()

I have tried to edit the grub with nomodeset and rmmod the ums_realtek, and a few other things I have found with google. None have worked so far.

Any suggestions on how to get my files back or even fix this?

Thanks a million from a newbie.

Click Here!