A message for Linux.com registered users: We are in the process of making changes to the Linux forums. Starting Monday, 8/13/18 at 6:00 PM PT, you will be unable to access the forums. They will re-launch as soon as possible on Wednesday, 8/15/18 with new features and improved functionality. Thank you for your patience and stay tuned for the new improved forums.

November 6, 2015

Scanner not Detected after re-opening scanner app

Hi, been with Linux for about two weeks so still a very new newbie! I'm using Mint 17.2 and no matter what scanner program I use, they all react the same. They scan fine the first time they are run, and then if I close any scanner program and re-open it, scanner is not detected anymore. The only way I can get it to scan is to either reboot or to remove and re-insert the scanner usb cable. Any thoughts?

Should also mention that when I reboot, scanner is not detected either and so I need to remove and insert the scanner usb cable each time to be detected even by the system.

I have tried connecting the scanner cable to different usb ports and they are all 2.0. Also tried a powered usb hub, but that didn't work too.

Click Here!