A message for Linux.com registered users: We are in the process of making changes to the Linux forums. Starting Monday, 8/13/18 at 6:00 PM PT, you will be unable to access the forums. They will re-launch as soon as possible on Wednesday, 8/15/18 with new features and improved functionality. Thank you for your patience and stay tuned for the new improved forums.

February 18, 2013

SuperMicro X7DAL-E Motherboard, want Ubuntu on it

Hello future friends!

I plan on sticking around on this site for a very long time.

I recently encountered Linux Ubuntu and I am in love! I also love how much helpful information there is out there, and how helpful the community is out there as well!

Now here's the problem: I format a partition using Ubuntu, I install Ubuntu onto that partition, Ubuntu tells me that it's been successfully installed. However, when I re-boot, it won't boot from HDD.

I've messed around a bunch in the BIOS changing boot order, etc., so we can rule that out.

I'm pretty sure I know what the problem is; there's some Intel 5000x chipset driver update I need in order to boot from a partition on an HDD. Here's how I know this:

The first attempt at installing Ubuntu did what I said earlier; said installation was successful, so I take out the CD, I re-boot the system, and I get the message "No Operating System Found."

I talked to someone who knows computers better than most anyone on the planet (...his first PC was a Commodore 64, and he's been a daily PC user since 1979.) and he told me that the problem is the Intel(R) 5000x Chipset driver needs to be installed onto the system in order for it to be able to boot up.

So, he told me I should install Windows 7 first, along with the drivers, and run Ubuntu as a virtual machine within Windows. So, begrudgingly, I attempted just that. Windows 7 would allow me to get to the screen where you can install drivers. I put them onto a bootable flash drive, selected all of them, and after about half an hour, some windows pop up saying that so-and-so driver didn't install correctly. So I click and say "OK" to each of those pop-ups. At no point does it actually say that the drivers were installed.

Well, it wouldn't let me move on to the next area where I actually install windows. So, after letting it sit overnight running, still no change. I decide to re-boot, without the Windows disk. And guess what? The Ubuntu that I had installed now works!

So, my guess is that I somehow managed to install the necessary Intel(r) 5000x chipset drivers, without actually fully installing Windows.

I thought, "Great!" But then comes along another problem; I had installed the 32-bit version!

I know that 32 will work on both 32 and 64-bit machines, but man, this is a server board made into a personal computer. It has TWO CPUs, both of which are Xeon Dual-Core 3.0 Ghz. This is one serious machine that I acquired, and as such, I most certainly want to be using it with a 64-bit OS.

So, I delete everything that I had installed, tried to just install the 64-bit OS, and now I'm right back where I started.

You might be thinking, "Well, yeah, stupid, you deleted the drivers making all your previous work wasted!"

Well, that's true, but the reason why I went ahead and deleted everything and started over was because - before I half-installed Windows 7 with the 5,000x chipset drivers - I ALSO flashed the BIOS. So, I was thinking that it was the updated BIOS that allowed the Ubuntu OS to work, not the drivers that were somehow installed onto the HDD, even though the Win 7 installation was incomplete.

So, now that you guys have all of that background information available, what do you suggest I do?

I ultimately want Ubuntu, because it's design is pretty much ideal for what I want to be doing with the computer. I do also want to install Windows 7 on it, and have a multi-boot machine.

At the moment though, I'm dead in the water and don't know what to do.

Can someone point me in the right direction?

I was thinking, maybe I can boot Ubuntu 64-bit from CD, then while connected to the Web, install the necessary drivers. I assume there's a way to do this from the Terminal screen, but I don't know.

What should I do, guys and gals?

I hope you guys can help me, as I'd love to become an advanced user of Linux someday.

All the best folks,


PS: Let me know if there's any other information you need. If it matters; yes, the HDD is Serial ATA. The Optical Drive I'm not sure of, let me check... ok yeah, the optical drive is also SATA. The motherboard once again is a SuperMicro X7DAL-E+ with two Intel(R) Xeon 3.0 Ghz CPUs. Also, I've tried multiple HDDs. I'm just about 100% positive this is a driver issue.

Click Here!