A message for Linux.com registered users: We are in the process of making changes to the Linux forums. Starting Monday, 8/13/18 at 6:00 PM PT, you will be unable to access the forums. They will re-launch as soon as possible on Wednesday, 8/15/18 with new features and improved functionality. Thank you for your patience and stay tuned for the new improved forums.

December 5, 2011

boot from raid1 with mdadm. Opensuse 11.4


i have a problem - due to installation opensuse 11.4 x64 on ASUS motherboard with raid1 (manufacturer jmicron) i turned on raid support, i tried to boot from grub many times, and at last it works!
BUT now every time i boot mdadm give me an error and asks me if it could fall back to right preferences. It tries to create an raid device with incorrect UUID (it has "part1" on its end, why?) and then he wants to boot from /dev/md125p1 and its works.
I tried to configure /etc/mdadm.conf many times, but i have a feeling that mdadm wroks as a kernel module and it has another .conf file.

Please help me, its a server without any keyboard, so i must take this one from another computer when it boots and press "Y". Im sooo lazy, i know

Click Here!