May 18, 2009

Error 18 with grub 0.97

Forums: 

Hi Folks,

I've just installed ubuntu 9.04 for my mum, having spent a good couple of years pulling her in the right direction by getting her to use Open Source apps on Windows, but every second (or so) boot I get the dreaded 'Error 18'.

I refuse to believe the BIOS is old enough to suffer the 'trying to put executable code >1023 cylinders' problem, and there's no option to use anything freaky like Bit-Shifting, which seems to me that it's using (normal) LBA translation.

The board she's now using was working fine with grub installed after an 80GB Windows 7 partion (yeah, i know, but we have to know what to expect before the lusers get hold of it...) on a SATA disc, proving that it's not a >1023cyls problem.

I know grub in ubuntu has been updated recently, and i was wondering if anyone else is seeing this problem in other recent distros. It is reporting itself as being version 0.97.

It's an old PATA disk in the machine now, but surely this shouldn't matter as it's still disk 0x80 (and it wouldn't have got that far if that was the problem - only one disk in there anyway!) ?

Also, the ext3 is the first partition on the disk too.

This is an unfortunate show stopper for someone who is not technical at all (she will have to keep powring off and on the machine until it actually boots!), and potentially a huge barrier to getting folks on the platform :(