January 16, 2015

Issue in updating the apache httpd rpm from PHP UI

Forums: 

Hi All,

We have a requirement of upgrading apache httpd version from 2.2.15 to 2.2.15-39 for fixing a vulnerability issue. We are using PHP User interface which runs an upgrade process using yum command (yum -y install $Udir/*.rpm) to install the RPMs.

When we run the upgrade which have the yum command for upgrading the apache httpd version through user interface, the yum command is executed to install the apache httpd-rpm and when it is in progress the apache service is restarted which in turn changes the process ID for httpd and which affects the user interface which owns this process and it hangs the User Interface in between of the upgrade. It is also not possible to restart the httpd service at last of upgrade as the yum command itself is restarting the httpd apache service after installing the RPM.

Basically some control is required for yum command which restricts the httpd service to be restarted later. If anyone has faced the similar issue, please share your views on same.

Thanks,

Click Here!