January 9, 2011

Untraceable problem with minicom

Forums: 

Dear all,

I am facing an untraceable problem with minicom. Allow me to provide proper details so that it will be easier to provide assistance.

I am using a desktop PC with Ubuntu 10.10. It has only one serial port (ttyS0) and I have verified that using the command " dmesg | grep tty ".

My development board is called HDP6410, which is a clone of the SMDK6410. The processor is S3C6410 with ARM 1176 JZ(F)-S core. After I start minicom, when I connect the board to the pc using a null-modem cable and power up the board I am supposed to see booting updates on minicom, followed by a prompt that would allow me to access the board. However, I do not see anything. I know that the serial port on the pc and the serial cable are fully functional because I do get all the booting updates and prompt when I use a custom serial communication software provided with the board. However, I want to use minicom because the custom software provides no means of transferring files.

I added my username to the following groups : dialout, uucp and tty.

I have also checked that ttyS0 has read/write permissions.

My settings in minicom are as follows:

Serial Device : /dev/ttyS0
Lockfile Location : /var/lock
Bps / Par / Bits : 115200 8N1
hardware flow control : no
software flow control : no

I have tried running minicom both as normal user and root, but I still get no output on the console when I power up the board. I know for sure that the serial port on the board is working fine and it does send messages once I power up the board. Something is wrong on the PC side. For some reason when I run minicom, the connection is probably not established on the PC side.

Am I missing any essential configurations / settings ?

I would highly appreciated some guidance on this. I have been trying for a week now without any positive result. Please help.

Sincerely,
Shan

Click Here!