March 23, 2016

Lab 40.1 - any ideas how to install firewalld package on Debian-based systems?

Hi everyone,

Greetings from Poland :-)

I using a Debian on raspberry Pi as well as Ubuntu Desktop. No possible to install firewalld properly on both ones so far. I tried according Lab instructions and Internet:

./configure fails because of glib-compile-schemas is missing. I looked for a solutions on the Internet. I found that I need a libgtk2.0-dev. Once this installed, I tried ./configure again. I've got an error that intltool is too old. Ok, I installed it again as apt-get install intltool. After that ./configure ends without errors. So, I moving right along, I typed make and another problem has been occured: make: *** [all-recursive] Error 1.

Does anybody install firewalld package on Ubuntu or other Debian-based system? Or perhaps it would be better using CentOs 7 for this exerise. And what about an exam? I declared an Ubuntu as desired distribution. Will I have to install a firewalld package?

Thank you.

Click Here!