June 13, 2017

Lab 4 not quite working - cant add data

Hi all,

I have managed to get the Roster. jar file onto PWS and it seems to be working fine. However in Lab 4 we are asked to add data to the application. I have tried the following and it is returning an error. I am trying this through a Windows Command prompt. I think the issue is to do with the PATH. I have tried all the following:

https:\\roster-beauish-gesticulator.cfapps.io OR




C:\Users\PG\CF>cf app roster
Showing health and status for app roster in org xxxxx / space development as xxxxxxxxxxxxx


requested state: started
instances: 1/1
usage: 1G x 1 instances
urls: roster-beauish-gesticulator.cfapps.io
last uploaded: Tue Jun 13 10:50:14 UTC 2017
stack: cflinuxfs2
buildpack: container-certificate-trust-store=2.0.0_RELEASE java-buildpack=v3.15-offline-https://github.com/cloudfoundry/java-buildpack.git#a3a9e61 java-main open-jdk-like-jre=1.8.0_121 open-jdk-like-memory-calculator=2.0.2_RELEASE spring-auto-reconfiguration=1.10...

     state     since                    cpu    memory         disk           details
#0   running   2017-06-13 11:51:37 AM   0.5%   567.2M of 1G   154.7M of 1G

C:\Users\PG\CF>cf curl "roster-beauish-gesticulator" -H "Content-Type: application/json" -X POST -d "{"firstName":"foo", "lastName": "bar"}"
   "description": "Unknown request",
   "error_code": "CF-NotFound",
   "code": 10000

Click Here!