October 31, 2016

Lab 8.1 Task 4 Error during packstack installation

I got the error in the LAB environment:

openstack-setup.log

PuppetError: Error appeared during Puppet run: 192.168.98.1_amqp.pp
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install erlang' returned 1: Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
You will find full trace in log /var/tmp/packstack/20161031-093630-LCKvHY/manifests/192.168.98.1_amqp.pp.log

192.168.98.1_amqp.pp.log

^[[mNotice: Compiled catalog for rdo-cc in environment production in 0.75 seconds^[[0m
^[[1;31mError: Execution of '/usr/bin/yum -d 0 -e 0 -y install erlang' returned 1: Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_xrc-3.0.so.0(WXU_3.0)(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_baseu-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_gl-3.0.so.0(WXU_3.0)(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_xrc-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_baseu_xml-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_html-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_stc-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_baseu-3.0.so.0(WXU_3.0)(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_aui-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_stc-3.0.so.0(WXU_3.0)(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_adv-3.0.so.0(WXU_3.0)(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_html-3.0.so.0(WXU_3.0)(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_core-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_adv-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_gl-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_core-3.0.so.0(WXU_3.0)(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_aui-3.0.so.0(WXU_3.0)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest^[[0m
^[[1;31mError: /Stage[main]/Main/Enable_rabbitmq[rabbitmq]/Package[erlang]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install erlang' returned 1: Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_xrc-3.0.so.0(WXU_3.0)(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_baseu-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_gl-3.0.so.0(WXU_3.0)(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_xrc-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_baseu_xml-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_html-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_stc-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_baseu-3.0.so.0(WXU_3.0)(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_aui-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_stc-3.0.so.0(WXU_3.0)(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_adv-3.0.so.0(WXU_3.0)(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_gl-3.0.so.0()(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_core-3.0.so.0(WXU_3.0)(64bit)
Error: Package: erlang-wx-18.3.4.4-1.el7.x86_64 (openstack-liberty)
           Requires: libwx_gtk3u_aui-3.0.so.0(WXU_3.0)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest^[[0m
^[[mNotice: /Stage[main]/Rabbitmq/Anchor[rabbitmq::begin]: Dependency Package[erlang] has failures: true^[[0m
^[[1;31mWarning: /Stage[main]/Rabbitmq/Anchor[rabbitmq::begin]: Skipping because of failed dependencies^[[0m
^[[mNotice: /Stage[main]/Rabbitmq::Install/Package[rabbitmq-server]: Dependency Package[erlang] has failures: true^[[0m
^[[1;31mWarning: /Stage[main]/Rabbitmq::Install/Package[rabbitmq-server]: Skipping because of failed dependencies^[[0m
^[[mNotice: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq]: Dependency Package[erlang] has failures: true^[[0m
^[[1;31mWarning: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq]: Skipping because of failed dependencies^[[0m
^[[mNotice: /Stage[main]/Rabbitmq::Config/File[rabbitmq.config]: Dependency Package[erlang] has failures: true^[[0m
^[[1;31mWarning: /Stage[main]/Rabbitmq::Config/File[rabbitmq.config]: Skipping because of failed dependencies^[[0m
^[[mNotice: /Stage[main]/Rabbitmq::Config/File[/etc/systemd/system/rabbitmq-server.service.d]: Dependency Package[erlang] has failures: true^[[0m
^[[1;31mWarning: /Stage[main]/Rabbitmq::Config/File[/etc/systemd/system/rabbitmq-server.service.d]: Skipping because of failed dependencies^[[0m
^[[mNotice: /Stage[main]/Rabbitmq::Config/File[/etc/systemd/system/rabbitmq-server.service.d/limits.conf]: Dependency Package[erlang] has failures: true^[[0m
^[[1;31mWarning: /Stage[main]/Rabbitmq::Config/File[/etc/systemd/system/rabbitmq-server.service.d/limits.conf]: Skipping because of failed dependencies^[[0m
^[[mNotice: /Stage[main]/Rabbitmq::Config/Exec[rabbitmq-systemd-reload]: Dependency Package[erlang] has failures: true^[[0m
^[[1;31mWarning: /Stage[main]/Rabbitmq::Config/Exec[rabbitmq-systemd-reload]: Skipping because of failed dependencies^[[0m
^[[mNotice: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq/ssl]: Dependency Package[erlang] has failures: true^[[0m
^[[1;31mWarning: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq/ssl]: Skipping because of failed dependencies^[[0m
^[[mNotice: /Stage[main]/Rabbitmq::Config/File[/etc/security/limits.d/rabbitmq-server.conf]: Dependency Package[erlang] has failures: true^[[0m
^[[1;31mWarning: /Stage[main]/Rabbitmq::Config/File[/etc/security/limits.d/rabbitmq-server.conf]: Skipping because of failed dependencies^[[0m
^[[mNotice: /Stage[main]/Rabbitmq::Config/File[rabbitmq-env.config]: Dependency Package[erlang] has failures: true^[[0m
^[[1;31mWarning: /Stage[main]/Rabbitmq::Config/File[rabbitmq-env.config]: Skipping because of failed dependencies^[[0m
^[[mNotice: /Stage[main]/Rabbitmq::Service/Service[rabbitmq-server]: Dependency Package[erlang] has failures: true^[[0m
^[[1;31mWarning: /Stage[main]/Rabbitmq::Service/Service[rabbitmq-server]: Skipping because of failed dependencies^[[0m
^[[mNotice: /Stage[main]/Rabbitmq/Anchor[rabbitmq::end]: Dependency Package[erlang] has failures: true^[[0m
^[[1;31mWarning: /Stage[main]/Rabbitmq/Anchor[rabbitmq::end]: Skipping because of failed dependencies^[[0m
^[[mNotice: Finished catalog run in 2.46 seconds^[[0m

Can someone help who I resolve the dependencies in the LAB environment?

 

Regards

Andreas

Click Here!