March 8, 2017

LSF252 - Devstack stack.sh fails - Lab 2.1

Hello, I'm receiving the error below after creating the local.conf file and executing the script stack.sh.

 

2017-03-08 14:51:22.289 | setuptools must be installed to install from a source distributio
n
2017-03-08 14:51:22.762 | You are using pip version 7.1.2, however version 9.0.1 is availab
le.
2017-03-08 14:51:22.762 | You should consider upgrading via the 'pip install --upgrade pip'
 command.
2017-03-08 14:51:22.800 | + exit_trap
2017-03-08 14:51:22.800 | + local r=1
2017-03-08 14:51:22.801 | ++ jobs -p
2017-03-08 14:51:22.802 | + jobs=
2017-03-08 14:51:22.802 | +
2017-03-08 14:51:22.802 | + kill_spinner
2017-03-08 14:51:22.802 | + '[' '!' -z '' ']'
2017-03-08 14:51:22.802 | +
2017-03-08 14:51:22.802 | + echo 'Error on exit'
2017-03-08 14:51:22.802 | Error on exit
2017-03-08 14:51:22.802 | + generate-subunit 1488984645 37 fail
2017-03-08 14:51:22.803 | ./stack.sh: line 462: generate-subunit: command not found

 

What to do?

Thanks

Click Here!