November 3, 2016

Task 2: Deploy a Monitor step 2

When attempting to yum install ceph-deploy I receive the error "Package python-setuptools-0.9.8-4.el7.noarch is obsoleted by python2-setuptools-22.0.5-1.el7.noarch which is already installed"

How can I resolve this? Uninstalling teh current Python2-setuptools and installing the tool that is requested?  --skip-broken and rpm -Va --nofiles --nodigest did not resolve the issue

 

 

[ceph@rdo-cc ceph-cluster]$ sudo yum -y install ceph-deploy
Loaded plugins: fastestmirror, langpacks, priorities
Loading mirror speeds from cached hostfile
 * base: mirror.rackspace.com
 * epel: fedora-epel.mirror.lstn.net
 * epel-debuginfo: fedora-epel.mirror.lstn.net
 * epel-source: fedora-epel.mirror.lstn.net
 * extras: repos.dfw.quadranet.com
 * updates: mirrors.advancedhosters.com
Resolving Dependencies
--> Running transaction check
---> Package ceph-deploy.noarch 0:1.5.36-0 will be installed
--> Processing Dependency: python-distribute for package: ceph-deploy-1.5.36-0.noarch
Package python-setuptools-0.9.8-4.el7.noarch is obsoleted by python2-setuptools-22.0.5-1.el7.noarch which is already installed
--> Finished Dependency Resolution
Error: Package: ceph-deploy-1.5.36-0.noarch (ceph-noarch)
           Requires: python-distribute
           Available: python-setuptools-0.9.8-4.el7.noarch (base)
               python-distribute = 0.9.8-4.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

 

Click Here!