March 5, 2018

Lab 7.1 ,7.2 and 7.3

With the new labs version (2018-02-15) , in the lab 7.1 and 7.2 using the sample files rs.yaml and ds.yaml .

Firs question why are we using apiVersion: extensions/v1beta1?

Notice that on Lab7.1 , Step 10 there is a typo pod edition is requested to "IsolatedPod", later step 12 "isolated" is shown and step 15 "isolated" label is used.

 

Regarding Lab 7.2, this was the edit used ds.yaml file.

joaocfernandes@master-node:~$ cat ds.yaml 
apiVersion: extensions/v1beta1
kind: DaemonSet
metadata:
  name: rs-one
spec:
  replicas: 2
  template:
    metadata:
      labels:
        system: DaemonSetOne
    spec:
      containers:
      - name: nginx
        image: nginx:1.7.9
        ports:
        - containerPort: 80
joaocfernandes@master-node:~$ kubectl create -f ds.yaml 
error: error validating "ds.yaml": error validating data: ValidationError(DaemonSet.spec): unknown field "replicas" in io.k8s.api.extensions.v1beta1.DaemonSetSpec; if you choose to ignore these errors, turn validation off with --validate=false

 

I can't create the DaemonSet with this YAML, although I could and tried with the one provided in https://kubernetes.io/docs/concepts/workloads/controllers/daemonset/ .

This also affects directly the lab 7.3 which I cannot do.

 

Best Regards,

João

Click Here!