September 8, 2015

Need help with HDMI signale (amp+tv)

Forums: 

Hi,

I'm actually using Ubuntu 14.04 on my HTPC.
Sadly, I've got a problem which I'm not able to fix by myself.
My HTPC is connected to my AMP (Denon AVR-1912). My TV (Samsung Smart TV) is also connected to the AMP.

When I turn on everything with my remote, everything works fine (all at the same time).
If I add a timer for my PVR in the future, the HTPC turns on by RTC and record the timer.

Now to my problem:
If a record is running and just the HTPC is running and I turn on my AMP and the TV, I don't get a picture.
It seems, that the AMP/HTPC handshake (concerning the resolution) is not working.

As desktop I'm using lightdm for Kodi.
Could please someone help me? I also tried a solution with udevadm monitor, which was not working.
In addition I also tried a grub parameter with EDID, which is also not working:

root@xbmc:~# for f in /sys/class/drm/card*; do echo $f && cat $f/enabled; done
/sys/class/drm/card0
cat: /sys/class/drm/card0/enabled: No such file or directory
/sys/class/drm/card0-HDMI-A-1
disabled
/sys/class/drm/card0-HDMI-A-2
enabled
/sys/class/drm/card0-VGA-1
disabled
root@xbmc:~# sudo mkdir -p /lib/firmware/edid
root@xbmc:~# sudo cp /sys/class/drm/card0-HDMI-A-2/edid /lib/firmware/edid/edid.bin

root@xbmc:~# grep edid /etc/default/grub
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1 acpi_enforce_resources=lax drm_kms_helper.edid_firmware=HDMI-A-2:edid/edid.bin video=HDMI-A-2:e"
root@xbmc:~# update-grub

Might this is helping. This is the output from udevadm monitor when the AMP turns on:

Code:
root@kodi:~# udevadm monitor
monitor will print the received events for:
UDEV - the event which udev sends out after rule processing
KERNEL - the kernel uevent

KERNEL[1011.301987] change /devices/pci0000:00/0000:00:02.0/drm/card0 (drm)
UDEV [1011.302552] change /devices/pci0000:00/0000:00:02.0/drm/card0 (drm)
KERNEL[1011.329056] add /devices/platform/HDMI-A-2 (platform)
UDEV [1011.329346] add /devices/platform/HDMI-A-2 (platform)
KERNEL[1011.330344] remove /devices/platform/HDMI-A-2 (platform)
UDEV [1011.330470] remove /devices/platform/HDMI-A-2 (platform)
KERNEL[1011.393123] add /devices/platform/HDMI-A-2 (platform)
KERNEL[1011.393188] remove /devices/platform/HDMI-A-2 (platform)
UDEV [1011.393301] add /devices/platform/HDMI-A-2 (platform)
UDEV [1011.393730] remove /devices/platform/HDMI-A-2 (platform)

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 32767 x 32767
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
1920x1080 60.0*+ 50.0 59.9 30.0 25.0 24.0 30.0 24.0
1920x1080i 60.1 50.0 60.0
1680x1050 59.9
2880x576 50.0
1600x900 60.0
2880x480 60.0 59.9
1280x1024 75.0 60.0
1440x900 59.9
1366x768 59.8
1280x800 59.9
1152x864 75.0
1280x720 60.0 50.0 59.9
1440x576 50.0
1440x576i 50.1
1024x768 75.1 70.1 60.0
1440x480 60.0 59.9
1440x480i 60.1 60.1
832x624 74.6
800x600 72.2 75.0 60.3
720x576 50.0
720x480 60.0 59.9
640x480 75.0 72.8 66.7 60.0 59.9
720x400 70.1
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

I would really appreciate if someone could finally help me to solve this problem.
Thanks in advance.

Click Here!