A message for Linux.com registered users: We are in the process of making changes to the Linux forums. Starting Monday, 8/13/18 at 6:00 PM PT, you will be unable to access the forums. They will re-launch as soon as possible on Wednesday, 8/15/18 with new features and improved functionality. Thank you for your patience and stay tuned for the new improved forums.

November 27, 2015

Can't get Atheros USB wifi adapter to work on Linux Mint 17.2

Forums: 

Hi,

I've used windows for almost 20 years, but am considering moving to linux. I wanted to play around with it so I installed Mint 17.2 32 bit w/Xfce desktop on an old Dell Inspiron 1520 laptop. The laptop stopped recognizing its onboard wifi card a couple of years ago (while still a windows machine) but has worked fine with a USB adapter since then. However, now that I've installed Mint I can't get the adapter to work, I can't even get the computer to detect it.

I've read through quite a lot of similar situations online and tried to take the steps that others took, but I can't get it to work. Actually, the very first distro I installed was Mint 17.2 Cinnamon 64 bit (uninstalled because computer wasn't powerful enough), and I did somehow get the adapter to work, but (as ridiculous as this will sound) didn't realize it at the time and I tried quite a lot of things, so I'm not sure what actually worked. The good news is, the port will currently recognize a USB flash drive, the wifi adapter will work in another machine, and as I just said, I was able to get it to work once, so I would think all the hardware is ok.

The adapter is pretty old, it has the Atheros AR5007 chipset, which (from what I read) I think requires the ZD1211 driver. I checked the firmware folder and it's in there, but that doesn't seem to help. When I enter lsusb and lspci the device doesn't show up. I've tried various other things, including ndiswrapper, to no avail. If anyone has any ideas on how I might get this to work I would greatly appreciate it.

Thanks,

Scott

Click Here!