A message for Linux.com registered users: We are in the process of making changes to the Linux forums. Starting Monday, 8/13/18 at 6:00 PM PT, you will be unable to access the forums. They will re-launch as soon as possible on Wednesday, 8/15/18 with new features and improved functionality. Thank you for your patience and stay tuned for the new improved forums.

November 19, 2013

Unable to connect Wireless


I have managed to install Broadcom BCM43228 Wireless adapter on a laptop running CentOS 5.9 using instructions at:

I had the problem "Error for wireless request "Set Encode" (8B2A): SET failed on device... mentioned on the same page and solved it following the instructions at:

After reboot the NetworkManager is enabled showing all the available networks. However, with regular user the request for default keyring password was popping-up again and again and was not accepting any password. I logged in as root and was able to set the keyring password.
When I select the network from drop down menu of NetworkManager a pop-up shows up asking for:
Authentication required by Wireless Network
Password or encryption keys are required to access the wireless network 'blade'
Wireless security: WPA & WPA Personal

It fails to connect even I verified the SSID and password is correct which works fine under Windows 7.

I have also tried to configure system-config-network GUI but unable to activate the wireless adapter (eth1) and cannot File->Save the setting with the following error:
Component: system-config-network
Summary: TBf6c835f4 NCHardwareList.py:482:save:AttributeError: HwWireless instance has no attribute 'type' ...

I also found the following link and now confused (establish a Wifi connection at system startup (without login)...). Do I need to use wpa_supplicant or NetworkManager?

Can anyone please help to resolve this issue.

Click Here!