November 23, 2013

Wireless Network Configuration?

Forums: 

The network connection icon on the top right corner shows "no network connection" but I can see all the available wireless networks. With this I assume that driver is working fine and wireless connectivity is available without access point connectivity. Here is the output for iwconfig eth1
eth1 IEEE 802.11abgn ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate=144 Mb/s Tx-Power:24 dBm
Retry min limit:7 RTS thr:off Fragment thr:off
Power Managementmode:All packets received
Link Quality=5/5 Signal level=-256 dBm Noise level=-90 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Then I assume it is the problem of network configuration. When I right click to Edit Connections... there are 3 tabs available for the selected connection: Wireless, Wireless Security and IPv4 Setting. The Connect automatically option is selected and for the Wireless tab I have set the SSID and Mode: Infrastructure. The security in Wireless Security tab is set to WPA & WPA2 Personal and the password is set. For IPv4 Setting tab Method: Automatic (DHCP) is set. With this configuration when I apply to connect it asks again and again for "Authentication required by wireless network" with WPA & WPA2 Personal and password information but failed to connect. The configuration files looks like this:

/etc/sysconfig/network-scripts/ifcfg-eth1
# Broadcom Corporation BCM43228 802.11a/b/g/n
DEVICE=eth1
BOOTPROTO=dhcp
ONBOOT=no
HWADDR=08:ed:b9:e1:4e:ec

/etc/sysconfig/network
NETWORKING=yes
NETWORKING_IPV6=yes
HOSTNAME=localhost.localdomain

/etc/resolv.conf
# No nameservers found; try putting DNS servers into your
# ifcfg files in /etc/sysconfig/network-scripts like so:
#
# DNS1=xxx.xxx.xxx.xxx
# DNS2=xxx.xxx.xxx.xxx
# DOMAIN=lab.foo.com bar.foo.com

I had disabled the SELinux and Firewall since SELinux was preventing NetworkManager (NetworkManager_t) "execute" to ./dnsmasq (dnsmasq_exec_t).

Another issue is that when I try to save the Network Configuration (System->Administrator->Network) after editing the wireless device configuration it exits with an unhandled exception...
Component: system-config-network
Version: 1.3.99.21
Summary: TBf6c835f4 NCHardwareList.py:482:save:AttributeError: HwWireless instance has no attribute 'type'...
Also I don't know what to set in Wireless Settings tab of wireless device configuration if I will be able to save it.

With Windows 7 on the same system (dual boot) I have absolutely no issue in wireless connectivity with the following settings.
IPv4 connectivity, Access Point, Security type: WPA2-Personal and Encryption: AES

Please help to configure the wireless connection. Thanks.