A message for Linux.com registered users: We are in the process of making changes to the Linux forums. Starting Monday, 8/13/18 at 6:00 PM PT, you will be unable to access the forums. They will re-launch as soon as possible on Wednesday, 8/15/18 with new features and improved functionality. Thank you for your patience and stay tuned for the new improved forums.

September 17, 2017

Trying to RDP to Centos 7

Forums: 

Hello!

I'm trying to use xrdp on my CentOS 7 from my windows 10 but can't connect.

I installed xrdp - yum install xrdp

That worked fine. But when starting RDP on the Windows machine and putting in the IP, I get:

Remote Desktop can't connect to the remote computer for one of these reasons:
1) Remote access to the server is not enabled
2) The remote computer is turned off
3) The remote computer is not available on the network

Make sure the remote computer is turned on and connected to the network, and that remote access is enabled

 

Remote Access Not enabled seems like the most likely issue to me but I don't seem to be able to find much on that. 

Turned off the firewall: systemctl stop firewalld.service

No luck. Turned the firewall back on.

Tested RDP from my windows 10 to my windows 7 machine and that worked.

Thanks for any help!

Click Here!