A message for Linux.com registered users: We are in the process of making changes to the Linux forums. Starting Monday, 8/13/18 at 6:00 PM PT, you will be unable to access the forums. They will re-launch as soon as possible on Wednesday, 8/15/18 with new features and improved functionality. Thank you for your patience and stay tuned for the new improved forums.

August 25, 2010

Xsane Problem: Recognizes Webcam as Scanner (?)

Due to a sale at my university's computer store, I decided to purchase a new HP Deskjet F4480 all-in-one unit. I have tested its printing abilities and it works remarkably well in Ubuntu 10.04 x86_64. However, the scanning function is malfunctioning and I know that it is not a hardware issue.

I have found that I have been able to scan documents with other HP models via Trisquel (the FSF's answer to Ubuntu) within VirtualBox. My theory is that there is something wrong with my build of SANE and/or Xsane and have tried compiling the former from source to fix my problem.

Every time I run "sane-find-scanner", I get the following output in my terminal:

device `v4l:/dev/video0' is a Noname BisonCam, NB Pro virtual device

When I run lsusb, it displays Bus 001 Device 015: ID 03f0:7711 Hewlett-Packard

Does anyone know how I can 1.) disable my webcam as being recognized as my scanner, and 2.) how to get my scanner functioning properly in Ubuntu 10.04?

Thank you to anyone in advance for helping me out with this predicament.

Click Here!