A message for Linux.com registered users: We are in the process of making changes to the Linux forums. Starting Monday, 8/13/18 at 6:00 PM PT, you will be unable to access the forums. They will re-launch as soon as possible on Wednesday, 8/15/18 with new features and improved functionality. Thank you for your patience and stay tuned for the new improved forums.

May 14, 2015

Puppet - mySQL not remotely accessible upon setup (workbench)

I used Puppet's mySQL module to bring it up like this.

The workstation ip is 172.16.1.49 and JIRA(mySQL) VM is 172.16.1.47 (Puppet Master is 172.16.1.80);

I'm trying to access mySQL server using workbench mySQL client tool from workstation 172.16.1.49 (hence @172.16.1.49 in the grant).

Usually I know I can remotely access if I can view htp:/172.16.1.47:3306 on the browser.
On mySQL VM, if I do htp:/localhost:3306, I see some messages that means I can access the mySQL server. But htp:/172.16.1.47:3306 on itself doesn't work either.

Where the heck in my Puppet for mySQL code, did I mess up? I think somewhere in my puppet code, I am not allowing mySQL server to allow remote access.

class { '::mysql::server':
root_password => 'secret',
remove_default_accounts => true,
override_options => $override_options
}

::mysql::db { 'mydb':
user => 'jira',
password => 'secret',
dbname => 'jiraDB',
host => 'localhost',

}

mysql_grant { 'jira@localhost/*.*':
ensure => 'present',
options => ['GRANT'],
privileges => ['ALL'],
table => '*.*',
user => 'jira@localhost' ,
}

mysql_grant { 'jira@172.16.1.49/*.*':
ensure => 'present',
options => ['GRANT'],
privileges => ['ALL'],
table => '*.*',
user => 'jira@172.16.1.49' ,
}

mysql_grant { 'root@172.16.1.49/*.*':
ensure => 'present',
options => ['GRANT'],
privileges => ['ALL'],
table => '*.*',
user => 'root@172.16.1.49' ,
}

Click Here!