October 23, 2010

SMTP (smtp.domain.com), POP3 (mail.domain.com), MX

So help me put this into perspective.

SMTP is used to send mail from the inside of the company out to people on the Internet.
POP3 (often mail.domain.com) is used to receive mail from the people on the internet.
MX is used for... ??? Is it supposed to be the same as mail.domain.com or smtp.domain.com or what? =(

I have three servers (all in the same LAN, and all Linux).
The first two have public Internet IPs (static).
The third one cannot be communicated with from the Internet (no WAN static IP).

The first server receives and sends to the second server.
The second server sorts and forwards to the third server.
Third server ultimately delivers the mail to the employees.
(Or at least I think this is how it is setup.)

When I send an e-mail from the inside to myself, it says it's coming from the second server.

When I set smtp/mail.domain to the first server, and the MX to the first server, and I send an e-mail from the Internet to a company employee, I will get a reply back from the first server with this:

The original message was received at Fri, 22 Oct 2010 21:54:52 -0500
from mail-iw0-f178.google.com [209.85.214.178]

----- The following addresses had permanent fatal errors -----

(reason: 553 5.3.5 system config error)

----- Transcript of session follows -----
553 5.3.5 mail2.company.com. config error: mail loops back to me (MX problem?)
554 5.3.5 Local configuration error

The original message was received at Fri, 22 Oct 2010 21:55:41 -0500
from mail-vw0-f50.google.com [209.85.212.50]

----- The following addresses had permanent fatal errors -----

(reason: 553 5.3.5 system config error)

(reason: 553 5.3.5 system config error)

(reason: 553 5.3.5 system config error)

----- Transcript of session follows -----
554 5.3.5 Local configuration error

When I set smtp/mail.domain to the first server, and the MX to the second server, and I send an e-mail from the Internet to a company employee, I will receive no responses (nothing happens).

There is a private address that can only be accessed from the inside of the company that takes the employee to Squirrel Mail login (there are no public DNS records for this, so I assume one of the servers is acting as an inside DNS as far as this goes): intmail.company.com. When I ping it, the WAN static IP of the second server is what I get.

There is one employee who uses Outlook; everyone else must use Squirrel Mail. This employee is the CEO. His Outlook is setup to receive and send mail to/from the second server (by its internal LAN IP) on IMAP.

Please help me. :(

EDIT: Some DNS stuff on the company.com domain..

www A 3600
@ A 3600
* A 3600
mail2.company.com A 3600
server1.company.com A 3600

server2.company.com CNAME 3600 www.company.com
mail.company.com CNAME 3600
smtp.company.com CNAME 3600

MX 3600 10

Click Here!