Linux.com

Home Linux Community Forums Linux Distributions Fedora Terminal/Shell autofill is not working

Terminal/Shell autofill is not working

Link to this post 25 Jan 12

Hi,

I have 2 problems in Fedora 16,

1. The autofill property is not working always in Terminal.No response for the tab key. But, the file starting with the characters I am trying is exist in that dir level.
Very often it is happening. Opening a new terminal some times fix the problem .

2. When I do shutdown using, "shutdown -P now" and the shutdown using physical Power button, the system is not shutting down. Means, it closed all the programs but finally it is hanging in the blue screen with Fedora Symbol. No prograss after that.
I am just pressing Power button for some seconds to turn off, but I think it is a kind of force shutdown.

Link to this post 25 Jan 12

1. tab completion works in specific shells, do you know what shell you are using such as bash?
2. distros tend to modify the source code for that function, have you tried it without arguments or try to use halt?

Link to this post 25 Jan 12

1. its bash. But, if the shell is not supported for "tab", it should be forever right? . But, sometimes its working fine. Many times it is not
2. No, I didn't. Will try and report back. But, direct power button option and shutdown using the system Menu, these two too also causing the same problem

Link to this post 25 Jan 12

I found a discussion about the tab completion not working at http://www.linuxquestions.org/questions/fedora-35/tab-does-not-auto-complete-in-terminal-440190/ , I recommend checking the files and steps listed in that discussion.

Link to this post 25 Jan 12

Tab completion only works for files in $PATH. Generally, the current directory is not in your PATH: tab completion doesn't work ;)

Try ./fi and hit "tab", completion will work there ("./" is making the shell look into the current directory)

2 - If you need to hold the power button for 4 seconds, then you'll forcing the shutdown. There's something wrong with your shutdown process: check the logs

Regards

Link to this post 28 Jan 12

I just waited the same thing to happen, since, its not happenening always.
And I got it now, and I dont find any difference in $PATH variable.

But, when trying to mention with current dir indication [ as you mentioned in some other thread too ], the search and autofill is faster than the prior.

Generally what I guess is the search time duration may get configured for too long?
I need to check that too..

@Matt: that link has some info about ambiguity thing. That is a must note :-)

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board