Home Linux Community Forums Linux Distributions Fedora Yum does not work after updates

Yum does not work after updates

Link to this post 06 May 10

[file name=yumgrouplist.txt size=1943][/file] I have two laptops with F12 installed which recently received updates and now the yum command does not work on either of them. I have attached a file showing the output when yum command is executed on one of these laptops.

Has anyone else seen this? Or does anyone have any ideas of how to resovle it?

Link to this post 06 May 10

This is a link to a thread in the FedoraForum that might help explain what is going on, though I don't know if the solution works. It might be related to a new version of Python, or some mismatched versionitis between python & the script it is running.[1%3A]

If I find something more helpful, I'll post back.

I only have one F12 system, I've already switched to F13, except F11 on my laptops, I'll try to update the F12 box and see if it's working here. Maybe we could check which versions of yum are running if your still having problems.

You could also try reinstalling yum using rpm -i <packagename> packagename would be yum, but I don't know the version.

I just saw the new version of yum that came in - yum-3.2.27-3.fc12.noarch.

Link to this post 06 May 10

After the update the command "yum grouplist" worked for me. You might want to try:

rpm -ihv --force yum-3.2.27-3.fc12.noarch

and see if reinstalling yum might help.

Link to this post 07 May 10

I did see the link from the Fedora Forum and I was planning on trying it.
I also tried

rpm -ihv --force yum-3.2.27-3.fc12.noarch

however, the following message was displayed

error: open of yum-3.2.27-3.fc12.noarch failed: No such file or directory

For what it's worth the /var/log/yum.log shows the yum-3.2.27-3.fc12.noarch was updated on April 29....

Link to this post 11 May 10

Since I was not successful with the recommendations, I decided to rebuild the systems which resolved this issue.

Link to this post 11 May 10

I just thought I should point out why the previous command returned an error message.
metaylor wrote:

rpm -ihv --force yum-3.2.27-3.fc12.noarch
error: open of yum-3.2.27-3.fc12.noarch failed: No such file or directory

That command is used to manually install a package with rpm. For it to work, you have to specify the full path to the package you want to install, for instance:
rpm -ihv --force /home/username/Desktop/yum-3.2.27-3.fc12.noarch.rpm

But given that yum.log claimed that this package was already installed, I don't think it would have solved your original problem anyway.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board

/** BC-056 Ameex changes to add tracking code - 2016-01-22 **/ ?>