Home Linux Community Forums Hardware Networking Cant find any wireless networks

Cant find any wireless networks

Link to this post 29 May 10

I installed Ubuntu today itself.

Although internet and wifi is running absolutely fine on other OS,
but cant find any wireless networks on Linux.

Pls help

Link to this post 29 May 10

Can you try opening a terminal (in the menu, Applications -> Accessories -> Terminal) and enter the following commands:

ifconfig -a

If you post the output of those commands here, that should help us determine whether or not Linux has loaded the correct network drivers yet :)

Link to this post 12 Jun 10

The output of

lshw | grep -A12 '\-network'
would be a big help, too.

Link to this post 15 Jun 10

I have exactly the same problem: WiFi works in Windows, ethernet cable works in Ubuntu (Hardy Heron), but WiFi doesn't work in Ubuntu. Since the original poster seems to have abandoned this thread, I'm taking over the position of n00b :huh:

When I boot up in Windows, the light that says "WIFI" usually comes on. But in Linux it doesn't come on even if I press the button, and if I go back to Windows I have to press the button to turn it on again.

The output from "dmesg" was 28K, so I've tried to attach it as a separate file, but I'm not sure if it's worked: [file name=dmesg_output.txt size=28714][/file]

The output from the other 3 commands was as follows:

david@david-laptop:~$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:1d:60:ec:47:75
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:20 Base address:0xdead

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:2530 errors:0 dropped:0 overruns:0 frame:0
TX packets:2530 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:126500 (123.5 KB) TX bytes:126500 (123.5 KB)

david@david-laptop:~$ iwconfig
lo no wireless extensions.
eth0 no wireless extensions.

david@david-laptop:~$ lshw | grep -A12 '-network'
WARNING: you should run this program as super-user.
137: *-network DISABLED
138- description: Ethernet interface
139- product: 191 Gigabit Ethernet Adapter
140- vendor: Silicon Integrated Systems [SiS]
141- physical id: 4
142- bus info: pci@0000:00:04.0
143- logical name: eth0
144- version: 02
145- serial: 00:1d:60:ec:47:75
146- width: 32 bits
147- clock: 33MHz
148- capabilities: bus_master cap_list ethernet physical
149- configuration: broadcast=yes driver=sis190 driverversion=1.2 latency=0 module=sis190 multicast=yes
172: *-network UNCLAIMED
173- description: Ethernet controller
174- product: AR242x 802.11abg Wireless PCI Express Adapter
175- vendor: Atheros Communications Inc.
176- physical id: 0
177- bus info: pci@0000:02:00.0
178- version: 01
179- width: 64 bits
180- clock: 33MHz
181- capabilities: cap_list
182- configuration: latency=0
183- *-pci:2
184- description: PCI bridge

david@david-laptop:~$ sudo lshw | grep -A12 '-network'
209: *-network DISABLED
210- description: Ethernet interface
211- product: 191 Gigabit Ethernet Adapter
212- vendor: Silicon Integrated Systems [SiS]
213- physical id: 4
214- bus info: pci@0000:00:04.0
215- logical name: eth0
216- version: 02
217- serial: 00:1d:60:ec:47:75
218- size: 10MB/s
219- capacity: 100MB/s
220- width: 32 bits
221- clock: 33MHz
283: *-network UNCLAIMED
284- description: Ethernet controller
285- product: AR242x 802.11abg Wireless PCI Express Adapter
286- vendor: Atheros Communications Inc.
287- physical id: 0
288- bus info: pci@0000:02:00.0
289- version: 01
290- width: 64 bits
291- clock: 33MHz
292- capabilities: pm msi pciexpress msix cap_list
293- configuration: latency=0
294- *-pci:2
295- description: PCI bridge

Link to this post 16 Jun 10

OK, I looked at the other post. When I type "uname -r" it says "2.6.24-27-generic". I looked on Synaptic Package Manager. It lists a package named linux-restricted-modules-2.6.24-27-generic, and it says my installed version (of linux-restricted-modules-2.6.24-27-generic) is This seems like a mixed message, to my untrained eyes. (Is the version number 2.6.24-27-generic or And there are also a few more versions installed:
- linux-restricted-modules-2.6.24-16-generic, version
- linux-restricted-modules-2.6.24-21-generic, version
- linux-restricted-modules-2.6.24-26-generic, version
- linux-restricted-modules-common, version
- linux-restricted-modules-generic, version
I tried following the link to the madwifi page, but the link was broken and their main page says they've delegated their software distribution to sourceforge, and I couldn't find madwifi-ng on sourceforge.
What do I do now?

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board

/** BC-056 Ameex changes to add tracking code - 2016-01-22 **/ ?>