Linux.com

Keyboard Layout... again...

Link to this post 16 Mar 11

Hello to All.
Did you know how to add russian and UK keyboard layout to my OpenSuse 11.4.
My WM is LXDE.
Modification of file "90-keyboard"../or whatever/ in /etc/X11/xorg.conf.d don`t resolve the problem.
Thank you.

Link to this post 18 Mar 11

Could you post what exactly you did with /etc/X11/xorg.conf.d/90-keyboard? What modifications did you try? And you remembered to restart X (log out and in again) to check that it works?

According to a quick google, something like this is what should be added to enable UK and RU keymaps, and switch between them using Caps Lock:

Option "XkbLayout"  "uk, ru"
Option "XkbOptions" "grp:caps_toggle"

It is also possible to manually swap keymaps using the following commands:
setxkbmap uk
setxkbmap ru
So if nothing else works, you could make your own keybindings for those two commands to quickly switch between the layouts.

[EDIT]
I see that this thread is a dupe... Did you try mfillpots suggestion lxpanel-xkb from your previous thread?

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board