Linux.com

grammjr

grammjr

  • Linux.com Member
  • Posts: 35
  • Member Since: 12 May 10
  • Last Logged In: 29 Jun 10

Latest Posts

Posted by
Topic
Post Preview
Posted
  • grammjr
    RE: Mounting USB wireless adapter and hard drive
    Yes the iwlist wlan0 scan works and I am sending through the wireless adapter, how ever it still does not show in NETWORK MANAGER. The RADAR tool will pick up the sites so that one works. So I still have a problem with it being detected by NETWORK MANAGER. I have 2 routers to get the signal through the house so the scan was correct. What do you need to see? [code]debian:~# iwlist wlan0 scan wlan0 Scan completed : Cell 01 - Address: 00:02:6F:61:7F:D7 ESSID:"Hey" Mode:Master Channel:9 Frequency:2.452 GHz (Channel 9) Quality=46/100 Signal level=-82 dBm Encryption key:on Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s 11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s 48 Mb/s; 54 Mb/s Extra:tsf=0000008fde4e56aa Cell 02 - Address: 00:24:01:72:92:29 ESSID:"Hey" Mode:Master Channel:9 Frequency:2.452 GHz (Channel 9) Quality=54/100 Signal level=-36 dBm Encryption key:on Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s 48 Mb/s; 54 Mb/s Extra:tsf=000000a7eff6df68 [/code] [quote]I seriously encourage you to umount/eject the device before unplugging it. [/quote] I hear you but I had to test it to see if it would work as if should and it did. [i]unmount/reject[/i] is the best and safest way to do it, I agree.
    Link to this post 31 May 10

    Yes the iwlist wlan0 scan works and I am sending through the wireless adapter, how ever it still does not show in NETWORK MANAGER. The RADAR tool will pick up the sites so that one works.
    So I still have a problem with it being detected by NETWORK MANAGER. I have 2 routers to get the signal through the house so the scan was correct.
    What do you need to see?

    debian:~# iwlist wlan0 scan
    wlan0 Scan completed :
    Cell 01 - Address: 00:02:6F:61:7F:D7
    ESSID:"Hey"
    Mode:Master
    Channel:9
    Frequency:2.452 GHz (Channel 9)
    Quality=46/100 Signal level=-82 dBm
    Encryption key:on
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
    11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
    48 Mb/s; 54 Mb/s
    Extra:tsf=0000008fde4e56aa
    Cell 02 - Address: 00:24:01:72:92:29
    ESSID:"Hey"
    Mode:Master
    Channel:9
    Frequency:2.452 GHz (Channel 9)
    Quality=54/100 Signal level=-36 dBm
    Encryption key:on
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
    9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
    48 Mb/s; 54 Mb/s
    Extra:tsf=000000a7eff6df68

    I seriously encourage you to umount/eject the device before unplugging it.

    I hear you but I had to test it to see if it would work as if should and it did. unmount/reject is the best and safest way to do it, I agree.

  • grammjr
    RE: Mounting USB wireless adapter and hard drive
    OK [i]commented out[/i] the lines [code] #/dev/sda1 /mnt/usb vfat,ntfs-3g users,rw,noauto,umask=000,relatime 0 0 #/dev/sdb1 /mnt/usb2 vfat,ntfs-3g users,rw,noauto,umask=000,relatime 0 0 [/code] and the TD and HD automatically mount. All seems to be working. Even a hot unplug, unplugging without [i]unmounting[/i] is working just like in the first install. Did not even have to reboot.
    Link to this post 31 May 10

    OK commented out the lines

     #/dev/sda1 /mnt/usb vfat,ntfs-3g users,rw,noauto,umask=000,relatime 0 0 
    #/dev/sdb1 /mnt/usb2 vfat,ntfs-3g users,rw,noauto,umask=000,relatime 0 0

    and the TD and HD automatically mount. All seems to be working.
    Even a hot unplug, unplugging without unmounting is working just like in the first install.
    Did not even have to reboot.

  • grammjr
    RE: Mounting USB wireless adapter and hard drive
    [quote]That is an option, but I think we're close to solving this now, so let's give it a couple of more days [/quote] OK I will wait, was going wait, just thinking ahead.. I am learning Linux... boy oh boy.. I am a 59 yr old man learning a new trick. :laugh: OK, I entered the command: [code]debian:~# usermod --append --groups adm,cdrom,audio,video,plugdev,games,users,lpadmin,netdev,scanner jim debian:~# [/code] Rebooted, the TD came up automatically, but not the HD, I [i]unmounted[/i] the TD unplugged it and plugged it back in and it [i]mounted[/i]. So I think the TD is OK. In order to get HD to [i]mount[/i] I have to go to root and command line it. It will still not do it automatically. [code] debian:~# mount /mnt/usb2 debian:~# [/code] It mounts and I can access, I unmount it and unplug it and plug it back in it will not remount, until I do it from the command line then it will mount.
    Link to this post 31 May 10

    That is an option, but I think we're close to solving this now, so let's give it a couple of more days

    OK I will wait, was going wait, just thinking ahead.. I am learning Linux... boy oh boy.. I am a 59 yr old man learning a new trick. :laugh:

    OK, I entered the command:

    debian:~# usermod --append --groups adm,cdrom,audio,video,plugdev,games,users,lpadmin,netdev,scanner jim
    debian:~#

    Rebooted, the TD came up automatically, but not the HD, I unmounted the TD unplugged it and plugged it back in and it mounted. So I think the TD is OK.

    In order to get HD to mount I have to go to root and command line it. It will still not do it automatically.


    debian:~# mount /mnt/usb2
    debian:~#

    It mounts and I can access, I unmount it and unplug it and plug it back in it will not remount, until I do it from the command line then it will mount.

  • grammjr
    RE: Mounting USB wireless adapter and hard drive
    No I did not [i]unmount [/i]them, on my first install, I was able to unplug them and plug them back in and it automatically accessed them. I did not have to do anything special. The TD will remount if I [quote]unmount [/quote]it before unplugging, but the HD I have to go to root and [i]mount /mnt/usb[/i] to get it to [i]mount[/i] again. It will not auto mount when I plug it in. It is a required thing to [i]unmount[/i] in Linux? There is a ton of information here in this thread, I am tempted now that I have this stuff working to try a new install and see if this stuff will set up automatically. What do you think?
    Link to this post 30 May 10

    No I did not unmount them, on my first install, I was able to unplug them and plug them back in and it automatically accessed them. I did not have to do anything special.

    The TD will remount if I

    unmount
    it before unplugging, but the HD I have to go to root and mount /mnt/usb to get it to mount again. It will not auto mount when I plug it in.

    It is a required thing to unmount in Linux?

    There is a ton of information here in this thread, I am tempted now that I have this stuff working to try a new install and see if this stuff will set up automatically. What do you think?

  • grammjr
    RE: Mounting USB wireless adapter and hard drive
    The drives will mount if plugged in when I reboot, but if I unplug them and replug them back they will not remount.
    Link to this post 30 May 10

    The drives will mount if plugged in when I reboot, but if I unplug them and replug them back they will not remount.

  • grammjr
    RE: Mounting USB wireless adapter and hard drive
    Well this change made both drives work.... [b]Code:[/b] /dev/sda1 /mnt/usb vfat,ntfs-3g users,rw,noauto,umask=000,relatime 0 0 /dev/sdb1 /mnt/usb2 vfat,ntfs-3g users,rw,noauto,umask=000,relatime 0 0 [code] debian:~# cat /etc/group root:x:0: daemon:x:1: bin:x:2: sys:x:3: adm:x:4: tty:x:5: disk:x:6: lp:x:7: mail:x:8: news:x:9: uucp:x:10: man:x:12: proxy:x:13: kmem:x:15: dialout:x:20: fax:x:21: voice:x:22: cdrom:x:24: floppy:x:25: tape:x:26: sudo:x:27: audio:x:29:jim dip:x:30: www-data:x:33: backup:x:34: operator:x:37: list:x:38: irc:x:39: src:x:40: gnats:x:41: shadow:x:42: utmp:x:43: video:x:44: sasl:x:45: plugdev:x:46: staff:x:50: games:x:60: users:x:100: nogroup:x:65534: libuuid:x:101: crontab:x:102: scanner:x:103: ssl-cert:x:104: Debian-exim:x:105: mlocate:x:106: ssh:x:107: messagebus:x:108: avahi-autoipd:x:109: avahi:x:110: netdev:x:111: lpadmin:x:112: gdm:x:113: stb-admin:x:114: haldaemon:x:115: powerdev:x:116: jim:x:1000: debian:~# [/code] I can now read both drives and have sound.. but WOW LOL
    Link to this post 30 May 10

    Well this change made both drives work....
    Code:
    /dev/sda1 /mnt/usb vfat,ntfs-3g users,rw,noauto,umask=000,relatime 0 0
    /dev/sdb1 /mnt/usb2 vfat,ntfs-3g users,rw,noauto,umask=000,relatime 0 0


    debian:~# cat /etc/group
    root:x:0:
    daemon:x:1:
    bin:x:2:
    sys:x:3:
    adm:x:4:
    tty:x:5:
    disk:x:6:
    lp:x:7:
    mail:x:8:
    news:x:9:
    uucp:x:10:
    man:x:12:
    proxy:x:13:
    kmem:x:15:
    dialout:x:20:
    fax:x:21:
    voice:x:22:
    cdrom:x:24:
    floppy:x:25:
    tape:x:26:
    sudo:x:27:
    audio:x:29:jim
    dip:x:30:
    www-data:x:33:
    backup:x:34:
    operator:x:37:
    list:x:38:
    irc:x:39:
    src:x:40:
    gnats:x:41:
    shadow:x:42:
    utmp:x:43:
    video:x:44:
    sasl:x:45:
    plugdev:x:46:
    staff:x:50:
    games:x:60:
    users:x:100:
    nogroup:x:65534:
    libuuid:x:101:
    crontab:x:102:
    scanner:x:103:
    ssl-cert:x:104:
    Debian-exim:x:105:
    mlocate:x:106:
    ssh:x:107:
    messagebus:x:108:
    avahi-autoipd:x:109:
    avahi:x:110:
    netdev:x:111:
    lpadmin:x:112:
    gdm:x:113:
    stb-admin:x:114:
    haldaemon:x:115:
    powerdev:x:116:
    jim:x:1000:
    debian:~#

    I can now read both drives and have sound.. but WOW LOL

  • grammjr
    RE: Mounting USB wireless adapter and hard drive
    OK, made the changes [code] # /etc/fstab: static file system information. # # proc /proc proc defaults 0 0 /dev/hda1 / ext3 errors=remount-ro 0 1 /dev/hda5 none swap sw 0 0 /dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0 /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0 /dev/sda1 /mnt/usb vfat,ntfs-3g users,rw,noauto,umask=000,relatime,silent 0 0 /dev/sdb1 /mnt/usb2 vfat,ntfs-3g users,rw,noauto,umask=000,relatime,silent 0 0 [/code] HD is working :cheer: The TD seems to be having a permissions issue. [code]debian:~# mount /mnt/usb NTFS signature is missing. Failed to mount '/dev/sda1': Invalid argument The device '/dev/sda1' doesn't have a valid NTFS. Maybe you selected the wrong device? Or the whole disk instead of a partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around? debian:~# mount /mnt/usb2 debian:~# [/code] TD permisions: [img size=523]http://www.linux.com/media/kunena/attachments/legacy/images/USB_TD_gnome_mount_1.png[/img] Also the [b]Jim Backup[/b] is now showing as a HD. I can access the [b]Jim Backup[/b] , but I cannot open either of the usb/usb2 drives, I get the same permission denied as above when I try to access the TD. [file name=Screenshot_Computer.png size=34550]http://www.linux.com/media/kunena/attachments/legacy/files/Screenshot_Computer.png[/file] [quote]could you post the contents of the file /etc/group so we can check if these are more permissions-issues? [/quote] [code] GNU nano 2.0.7 File: /etc/group root:x:0: daemon:x:1: bin:x:2: sys:x:3: adm:x:4: tty:x:5: disk:x:6: lp:x:7: mail:x:8: news:x:9: uucp:x:10: man:x:12: proxy:x:13: kmem:x:15: dialout:x:20: fax:x:21: voice:x:22: cdrom:x:24: floppy:x:25: [/code] We are one step closer..... :woohoo: [i][/i]
    Link to this post 29 May 10

    OK, made the changes


    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/hda1 / ext3 errors=remount-ro 0 1
    /dev/hda5 none swap sw 0 0
    /dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
    /dev/sda1 /mnt/usb vfat,ntfs-3g users,rw,noauto,umask=000,relatime,silent 0 0
    /dev/sdb1 /mnt/usb2 vfat,ntfs-3g users,rw,noauto,umask=000,relatime,silent 0 0

    HD is working :cheer: The TD seems to be having a permissions issue.

    debian:~# mount /mnt/usb
    NTFS signature is missing.
    Failed to mount '/dev/sda1': Invalid argument
    The device '/dev/sda1' doesn't have a valid NTFS.
    Maybe you selected the wrong device? Or the whole disk instead of a
    partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?

    debian:~# mount /mnt/usb2
    debian:~#

    TD permisions:

    Also the Jim Backup is now showing as a HD. I can access the Jim Backup , but I cannot open either of the usb/usb2 drives, I get the same permission denied as above when I try to access the TD.
    [file name=Screenshot_Computer.png size=34550]http://www.linux.com/media/kunena/attachments/legacy/files/Screenshot_Computer.png[/file]

    could you post the contents of the file /etc/group so we can check if these are more permissions-issues?


    GNU nano 2.0.7 File: /etc/group
    root:x:0:
    daemon:x:1:
    bin:x:2:
    sys:x:3:
    adm:x:4:
    tty:x:5:
    disk:x:6:
    lp:x:7:
    mail:x:8:
    news:x:9:
    uucp:x:10:
    man:x:12:
    proxy:x:13:
    kmem:x:15:
    dialout:x:20:
    fax:x:21:
    voice:x:22:
    cdrom:x:24:
    floppy:x:25:

    We are one step closer..... :woohoo:

  • grammjr
    RE: Mounting USB wireless adapter and hard drive
    [b]Thumb drive and HD[/b] OK, maybe my fault here. What I have is 4G TD that is FAT32, one my first install this was recognized and accesses with no intervention on my part. This time it is not. I also have a USB external HD that is NTFS. [quote]Upon closer inspection, I see that the contents of your /etc/fstab is in fact this: /dev/disk/by-id /usb-UT163_USB_Flash_Disk_00000000001055-0:0-part1 /mnt/usb ntfs-3g users,rw,noauto,umask=000,relatime,silent 0 0 You just have to remove all the whitespace between /dev/disk/by-id and /usb-(...)[/quote] Did this, but still not working. This is with the TD: [code]debian:~# mount /mnt/usb NTFS signature is missing. Failed to mount '/dev/sda1': Invalid argument The device '/dev/sda1' doesn't have a valid NTFS. Maybe you selected the wrong device? Or the whole disk instead of a partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around? [/code] This is with the HD: [code]debian:~# mount /mnt/usb ntfs-3g: Failed to access volume '/dev/disk/by-id/usb-UT163_USB_Flash_Disk_00000000001055-0:0-part1': No such file or directory Please type '/sbin/mount.ntfs-3g --help' for more information. [/code] As you can see when I plug them all in I have the TD, the USB we set up and HD (Jim Backup). The USB is there all the time with or without a drive installed. [img size=511]http://www.linux.com/media/kunena/attachments/legacy/images/Screenshot_Computer.png[/img] [file name=Screenshot_gnome_mount.png size=39123]http://www.linux.com/media/kunena/attachments/legacy/files/Screenshot_gnome_mount.png[/file]
    Link to this post 29 May 10

    Thumb drive and HD

    OK, maybe my fault here.

    What I have is 4G TD that is FAT32, one my first install this was recognized and accesses with no intervention on my part. This time it is not.
    I also have a USB external HD that is NTFS.

    Upon closer inspection, I see that the contents of your /etc/fstab is in fact this:
    /dev/disk/by-id
    /usb-UT163_USB_Flash_Disk_00000000001055-0:0-part1 /mnt/usb ntfs-3g users,rw,noauto,umask=000,relatime,silent 0 0
    You just have to remove all the whitespace between /dev/disk/by-id and /usb-(...)

    Did this, but still not working.
    This is with the TD:

    debian:~# mount /mnt/usb
    NTFS signature is missing.
    Failed to mount '/dev/sda1': Invalid argument
    The device '/dev/sda1' doesn't have a valid NTFS.
    Maybe you selected the wrong device? Or the whole disk instead of a
    partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?


    This is with the HD:

    debian:~# mount /mnt/usb
    ntfs-3g: Failed to access volume '/dev/disk/by-id/usb-UT163_USB_Flash_Disk_00000000001055-0:0-part1': No such file or directory
    Please type '/sbin/mount.ntfs-3g --help' for more information.

    As you can see when I plug them all in I have the TD, the USB we set up and HD (Jim Backup). The USB is there all the time with or without a drive installed.

    [file name=Screenshot_gnome_mount.png size=39123]http://www.linux.com/media/kunena/attachments/legacy/files/Screenshot_gnome_mount.png[/file]

  • grammjr
    PalTalk on Debian Lenny
    I was able to install PalTalk in Wine and it comes up and connects, but the screen to display the rooms does not display the rooms, anyone successively running PT on Lenny? [img size=624]http://www.linux.com/media/kunena/attachments/legacy/images/Screenshot_Rooms_List.png[/img] Thanks
    Link to this post 28 May 10

    I was able to install PalTalk in Wine and it comes up and connects, but the screen to display the rooms does not display the rooms, anyone successively running PT on Lenny?

    Thanks

  • grammjr
    RE: Mounting USB wireless adapter and hard drive
    [b]Sound[/b] [quote]Did you try to install the gstreamer plugins? [/quote] Yes one of the first things tried. [code] debian:~# usermod -a -G adm,admin,cdrom,audio,video,games,users,netdev,plugdev,lpadmin,pulse-access,sambashare jim usermod: unknown group admin usermod: unknown group pulse-access usermod: unknown group sambashare debian:~# [/code] Logged out and back in and I now have sound :cheer: Kind of weird because the first install it worked right away and this second I have to do all this extra stuff. But the complete sound device works, records plays back etc.. [b]HD[/b] OK I made the su -c "mkdir /mnt/usb" fstab:[code] # /etc/fstab: static file system information. # # proc /proc proc defaults 0 0 /dev/hda1 / ext3 errors=remount-ro 0 1 /dev/hda5 none swap sw 0 0 /dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0 /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0 /dev/disk/by-id /usb-UT163_USB_Flash_Disk_00000000001055-0:0-part1 /mnt/usb ntfs-3g users,rw,no$,rw,noauto,umask=000,relatime,silent 0 0[/code] [code]debian:~# mount /mnt/usb ntfs-3g: Failed to access volume '/usb-UT163_USB_Flash_Disk_00000000001055-0:0-part1': No such file or directory Please type '/sbin/mount.ntfs-3g --help' for more information. debian:~# [/code] [img size=508]http://www.linux.com/media/kunena/attachments/legacy/images/Screenshot_Computer_1.png[/img] Again on the first install I did not have this issue, once I installed [i]ntfs-3g[/i] I was able to look at the HD, the thumbdrive worked from the get go with no intervention. [b]NetworkManager[/b] Tried the suggested and it still did not work, but we can work on that later, this HD thing is more important
    Link to this post 28 May 10

    Sound

    Did you try to install the gstreamer plugins?

    Yes one of the first things tried.

    debian:~# usermod -a -G adm,admin,cdrom,audio,video,games,users,netdev,plugdev,lpadmin,pulse-access,sambashare jim
    usermod: unknown group admin
    usermod: unknown group pulse-access
    usermod: unknown group sambashare
    debian:~#


    Logged out and back in and I now have sound :cheer:

    Kind of weird because the first install it worked right away and this second I have to do all this extra stuff. But the complete sound device works, records plays back etc..

    HD

    OK I made the su -c "mkdir /mnt/usb"
    fstab:


    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/hda1 / ext3 errors=remount-ro 0 1
    /dev/hda5 none swap sw 0 0
    /dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
    /dev/disk/by-id
    /usb-UT163_USB_Flash_Disk_00000000001055-0:0-part1 /mnt/usb ntfs-3g users,rw,no$,rw,noauto,umask=000,relatime,silent 0 0

    debian:~# mount /mnt/usb
    ntfs-3g: Failed to access volume '/usb-UT163_USB_Flash_Disk_00000000001055-0:0-part1': No such file or directory
    Please type '/sbin/mount.ntfs-3g --help' for more information.
    debian:~#

    Again on the first install I did not have this issue, once I installed ntfs-3g I was able to look at the HD, the thumbdrive worked from the get go with no intervention.


    NetworkManager
    Tried the suggested and it still did not work, but we can work on that later, this HD thing is more important

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board