Home Linux Community Forums Hardware Printers Ricoh Multifunctional with UserCode

Ricoh Multifunctional with UserCode

Link to this post 18 Feb 14


Following is an overview of the print setup I need to get working:
- printer: Ricoh MPC5503
- print server: Windows 2008 SMB share with PCL6 driver
- print client: RedHat Enterprise 4 server (yes, I know it's old and should be replaced) using the generic PCL6 driver

The connection from the linux box to the windows share works, when I pause the windows queue I see the jobs arrive.
... so this setup wouldn't be that hard (I got it working for a Ricoh MP7502 with the generic PCL6 driver) if it wasn't for the fact that they have configured this printer with User and Classification codes to track and limit printing. (see attachment "ricoh.png" for an example of what to configure on a windows client)

I already tried to follow the Ricoh FAQ on LinuxFoundation chapter 1.2.3 and entered several of the commands to the Queue Options (see attachment RHEL-Queue.png) but I keep getting the error "You do not have a privilege to use this function. This job has been cancelled."

Aside from the option UserCode I couldn't find any command to pass along the classification code anywhere.

If I have left something out I'm more than willing to provide additional information. Can someone assist me to shed some light on this?

Kind regards,

edit: I'm getting an error from the site for the uploaded files so I'm afraid I can't provide the screenshots

Link to this post 18 Feb 14

Yes, as far as I can tell this is a postscript driver, not a PCL and therefor wouldn't be compatible with the windows print queue.

(When I tried to use the openprinting driver for the other printer (Ricoh MP7502) I consistently got "print data error" back, even if I printed directly to the IP address of the printer ... that is, until I used the generic PCL6 driver.)

In the case for the MPC5503, both the PPD from and the generic PCL6 driver have the same result: "You do not have a privilege to use this function. This job has been cancelled."
(Also both direct and via the windows print queue)

When I click the link "Look for help in our forum for printers [etc ...]" I get a security pop-up to enter a username password but I can't seem to get in.

Kind regards,

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board