Linux.com

Home Linux Community Forums Linux Distributions Ubuntu Mount of filesystem fails - Ubuntu won't boot

Mount of filesystem fails - Ubuntu won't boot

Link to this post 18 Aug 10

I am using Ubuntu 9.04, I am having this error "Mount of filesystem fails, Maintenance Shell will now be started, Control-D will terminate this Shell and Re-Try, $root@jojocompas:~# "

My question: How do I get my system to boot, it has been sitting there in the Shell, it doesn't seem to be doing anything at all. I have tried the recovery but each time it sends the system to this Shell. Do I need to do something to start up the Shell?

Link to this post 18 Aug 10

After attempting a recovery that fails, it asked me to run "fsck" and now everything just works fine!

Link to this post 18 Aug 10

That is good that you found the problem. It's not easy to find the reason why a system fails or how to solve it, especially when not too many people experience the same problem. Usually it just takes some time experimenting.

Make sure you document what you found and write an article about the problem you had so others can benefit from your solution.

Good job!!B)

Link to this post 18 Aug 10

Based upon the resolution you found it looks like it has been determined and solved.

What you experienced was disk corruption resulting in the system being unable to access files necessary for it to boot. by running the command fsck you told the system to locate and (when possible) correct disk corruptions.

You also bring up one feature in ubuntu that I like, which is the simplified error message and included recommendations for remediation, in general when it tells you what to run it will fix your issues.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board