November 1, 2011

Help with Permissions Problem?

I am having a little problem with permissions of a file, and can´t find a solution, I have a mail Server with Postfix, Courier and Roundcube as Webmail. When I give in the user´s directory permissions to root (/maildir/user root:root), login is ok in Roundcube but can´t send mails, and logs show: "/maildir/domain.com/user/tmp/mail_id.server_name: Permission denied)" If I give in user´s directory permissions to another user, for example mail (/maildir/user mail:mail), I can send mails but can´t login into Roundcube Webmail. This is what I find with lsof: lsof -i :143 COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME couriertc 2849 root 3u IPv4 7630 TCP mail-server:imap2 (LISTEN) couriertc 2849 root 5u IPv4 7631 TCP localhost:imap2 (LISTEN) Seems that root is the username being used. I´ve changed the courier directory´s UID and GID to mail:mail but when I do lsof -i :143 still root as the username in used. Any help will be welcome. Thanks for your attention Sirs. Best regards,

Hello friend,...

Hello friend,
I thing is normal problem friend. your Roundcube is not connect properly database. so please check ur database.

Like  (0 likes)

Dear Sirs I´ve finally solved this problem....

Dear Sirs I´ve finally solved this problem.
If it is useful for someone, here is what I do.
I leave permissions over the /maildir/doamin.com/user directory to the user mail, so as to be able to send mails.
But as I said, I can´t login inTO Roundcube Webmail, so I run:

telnet localhost imap
a login user@domain.com password
[ALERT] Fatal error: Account's mailbox directory is not owned by the correct uid or gid

This is what I receive when I try to login.
So I find in a post that Courier checks for the SANITY of the setup, so turning this option to "0" solved the problem.
I added this line in /etc/courier/imapd => IMAP_MAILBOX_SANITY_CHECK=0

So if I telnet localhost now I can login ok:

telnet localhost imap
a login user@domain.com password
a OK LOGIN Ok.

Now when trying to login into Roundcube Webmail, everything works ok, and can send mails ok too.
Thanks to everyone for your help.

Best regards.

Like  (0 likes)

this is the same question as posted here today...

this is the same question as posted here today
(word for word )
https://www.linuxquestions.org/questions/linux-server-73/permission-issu...

Like  (0 likes)