Run the vlc command in a terminal window, that should display any error mess...

Run the vlc command in a terminal window, that should display any error message to tell you what is causing the application to fail.

vlc
VLC media player 1.1.4 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x9ef48fc] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0x9fadedc] skins2 interface error: no suitable dialogs provider found (hint: compile the qt4 plugin, and make sure it is loaded properly)
[0x9fadedc] skins2 interface error: cannot instanciate qt4 dialogs provider
[0x9ef48fc] main libvlc error: interface "default" initialization failed

Judging by the error message either the plugin-cache is incomplete or qt is not installed correctly. Try the steps mentioned in http://ubuntuforums.org/showthread.php?t=1484407 then report back with what does or does not work.

ya sure...i report back. thank you mfillpot..

Click Here!