April 17, 2018

Yum Server - Client mismatch

Hello,

I have a test environment which has six CentOS servers, and created a local YUM repository in one of the servers, where the other five servers should be fetching packages from this local YUM server via ftp.

Server1 (Yum Server): I have installed the FTP server and was able to install local yum server without any issues, but only after renaming the remaining pre-installed CentOS-*.repo files to CentOS-*.repo.bak files.

Server2-5 (Yum Clients): I am able to fetch packages from Yum Server via ftp. But, I had to rename the pre-installed CentOS-*.repo files to CentOS-*.repo.bak files, just like I did in Server1.

Server6 (Yum Client): In this server, I did not rename the CentOS-*.repo files, but created a new file "client.repo" in the /etc/yum.repos.d/ folder. When i tried to do a yum repolist, it failed with “Another app is currently holding the yum lock” error. After going through various articles, I have disabled the PackageKit utility which was the reason for the error and then I was able to execute the yum repolist command. But, when I tried to install a package, it fetched from the CentOS-Base.repo file, instead of the "client.repo" file, which was created to fetch the packages via ftp server.

Can someone help me how can this be fixed? One of my friend said, it is okay to have multiple .repo files in /etc/yum.repos.d/ folder. How can I make sure that the packages are being fetched from the local YUM server which I created?

It would be great, if anyone can help me on this. Thanks in advance.

Click Here!