<!DOCTYPE html>
<html  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# og: http://ogp.me/ns# article: http://ogp.me/ns/article# og: http://ogp.me/ns# book: http://ogp.me/ns/book# og: http://ogp.me/ns# profile: http://ogp.me/ns/profile# og: http://ogp.me/ns# video: http://ogp.me/ns/video# og: http://ogp.me/ns# product: http://ogp.me/ns/product# og: http://ogp.me/ns# content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ rdfs: http://www.w3.org/2000/01/rdf-schema# og: http://ogp.me/ns# sioc: http://rdfs.org/sioc/ns# og: http://ogp.me/ns# sioct: http://rdfs.org/sioc/types# og: http://ogp.me/ns# skos: http://www.w3.org/2004/02/skos/core# og: http://ogp.me/ns# xsd: http://www.w3.org/2001/XMLSchema# og: http://ogp.me/ns#">

<head>
  <meta charset="utf-8" />
<script>
      dataLayer = [{"gtm.whitelist":["google","nonGooglePixels","nonGoogleScripts","nonGoogleIframes"],"gtm.blacklist":["customScripts","customPixels"],"loggedIn":false,"byline":"Eric Brown","publishDate":"April 25, 2018","contentType":"blog","contentSource":"Freelance","resources":["Event"],"general":["Linux","Embedded"]}, {"event":"generalPush","general":"Linux"},{"event":"generalPush","general":"Embedded"}]
    </script><link rel="shortcut icon" href="https://www.linux.com/sites/all/themes/custom/lcom/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="description" content="Although Real-Time Linux (RT Linux) has been a staple at Embedded Linux Conferences for years -- here’s a story on the RT presentations in 2007 -- many developers have viewed the technology to be peripheral to their own embedded projects." />
<link rel="canonical" href="https://www.linux.com/blog/elc/2018/4/developers-prepare-your-drivers-real-time-linux" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="shortlink" href="https://www.linux.com/blog/elc/2018/4/developers-prepare-your-drivers-real-time-linux" />
<meta property="og:site_name" content="Linux.com | The source for Linux information" />
<meta property="og:type" content="website" />
<meta property="og:title" content="Developers: Prepare Your Drivers for Real-Time Linux" />
<meta property="og:url" content="https://www.linux.com/blog/elc/2018/4/developers-prepare-your-drivers-real-time-linux" />
<meta property="og:description" content="Although Real-Time Linux (RT Linux) has been a staple at Embedded Linux Conferences for years -- here’s a story on the RT presentations in 2007 -- many developers have viewed the technology to be peripheral to their own embedded projects." />
<meta property="og:updated_time" content="2018-04-25T21:46:27+00:00" />
<meta property="og:image" content="https://www.linux.com/sites/lcom/files/drivers-chuttersnap-unsplash.jpg" />
<meta name="twitter:site" content="@linuxfoundation" />
<meta name="twitter:url" content="https://www.linux.com/blog/elc/2018/4/developers-prepare-your-drivers-real-time-linux" />
<meta name="twitter:title" content="Developers: Prepare Your Drivers for Real-Time Linux" />
<meta name="twitter:description" content="Although Real-Time Linux (RT Linux) has been a staple at Embedded Linux Conferences for years -- here’s a story on the RT presentations in 2007 -- many developers have viewed the technology to be peripheral to their own embedded projects." />
<meta name="twitter:image" content="https://www.linux.com/sites/lcom/files/drivers-chuttersnap-unsplash.jpg" />
<meta property="article:published_time" content="2018-04-25T14:27:52+00:00" />
<meta property="article:modified_time" content="2018-04-25T21:46:27+00:00" />
<meta itemprop="name" content="Developers: Prepare Your Drivers for Real-Time Linux" />
<meta itemprop="description" content="Although Real-Time Linux (RT Linux) has been a staple at Embedded Linux Conferences for years -- here’s a story on the RT presentations in 2007 -- many developers have viewed the technology to be peripheral to their own embedded projects." />
<meta itemprop="image" content="https://www.linux.com/sites/lcom/files/drivers-chuttersnap-unsplash.jpg" />
  <title>Developers: Prepare Your Drivers for Real-Time Linux | Linux.com | The source for Linux information</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <!--[if IEMobile]><meta http-equiv="cleartype" content="on"><![endif]-->

  <link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_kShW4RPmRstZ3SpIC-ZvVGNFVAi0WEMuCnI0ZkYIaFw.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_7miOmtwKPtgd4frsGApNDqsuxu7-w-bZX3bp__1R3Hc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_XW-lOa7cj7oUUdmEUvbB6oUFqnqQgMi0uKEZyah0J20.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_VJJ45mjP6ywKVkfo0Io3-PB1zoNauDbwu2REXjBP9AU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_rfBpH0rulzlEFmwl1X3jVidtFsXI4VmwHQsYdwvUFzU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_nQwtytNsztHNRD8oGYQyyja_LgjxLi44qLISIPyImuw.css" media="all" />
  <script>(function(h,o,t,j,a,r){
  h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
  h._hjSettings={hjid:"134680",hjsv:5};
  a=o.getElementsByTagName('head')[0];
  r=o.createElement('script');r.async=1;
  r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
  a.appendChild(r);
})(window,document,'//static.hotjar.com/c/hotjar-','.js?sv=');</script>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js"></script>
<script>window.jQuery || document.write("<script src='/sites/all/modules/contrib/jquery_update/replace/jquery/1.7/jquery.min.js'>\x3C/script>")</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_PdiuypZMI8o81AYEdTHwjRslVPEF69JFzr7Y9sMWt4s.js"></script>
<script>var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};</script>
<script src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_c7JD4meMfpH1WtncuLu8d4NXqkL-6r2fxWVw1JNKG-M.js"></script>
<script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.10.2/jquery-ui.min.js"></script>
<script>window.jQuery.ui || document.write("<script src='/sites/all/modules/contrib/jquery_update/replace/ui/ui/minified/jquery-ui.min.js'>\x3C/script>")</script>
<script src="https://www.linux.com/sites/all/libraries/mediaelement/build/mediaelement-and-player.min.js?v=2.1.6"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js__bBogcF6zrob06qh5ifUeGh4t30mvORXZ2P3hX4c7sE.js"></script>
<script>var mapping = googletag.sizeMapping()
  .addSize([0, 0], [300, 250])
  .addSize([488, 0], [468, 60])
  .addSize([748, 0], [728, 90])
  .build();
googletag.slots["leaderboard1"] = googletag.defineSlot("/2972204/LF_ROS_728x90_468x60_300x250", [[728, 90], [468, 60], [300, 250]], "dfp-ad-leaderboard1")
  .addService(googletag.pubads())
  .defineSizeMapping(mapping);</script>
<script>var mapping = googletag.sizeMapping()
  .addSize([0, 0], [300, 250])
  .addSize([748, 0], [200, 200])
  .addSize([1028, 0], [300, 250])
  .build();
googletag.slots["box1"] = googletag.defineSlot("/2972204/LF_ROS_300x250_200x200", [[300, 250], [200, 200]], "dfp-ad-box1")
  .addService(googletag.pubads())
  .defineSizeMapping(mapping);</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_Xk8TsyNfILciPNmQPp9sl88cjH71DQWyeHE0MB62KO4.js"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_OVAOz6xKTt0o5QhoWFs7HJDiUhoqOR7FmnZl8WEbty4.js"></script>
<script>googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
});

googletag.enableServices();</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_YBDYs7heXRixjwSbdGrTzbuys9Ua3jHX0Te6thYuaJ4.js"></script>
<script>var _vwo_code=(function(){
var account_id=218604,
settings_tolerance=2000,
library_tolerance=1500,
use_existing_jquery=false,
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_9th_CAR-zdFHlBOR6cubKyS7kIo8orSEKfIrlzdjqlg.js"></script>
<script>window.a2a_config=window.a2a_config||{};window.da2a={done:false,html_done:false,script_ready:false,script_load:function(){var a=document.createElement('script'),s=document.getElementsByTagName('script')[0];a.type='text/javascript';a.async=true;a.src='https://static.addtoany.com/menu/page.js';s.parentNode.insertBefore(a,s);da2a.script_load=function(){};},script_onready:function(){da2a.script_ready=true;if(da2a.html_done)da2a.init();},init:function(){for(var i=0,el,target,targets=da2a.targets,length=targets.length;i<length;i++){el=document.getElementById('da2a_'+(i+1));target=targets[i];a2a_config.linkname=target.title;a2a_config.linkurl=target.url;if(el){a2a.init('page',{target:el});el.id='';}da2a.done=true;}da2a.targets=[];}};(function ($){Drupal.behaviors.addToAny = {attach: function (context, settings) {if (context !== document && window.da2a) {if(da2a.script_ready)a2a.init_all('page');da2a.script_load();}}}})(jQuery);a2a_config.callbacks=a2a_config.callbacks||[];a2a_config.callbacks.push({ready:da2a.script_onready});a2a_config.templates=a2a_config.templates||{};a2a_config.num_services = 5;
    a2a_config.prioritize = ["email", "facebook", "twitter", "linkedin", "pinterest", "google_plus"];</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_h1lDMTrnEZD5OYT82JLf5ycCK0cJAImbsG7ng0GSloQ.js"></script>
<script>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</script>
  </head>
<body class="html not-front not-logged-in one-sidebar sidebar-second page-node page-node- page-node-804737 node-type-blog section-blog page-panels" >
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-NXGNZW" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-NXGNZW');</script>
<!-- End Google Tag Manager -->
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<div id="page">

    <div class="region region-header-top">
    <div class="container">
      
<div id="block-dfp-leaderboard1" class="block block-dfp first last odd lf_header_leaderboard_ad">

    
	<div class="block__content">
	  <div id="dfp-ad-leaderboard1-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-leaderboard1" class="dfp-tag-wrapper">
  <div class="slug">Advertisement</div>  <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-leaderboard1");
    });
  </script>
</div>
</div>	</div>

</div>
    </div>
  </div>

  <header class="header" id="header" role="banner">

    <!-- Toggles -->
    <div class="header__toggles">
      <a id="nav__toggle" href="#"><span></span></a>
      <a id="search__toggle" href="#"><span></span></a>
    </div>

    <div class="header__inner">
      <div class="container header__container">

                  <div class="header__site-info" id="name-and-slogan">

                          <a href="/" title="Home" rel="home" class="header__logo" id="logo"><img src="https://www.linux.com/sites/all/themes/custom/lcom/logo.png" alt="Home" class="header__logo-image" /></a>
            
            
                          <div class="header__site-slogan" id="site-slogan">News for the Open Source Professional</div>
                      </div>
        
        
          <div class="header__region region region-header">
    
<div id="block-linux-user-login-logout-links" class="block block-linux-user first odd ">

    
	<div class="block__content">
	  <a href="/cas?destination=node/804737" rel="noindex, nofollow">Login / Create Account</a>	</div>

</div>

<div id="block-menu-menu-join-us" class="block block-menu even join-us" role="navigation">

    
	<div class="block__content">
	  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="https://www.facebook.com/TheLinuxFoundation" class="menu__link addthis-facebook" target="_blank">Facebook</a></li>
<li class="menu__item is-leaf leaf"><a href="https://twitter.com/linuxfoundation" class="menu__link addthis-twitter" target="_blank">Twitter</a></li>
<li class="menu__item is-leaf leaf"><a href="https://plus.google.com/105083814157272466314" class="menu__link addthis-googleplus" target="_blank">Google Plus</a></li>
<li class="menu__item is-leaf leaf"><a href="http://www.linkedin.com/groups?gid=48682" class="menu__link addthis-linkedin" target="_blank">LinkedIn</a></li>
<li class="menu__item is-leaf last leaf"><a href="/feeds" class="menu__link addthis-rss">Feeds</a></li>
</ul>	</div>

</div>

<div id="block-boxes-brought-lf" class="block block-boxes block-boxes-simple last odd lf-brought">

    
	<div class="block__content">
	  <div id='boxes-box-brought_lf' class='boxes-box'><div class="boxes-box-content">
      <p><span>Brought to you by</span> <a href="http://www.linuxfoundation.org"><img alt="Linux Foundation" src="/sites/all/themes/custom/lcom/images/lf/logo-header.png" /></a></p></div></div>	</div>

</div>
  </div>

      </div>

        
<nav class="main-menu" role="navigation">
  <div class="container">

    
    
    <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/news" class="menu__link">News</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/news/category/enterprise" class="menu__link">Enterprise</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/desktop" class="menu__link">Desktop</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/embeddedmobile" class="menu__link">Mobile &amp; Embedded</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/open-source-practices" class="menu__link">Open Source</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/linux-kernel" class="menu__link">Linux Kernel</a></li>
<li class="menu__item is-leaf leaf"><a href="/devops" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf"><a href="/networking" class="menu__link">Networking</a></li>
<li class="menu__item is-leaf last leaf"><a href="/cloud" class="menu__link">Cloud Computing</a></li>
</ul></li>
<li class="menu__item is-leaf leaf"><a href="/tutorials" class="menu__link">Tutorials</a></li>
<li class="menu__item is-leaf leaf"><a href="/blogs/linux-foundation" class="menu__link expanded">Open Source Pro</a></li>
<li class="menu__item is-expanded expanded"><span class="menu__link nolink">Learn</span><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/what-is-linux" class="menu__link">What is Linux?</a></li>
<li class="menu__item is-leaf leaf"><a href="/learn/training" class="menu__link">Training</a></li>
<li class="menu__item is-leaf leaf"><a href="/certification" class="menu__link">Certification</a></li>
<li class="menu__item is-leaf leaf"><a href="/events" class="menu__link">Events</a></li>
<li class="menu__item is-leaf last leaf"><a href="/blog/upcoming-free-webinars-linux-foundation" class="menu__link">Webinars</a></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/community" class="menu__link">Community</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/community/participate" class="menu__link">Participate</a></li>
<li class="menu__item is-leaf leaf"><a href="/answers" class="menu__link">Q&amp;A</a></li>
<li class="menu__item is-leaf leaf"><a href="/forum" class="menu__link">Forums</a></li>
<li class="menu__item is-leaf last leaf"><a href="/community/blogs" class="menu__link">Blogs</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded"><span class="menu__link nolink">Resources</span><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/resources/newsletter" class="menu__link">Newsletter</a></li>
<li class="menu__item is-leaf leaf"><a href="/distributions" class="menu__link">Distributions</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/publications" class="menu__link">Publications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/infographics" class="menu__link">Infographics</a></li>
<li class="menu__item is-leaf leaf"><a href="/photos" class="menu__link">Photos</a></li>
<li class="menu__item is-leaf leaf"><a href="/videos" class="menu__link">Videos</a></li>
<li class="menu__item is-leaf last leaf"><a href="/linux-and-open-source-jobs" class="menu__link">Jobs</a></li>
</ul></li>
</ul>
  </div>
</nav><!-- /#navigation -->

<div id="block-views-ed07b1def74a71b1f939ef53b3d18ead" class="block block-views last even search-block">

  <div class="container">
        
    <a id="search__toggle_desktop" href="#"><span></span></a>

    <div class="block__content">
      <form action="/search" method="get" id="views-exposed-form-linux-search-node-panel-pane-1" accept-charset="UTF-8"><div><div class="views-exposed-form">
  <div class="views-exposed-widgets clearfix">
          <div id="edit-keyword-wrapper" class="views-exposed-widget views-widget-filter-search_api_views_fulltext">
                        <div class="views-widget">
          <div class="form-item form-type-textfield form-item-keyword">
 <input type="text" id="edit-keyword" name="keyword" value="" size="30" maxlength="128" class="form-text required error" />
</div>
        </div>
              </div>
                    <div class="views-exposed-widget views-submit-button">
      <input type="submit" id="edit-submit-linux-search-node" name="" value="Search" class="form-submit" />    </div>
      </div>
</div>
</div></form>    </div>
  </div>

</div>

    </div>
  </header>

  
  <div id="main">
    <div class="container">
      <div id="content" class="column" role="main">
                        <a id="main-content"></a>
                                                                


<div class="lcom-stacked__header"><div class="panel-pane pane-entity-field pane-user-field-profile-image node-author-image"  >
  
      
  
  <div class="field field-name-field-profile-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/users/ericstephenbrown"><img typeof="foaf:Image" src="https://www.linux.com/sites/lcom/files/styles/author_profile_image_24x24/public/profile_image/42808.jpg?itok=PHrTCuUY" width="30" height="30" alt="" /></a></div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-real-author-name-linked-panel-pane-1 node-author"  >
  
      
  
  <div id="view-id-real_author_name_linked-panel_pane_1" class="view view-real-author-name-linked view-id-real_author_name_linked view-display-id-panel_pane_1 view-dom-id-d052712d96b7cdc841bcea3c7e56a5c3">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-linux-name">        <div class="field-content"><a href="/users/ericstephenbrown">Eric Brown</a></div>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-node-created node-date"  >
  
      
  
  April 25, 2018
  
  </div>
</div><div class="lcom-stacked__main"><div class="panel-pane pane-node-title"  >
  
      
  
  <h1>Developers: Prepare Your Drivers for Real-Time Linux</h1>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-image"  >
  
      
  
  <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><div id="file-8417" class="file file-image file-image-jpeg">

        <h2 class="element-invisible"><a href="/files/images/drivers-chuttersnap-unsplashjpg">drivers-chuttersnap-unsplash.jpg</a></h2>
    
  
  <div class="content">
    <img typeof="foaf:Image" src="https://www.linux.com/sites/lcom/files/styles/rendered_file/public/drivers-chuttersnap-unsplash.jpg?itok=DXyZ4WRq" alt="" /><div class="group-file-info field-group-div"><div class="field field-name-field-caption field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"> Linux device driver authors will need to ensure that their drivers play nice with RT-enabled kernels.</div></div></div><div class="field field-name-field-license field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/licenses/category/creative-commons-zero" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Creative Commons Zero</a></div></div></div><div class="field field-name-field-source field-type-link-field field-label-hidden"><div class="field-items"><div class="field-item even">Unsplash - photo by Chuttersnap</div></div></div></div>  </div>

  
</div>
</div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-body"  >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><span><span>Although Real-Time Linux (RT Linux) has been a staple at Embedded Linux Conferences for years -- here’s a </span><a href="http://linuxdevices.io/28-papers-on-real-time-and-embedded-linux/"><span>story</span></a><span> on the RT presentations in 2007 -- many developers have viewed the technology to be peripheral to their own embedded projects. Yet as RT, enabled via the </span><a href="https://wiki.linuxfoundation.org/realtime/start"><span>PREEMPT_RT patch,</span></a><span> prepares to be fully integrated into the mainline kernel, a wider circle of developers should pay attention. In particular, Linux device driver authors will need to ensure that their drivers play nice with RT-enabled kernels.</span></span></p>
</p>
<div class="media media-element-container media-image_left">
<div id="file-8431" class="file file-image file-image-jpeg">
<h2 class="element-invisible"><a href="/files/images/julia-cartwrightzjpg">julia-cartwright_z.jpg</a></h2>
<div class="content">
    <img class="media-element file-image-left" data-delta="1" typeof="foaf:Image" src="https://www.linux.com/sites/lcom/files/styles/floated_images/public/julia-cartwright_z.jpg?itok=BxUxRZgS" width="517" height="400" alt="Julia Cartwright" title="Julia Cartwright" /><br />
<div class="group-file-info field-group-div">
<div class="field field-name-field-caption field-type-text-long field-label-hidden">
<div class="field-items">
<div class="field-item even">Julia Cartwright speaking at Embedded Linux Conference.</div>
</div>
</div>
<div class="field field-name-field-license field-type-taxonomy-term-reference field-label-hidden">
<div class="field-items">
<div class="field-item even"><a href="/licenses/category/linux-foundation" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">The Linux Foundation</a></div>
</div>
</div>
</div>
</div>
</div>
</div>
<p>At the recent <a href="https://events.linuxfoundation.org/events/elc-openiot-north-america-2018/"><span>Embedded Linux Conference in Portland</span></a><span>, National Instruments software engineer Julia Cartwright, an acting maintainer on a stable release of the RT patch, gave a well-attended presentation called “What Every Driver Developer Should Know about RT.” Cartwright started with an overview of RT, which helps provide guarantees for user task execution for embedded applications that require a high level of determinism. She then described the classes of driver-related problems that can have a detrimental impact to RT, as well as potential resolutions. </span></p>
<p><span><span>One of the challenges of any real-time operating system is that most target applications have two types of </span><span>tasks: those with real-time requirements and latency sensitivity, and those for non-time critical tasks such as disk monitoring, throughput, or I/O. “The two classes of tasks need to run together and maybe communicate with one another with mixed criticality,” explained Cartwright. “You must resolve two different degrees of time sensitivity.”</span></span></p>
<p><span><span>One solution is to split the tasks by using two different hardware platforms. “You could have an Arm Cortex-R, FPGA, or PLD based board for super time-critical stuff, and then a Cortex-A series board with Linux,” said Cartwright. “This offers the best isolation, but it raises the per unit costs, and it’s hard to communicate between the domains.”</span></span></p>
<p><span><span>Another approach is to use the virtualization approach provided by </span><a href="http://linuxgizmos.com/real-time-linux-explained/"><span>Xenomai</span></a><span>, the other major Linux-based solution aside from </span><span>PREEMPT_RT. “Xenomai </span><span>follows a hypervisor, co-kernel approach using a hypervisor or AMP solution to separate an RTOS from Linux,” said Cartwright. “However, there’s still a tradeoff in limited communications between the two systems.”</span></span></p>
<p><span><span>RT Linux’s PREEMPT_RT, meanwhile, enables the two systems to share a kernel, scheduler, device stack, and subsystems. In addition, Linux IPC mechanisms can be used to communicate between the two. “There’s not as much isolation, but much greater communication and usability,” said Cartwright.</span></span></p>
<p><span><span>One challenge with RT is that “because the drivers are shared between the real-time and non real-time systems, they can misbehave,” said Cartwright. </span><span>“</span><span>A lot of the bugs we’re finding in RT come from device drivers.”</span></span></p>
<p><span><span>In RT, the time between when an event occurs – such as a timer firing an interrupt or an I/O device requesting service – and the time when the real-time task executes is called the delta. “RT systems try to characterize and bound this in some meaningful way,” explained Cartwright. “A cylic test takes a time stamp, then sleeps for a set time such as 10ms, and then takes a time stamp when the thread wakes up. The difference between the time stamps, which is the amount of time the thread slept, is called the delta.”</span></span></p>
<p><span><span>This delta can be broken down into two phases. The first is the </span><span>irq_dispatch</span><span>, which is the time it takes between the hardware firing and the dispatch occurring up until the time the thread scheduler is instructed that the thread needs to run. The second phase is scheduling latency, the time between when the scheduler has been made aware that a high priority task needs to run to the moment when the CPU is given the task to execute. </span></span></p>
<h3><span><span>irq_dispatch latency</span></span></h3>
<p><span><span>When using mainline Linux without RT extensions, irq_dispatch latency can be considerable. “Say you have one thread executing in user mode, and an external interrupt such as a network event fires that you don’t care about in your real time app,” said Cartwright. “But the CPU is going to vector off to into hard interrupt context and start executing the handler associated with that network device. If during that interrupt handler duration, a high priority event fires, it’s not able to be scheduled on the CPU until the low priority interrupt is done executing.”</span></span></p>
<p><span><span>The delta between the internal event firing and the external event “is a direct contributor to irq_dispatch latency,” said Cartwright. “Without an RT patch it would be a mess to define bounds on this because the bound would be the bound of the longest running interrupt handler in the system.”</span></span></p>
<p><span><span>RT avoids this latency by forcing irq threads. “There’s very little code that we execute in a hard interrupt context – just little shims that wake up the threads that are going to execute your handler,” said Cartwright. “You may have a low priority task running, and perhaps also a medium priority task that the irq fires, but only a small portion of time is spent waking up the associated handlers for the threads.”</span></span></p>
<p><span><span>RT also provides other guarantees. For example, because interrupt handlers are now running in a thread, it can be preempted. “If a high priority, real-time critical interrupt fires, that thread can be scheduled immediately, which reduces the irq_dispatch latency,” said Cartwright.</span></span></p>
<p><span><span>Cartwright said that most drivers require no modification to participate in forced irq threading. In fact, “Thread irq actually exists in mainline now. You can boot a kernel and pass the thread irq parameter and it will thread all your interrupts. RT will add a forced enablement.”</span></span></p>
<p><span><span>Yet there are a few cases when this causes problems. “If your drivers are invoked in the process of delivering an interrupt dispatch, you can’t be threaded,” said Cartwright. “This can happen with </span><a href="https://github.com/torvalds/linux/tree/master/include/linux/irqchip"><span>irqchip</span></a><span> implementations, which should not be threaded. Another issue may arise if the driver is invoked by the scheduler.”</span></span></p>
<p><span><span>Other glitches can emerge when “explicitly disabling interrupts using local_irq_disable or local_irq_save. Cartwright recommended against using such commands in drivers. As an alternative to local_irq_disable, Cartwright suggested using spinlocks or local locks, a new feature that will soon be proposed for mainline. </span><span>In a separate presentation at ELC 2018, called </span><a href="https://www.youtube.com/watch?v=pIJ3Zv_uxn0&amp;index=44&amp;list=PLbzoR-pLrL6qAnHzPdrTxwCUWPja5KnOq"><span>Maintaining a Real Time Stable Kernel</span></a><span>, Linux kernel developer </span><a href="https://www.linuxfoundation.org/blog/linux-kernel-developer-steven-rostedt/"><span>Steven Rostedt</span></a><span> goes into greater depth on local locks.</span></span></p>
<p><span><span>Cartwright finished up her discussion of irq_dispatch latency issues by discussing some rare, hardware related MMIO issues that can occur. Once when she accidentally pulled the Ethernet cable during testing, it caused buffering in the interconnect, which screwed up the interrupts and was a pain to fix. “To solve it we had to follow each write by a readback, which prevents write stacking,” she said. The ultimate solution? “Take the drugs away from the hardware people.” </span></span></p>
<h3><span><span>Scheduling latency</span></span></h3>
<p><span><span>There appear to be fewer driver problems related to the second latency phase – scheduling – which is the time from when you execute a real-time thread to the time when the irq thread is scheduled. One example stems from the use of preempt_disable, when prevents a higher priority thread to be scheduled upon return from interrupt because preemption has been disabled.</span></span></p>
<p><span><span>“The only reason for a device driver to use preempt_disable is if you need to synchronize with the act of scheduling itself, which can happen with cpufreq and cpuidle,” said Cartwright. “Use local locks instead.”</span></span></p>
<p><span><span>On mainline Linux, spinlock-protected critical sections are</span><span> </span><span>implicitly executed with preemption disabled, which can similarly lead to latency problems. </span><span>“With RT we solve this by making spinlock preemptible in critical sections,” said Cartwright. “We turn them into pi-aware mutexes and disable migration. When a spinlock is held by a thread it can be preempted by a higher priority thread to bring in the outer bound.”</span></span></p>
<p><span><span>Most drivers require no changes in order to have their spinlock critical sections preemptible, said Cartwright. However, if a driver is involved in interrupt dispatch or scheduling, they must use raw_spin_lock(), and all critical sections must be made minimal and bounded.</span></span></p>
<p><em><span><span>You can watch the complete presentation below:</span></span></em></p>
<p><iframe frameborder="0" height="315" src="https://www.youtube.com/embed/-J0y_usjYxo" width="560"></iframe></p>
<p>Join us at <a href="https://events.linuxfoundation.org/events/elc-openiot-europe-2018/">Open Source Summit + Embedded Linux Conference Europe</a><span> in Edinburgh, UK on </span><span class="m_4731627503274463177m_3109560012237893168gmail-aBn"><span class="m_4731627503274463177m_3109560012237893168gmail-aQJ"><span class="aBn"><span class="aQJ">October 22-24, 2018</span></span></span></span><span>, for 100+ sessions on Linux, Cloud, Containers, AI, Community, and more. </span></p>
<p><iframe frameborder="0" height="150" src="https://www2.thelinuxfoundation.org/l/6342/2018-04-05/3z7t95" style="border:0;" width="100%"></iframe></p>
</div></div></div>
  
  </div>
<div class="panel-pane pane-node-links link-wrapper"  >
  
      
  
  <ul class="links inline"><li class="addtoany first"><span><span class="a2a_kit a2a_target addtoany_list" id="da2a_1">
      
      <a class="a2a_dd addtoany_share_save" href="https://www.addtoany.com/share#url=https%3A%2F%2Fwww.linux.com%2Fblog%2Felc%2F2018%2F4%2Fdevelopers-prepare-your-drivers-real-time-linux&amp;title=Developers%3A%20Prepare%20Your%20Drivers%20for%20Real-Time%20Linux"></a>
      <a class="a2a_button_email"></a>
    <a class="a2a_button_facebook"></a>
    <a class="a2a_button_twitter"></a>
    <a class="a2a_button_linkedin"></a>
    <a class="a2a_button_pinterest"></a>
    <a class="a2a_button_google_plus"></a>
    </span>
    <script type="text/javascript">
<!--//--><![CDATA[//><!--
if(window.da2a)da2a.script_load();
//--><!]]>
</script></span></li>
<li class="comment_forbidden"><span><a href="/user/login?destination=node/804737%23comment-form">Log in</a> or <a href="/user/register?destination=node/804737%23comment-form">register</a> to post comments</span></li>
<li class="print_html"><a href="/print/804737" title="Display a printer-friendly version of this page." class="print-page" rel="nofollow">Print This</a></li>
<li class="flag-imagex_node_like last"><span><span class="flag-wrapper flag-imagex-node-like flag-imagex-node-like-804737">
      <a href="/flag/flag/imagex_node_like/804737?destination=node/804737&amp;token=e43b274522e04d13779e4a4f65008dd0" title="" class="flag flag-action flag-link-toggle" rel="nofollow">Like</a><span class="flag-throbber">&nbsp;</span>
          (<span class="flag-counter">0 likes</span>)
  </span>
</span></li>
</ul>
  
  </div>
</div><a href="/popup/nojs" class="ctools-use-modal ctools-modal-subscription-modal-style element-invisible" title="">Click Here!</a>      </div>

      
              <aside class="sidebars">
                      <section class="region region-sidebar-second column sidebar">
    
<div id="block-dfp-box1" class="block block-dfp first odd ">

    
	<div class="block__content">
	  <div id="dfp-ad-box1-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-box1" class="dfp-tag-wrapper">
  <div class="slug">Advertisement</div>  <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-box1");
    });
  </script>
</div>
</div>	</div>

</div>

<section id="block-views-training-block-1" class="block block-views even lf-training-block">

    	<header>
	    <h2 class="block__title block-title">Training</h2>
		</header>
	  
	<div class="block__content">
	  <div id="view-id-training-block_1" class="view view-training view-id-training view-display-id-block_1 view-dom-id-f806b80f44fe3098c54a7cf855a292cf">
            <div class="view-header">
      <div class="see_all_button"><a href="/learn/training">See all</a></div>
    </div>
  
  
  
      <div class="view-content">
          <ul>          <li class="views-row views-row-1 views-row-odd views-row-first">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfs301-linux-system-administration-23">LFS301 Linux System Administration</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2018-05-07T00:00:00+00:00">May 7, 2018</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/system-administration-training/linux-system-administration">Learn more</a></div>  </div></li>
          <li class="views-row views-row-2 views-row-even">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfs462-open-source-virtualization-11">LFS462 Open Source Virtualization</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2018-05-14T00:00:00+00:00">May 14, 2018</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/system-administration-training/open-source-virtualization">Learn more</a></div>  </div></li>
          <li class="views-row views-row-3 views-row-odd views-row-last">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfs426-linux-performance-tuning-16">LFS426 Linux Performance Tuning</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2018-05-14T00:00:00+00:00">May 14, 2018</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/system-administration-training/linux-performance-tuning">Learn more</a></div>  </div></li>
      </ul>    </div>
  
  
  
  
  
  
</div>	</div>

</section>

<section id="block-linux-blocks-pardot-newsletter-signup-form" class="block block-linux-blocks odd ">

    	<header>
	    <h2 class="block__title block-title">Newsletter</h2>
		</header>
	  
	<div class="block__content">
	  <iframe src="//go.pardot.com/l/6342/2011-03-24/1ATL" width="100%" height="420px" type="text/html" frameborder="0" allowTransparency="true" style="border: 0"></iframe>	</div>

</section>

<section id="block-views-linux-jobs-related-jobs-block" class="block block-views last even ">

    	<header>
	    <h2 class="block__title block-title">Related Jobs</h2>
		</header>
	  
	<div class="block__content">
	  <div id="view-id-linux_jobs-related_jobs_block" class="view view-linux-jobs view-id-linux_jobs view-display-id-related_jobs_block view-dom-id-e61d05500d6609a7f6c68ed9ba2aebc1">
        
  
  
      <div class="view-empty">
      <div id="view-id-linux_jobs-all_jobs_block" class="view view-linux-jobs view-id-linux_jobs view-display-id-all_jobs_block view-dom-id-5e15265f64dfedda3ea2fdc52ad82ceb">
        
  
  
  
  
  
  
  
  
</div>    </div>
  
  
  
  
  
  
</div>	</div>

</section>
  </section>
        </aside>
      
    </div>
  </div>

  
    <footer id="footer" class="region region-footer">
  	<div class="container">
    	
<div id="block-menu-block-1" class="block block-menu-block first odd lf-footer-primary-menu footer-menu" role="navigation">

    
	<div class="block__content">
	  <div class="menu-block-wrapper menu-block-1 menu-name-main-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-expanded first expanded menu-mlid-1275"><a href="/news" class="menu__link">News</a><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1281"><a href="/news/category/enterprise" class="menu__link">Enterprise</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1282"><a href="/news/category/desktop" class="menu__link">Desktop</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1283"><a href="/news/category/embeddedmobile" class="menu__link">Mobile &amp; Embedded</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1284"><a href="/news/category/open-source-practices" class="menu__link">Open Source</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1285"><a href="/news/category/linux-kernel" class="menu__link">Linux Kernel</a></li>
<li class="menu__item is-leaf leaf menu-mlid-5595"><a href="/devops" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf menu-mlid-5596"><a href="/networking" class="menu__link">Networking</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-5597"><a href="/cloud" class="menu__link">Cloud Computing</a></li>
</ul></li>
<li class="menu__item is-leaf leaf menu-mlid-1276"><a href="/tutorials" class="menu__link">Tutorials</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1277"><a href="/blogs/linux-foundation" class="menu__link expanded">Open Source Pro</a></li>
<li class="menu__item is-expanded expanded menu-mlid-1278"><span class="menu__link nolink">Learn</span><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1292"><a href="/what-is-linux" class="menu__link">What is Linux?</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1293"><a href="/learn/training" class="menu__link">Training</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1294"><a href="/certification" class="menu__link">Certification</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1295"><a href="/events" class="menu__link">Events</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1296"><a href="/blog/upcoming-free-webinars-linux-foundation" class="menu__link">Webinars</a></li>
</ul></li>
<li class="menu__item is-expanded expanded menu-mlid-1279"><a href="/community" class="menu__link">Community</a><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1297"><a href="/community/participate" class="menu__link">Participate</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1298"><a href="/answers" class="menu__link">Q&amp;A</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1299"><a href="/forum" class="menu__link">Forums</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1300"><a href="/community/blogs" class="menu__link">Blogs</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded menu-mlid-1280"><span class="menu__link nolink">Resources</span><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1301"><a href="/resources/newsletter" class="menu__link">Newsletter</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1303"><a href="/distributions" class="menu__link">Distributions</a></li>
<li class="menu__item is-leaf leaf menu-mlid-3808"><a href="/resources/publications" class="menu__link">Publications</a></li>
<li class="menu__item is-leaf leaf menu-mlid-3809"><a href="/resources/infographics" class="menu__link">Infographics</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1286"><a href="/photos" class="menu__link">Photos</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1287"><a href="/videos" class="menu__link">Videos</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-10188"><a href="/linux-and-open-source-jobs" class="menu__link">Jobs</a></li>
</ul></li>
</ul></div>
	</div>

</div>

<div id="block-menu-menu-footer" class="block block-menu even lf-footer-about-menu footer-menu" role="navigation">

    
	<div class="block__content">
	  <ul class="menu"><li class="menu__item is-expanded first last expanded"><a href="/about" class="menu__link">About Linux.com</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/terms-of-use" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="/privacy-policy" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/editorial-policy" class="menu__link">Editorial Policy</a></li>
<li class="menu__item is-leaf last leaf"><a href="/contact" class="menu__link">Contact</a></li>
</ul></li>
</ul>	</div>

</div>

<div id="block-boxes-about-lf" class="block block-boxes block-boxes-simple odd lf-about">

    
	<div class="block__content">
	  <div id='boxes-box-about_lf' class='boxes-box'><div class="boxes-box-content">
        <p><a href="http://www.linuxfoundation.org"><img alt="Linux Foundation" src="/sites/all/themes/custom/lcom/images/lf/logo-footer.png" /></a></p>
        <p>The Linux Foundation is a non-profit consortium enabling collaboration and innovation through an open source development model.</p>
        <p><a href="http://www.linuxfoundation.org" class="more">Learn More</a></p></div></div>	</div>

</div>

<div id="block-linux-blocks-linux-accelerated-by" class="block block-linux-blocks even ">

    
	<div class="block__content">
	  <div class="row"><p>Accelerated by</p></div><div class="row"><a href="http://www.fastly.com"><img typeof="foaf:Image" src="https://www.linux.com/sites/all/themes/custom/lcom/images/fastly-logo.png" width="60px" alt="Fastly" title="Fastly" /></a></div><div class="row"><a href="http://www.dnsmadeeasy.com"><img class="dns-made-easy-logo" typeof="foaf:Image" src="https://www.linux.com/sites/all/themes/custom/lcom/images/dns-made-easy-logo.png" width="100px" alt="DNS Made Easy" title="DNS Made Easy" /></a></div>	</div>

</div>

<div id="block-boxes-copyright-infos" class="block block-boxes block-boxes-simple last odd lf-copyright">

    
	<div class="block__content">
	  <div id='boxes-box-copyright_infos' class='boxes-box'><div class="boxes-box-content"><p>&copy; 2016 The Linux Foundation</p></div></div>	</div>

</div>
  	</div>
  </footer>

</div>


  <script src="https://www.linux.com/sites/lcom/files/js/js_EIY91SVu4Ez1BN8UI_1XQnC6AJTb65-lR4DGrCwCjos.js"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_7h324ifclLGYFxFoatQ4-wnM2It7bPCH8oukRlW-nkY.js"></script>
<script>da2a.targets=[
{title:"Developers: Prepare Your Drivers for Real-Time Linux",url:"https:\/\/www.linux.com\/blog\/elc\/2018\/4\/developers-prepare-your-drivers-real-time-linux"}];
da2a.html_done=true;if(da2a.script_ready&&!da2a.done)da2a.init();da2a.script_load();</script>
</body>
</html>
