<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Unikraft: Pushing Unikernels into the Mainstream - Linux.com</title>
    <meta charset="UTF-8" /><script type="text/javascript">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</script>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.linux.com/xmlrpc.php" />
    
<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><link rel="icon" type="image/png" href="https://www.linux.com/wp-content/uploads/2019/08/favicon-300x300.png">
<!-- This site is optimized with the Yoast SEO Premium plugin v11.9 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.linux.com/featured/unikraft-pushing-unikernels-into-the-mainstream/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Unikraft: Pushing Unikernels into the Mainstream - Linux.com" />
<meta property="og:description" content="Unikernels have been around for many years and are famous for providing excellent performance in boot times, throughput, and memory consumption, to name a few metrics [1]. Despite their apparent potential, unikernels have not yet seen a broad level of deployment due to three main drawbacks: Hard to build: Putting a unikernel image together typically &hellip;" />
<meta property="og:url" content="https://www.linux.com/featured/unikraft-pushing-unikernels-into-the-mainstream/" />
<meta property="og:site_name" content="Linux.com" />
<meta property="article:section" content="Featured" />
<meta property="article:published_time" content="2021-02-11T18:00:15-08:00" />
<meta property="article:modified_time" content="2021-02-11T18:49:20-08:00" />
<meta property="og:updated_time" content="2021-02-11T18:49:20-08:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Unikernels have been around for many years and are famous for providing excellent performance in boot times, throughput, and memory consumption, to name a few metrics [1]. Despite their apparent potential, unikernels have not yet seen a broad level of deployment due to three main drawbacks: Hard to build: Putting a unikernel image together typically [&hellip;]" />
<meta name="twitter:title" content="Unikraft: Pushing Unikernels into the Mainstream - Linux.com" />
<meta name="twitter:image" content="https://www.linux.com/wp-content/uploads/2021/02/unikraft.svg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.linux.com/#website","url":"https://www.linux.com/","name":"Linux.com","potentialAction":{"@type":"SearchAction","target":"https://www.linux.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.linux.com/featured/unikraft-pushing-unikernels-into-the-mainstream/#primaryimage","url":"https://www.linux.com/wp-content/uploads/2021/02/unikraft.svg","width":595,"height":239},{"@type":"WebPage","@id":"https://www.linux.com/featured/unikraft-pushing-unikernels-into-the-mainstream/#webpage","url":"https://www.linux.com/featured/unikraft-pushing-unikernels-into-the-mainstream/","inLanguage":"en-US","name":"Unikraft: Pushing Unikernels into the Mainstream - Linux.com","isPartOf":{"@id":"https://www.linux.com/#website"},"primaryImageOfPage":{"@id":"https://www.linux.com/featured/unikraft-pushing-unikernels-into-the-mainstream/#primaryimage"},"datePublished":"2021-02-11T18:00:15-08:00","dateModified":"2021-02-11T18:49:20-08:00","author":{"@id":"https://www.linux.com/#/schema/person/4cffccf840bf16194ac0bf44fac5c5b8"}},{"@type":["Person"],"@id":"https://www.linux.com/#/schema/person/4cffccf840bf16194ac0bf44fac5c5b8","name":"Linux.com Editorial Staff","image":{"@type":"ImageObject","@id":"https://www.linux.com/#authorlogo","url":"https://www.linux.com/wp-content/uploads/2020/03/avatar-96x96.png","caption":"Linux.com Editorial Staff"},"description":"The editorial team for Linux.com.","sameAs":[]}]}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//www.linux.com' />
<link rel='dns-prefetch' href='//js.hs-scripts.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Linux.com &raquo; Feed" href="https://www.linux.com/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.linux.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://www.linux.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://www.linux.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=c784b8db3e66cd68082f3ff7aa2d70e6' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=10.3.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://www.linux.com/wp-content/themes/Newspaper/style.css?ver=10.3.9.1' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-theme-child-css'  href='https://www.linux.com/wp-content/themes/Newspaper-child/style.css?ver=10.3.9.1c' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://www.linux.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=c784b8db3e66cd68082f3ff7aa2d70e6' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://www.linux.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=6b62588d33477b8e3dc5b8b3c9c8d86c' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css'  href='https://www.linux.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=a50385a2d79d6600973a7e697f735a0b' type='text/css' media='all, print' />
<script type='text/javascript' src='https://www.linux.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.linux.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.linux.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.11.6' id='gtm4wp-form-move-tracker-js'></script>
<link rel="https://api.w.org/" href="https://www.linux.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.linux.com/wp-json/wp/v2/posts/582597" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.linux.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.linux.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6.1" />
<link rel='shortlink' href='https://www.linux.com/?p=582597' />
<link rel="alternate" type="application/json+oembed" href="https://www.linux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linux.com%2Ffeatured%2Funikraft-pushing-unikernels-into-the-mainstream%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.linux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linux.com%2Ffeatured%2Funikraft-pushing-unikernels-into-the-mainstream%2F&#038;format=xml" />
			<!-- DO NOT COPY THIS SNIPPET! Start of Page Analytics Tracking for HubSpot WordPress plugin v7.51.34-->
			<script type="text/javascript">
				var _hsq = _hsq || [];
				_hsq.push(["setContentType", "blog-post"]);
			</script>
			<!-- DO NOT COPY THIS SNIPPET! End of Page Analytics Tracking for HubSpot WordPress plugin -->
						<script>
				(function() {
					var hbspt = window.hbspt = window.hbspt || {};
					hbspt.forms = hbspt.forms || {};
					hbspt._wpFormsQueue = [];
					hbspt.enqueueForm = function(formDef) {
						if (hbspt.forms && hbspt.forms.create) {
							hbspt.forms.create(formDef);
						} else {
							hbspt._wpFormsQueue.push(formDef);
						}
					}
					if (!window.hbspt.forms.create) {
						Object.defineProperty(window.hbspt.forms, 'create', {
							configurable: true,
							get: function() {
								return hbspt._wpCreateForm;
							},
							set: function(value) {
								hbspt._wpCreateForm = value;
								while (hbspt._wpFormsQueue.length) {
									var formDef = hbspt._wpFormsQueue.shift();
									if (!document.currentScript) {
										var formScriptId = 'leadin-forms-v2-js';
										hubspot.utils.currentScript = document.getElementById(formScriptId);
									}
									hbspt._wpCreateForm.call(hbspt.forms, formDef);
								}
							},
						});
					}
				})();
			</script>
		
<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pagePostType":"post","pagePostType2":"single-post","pageCategory":["cloud","featured","high-performance","open-source","thelinuxfoundation"],"pagePostAuthor":"Linux.com Editorial Staff"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NXGNZW');//]]>
</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"b60f935f5e","wpRestUrl":"https:\/\/www.linux.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.linux.com\/wp-admin\/","wpRestNonce":"b60f935f5e","wpRestUrl":"https:\/\/www.linux.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};
			</script>
			<!-- Start of HubSpot Embed Code -->
<script type="text/javascript" id="hs-script-loader" async defer src="//js.hs-scripts.com/8112310.js"></script>
<!-- End of HubSpot Embed Code -->
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>




<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.linux.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.linux.com/topic/",
                    "name": "Topic"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.linux.com/topic/cloud/",
                    "name": "Cloud"                                
                }
            }
            ,{
                "@type": "ListItem",
                "position": 4,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.linux.com/featured/unikraft-pushing-unikernels-into-the-mainstream/",
                    "name": "Unikraft: Pushing Unikernels into the Mainstream"                                
                }
            }    
        ]
    }
</script>

<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #ff6c0e;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #ff6c0e;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #ff6c0e;
                }
                .tdm-btn-style1 {
					background-color: #ff6c0e;
				}
				.tdm-btn-style2:before {
				    border-color: #ff6c0e;
				}
				.tdm-btn-style2 {
				    color: #ff6c0e;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #ff6c0e;
                    -moz-box-shadow: 0 2px 16px #ff6c0e;
                    box-shadow: 0 2px 16px #ff6c0e;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #ff6c0e;
                    -moz-box-shadow: 0 4px 26px #ff6c0e;
                    box-shadow: 0 4px 26px #ff6c0e;
				}
</style>

	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-582597 single-format-standard td-standard-pack unikraft-pushing-unikernels-into-the-mainstream global-block-template-4 single_template_5 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">


        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="td-mobile-main-menu"><li id="menu-item-579695" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-first menu-item-579695"><a href="https://linux.com/">Topic<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-577204" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-577204"><a href="https://www.linux.com/topic/ai-ml/">AI/ML</a></li>
	<li id="menu-item-577207" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-577207"><a href="https://www.linux.com/topic/cloud/">Cloud</a></li>
	<li id="menu-item-577208" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-577208"><a href="https://www.linux.com/topic/desktop/">Desktop</a></li>
	<li id="menu-item-577211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-577211"><a href="https://www.linux.com/topic/embedded-iot/">Embedded/IoT</a></li>
	<li id="menu-item-577212" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-577212"><a href="https://www.linux.com/topic/governance/">Governance</a></li>
	<li id="menu-item-577213" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-577213"><a href="https://www.linux.com/topic/hardware/">Hardware</a></li>
	<li id="menu-item-577215" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-577215"><a href="https://www.linux.com/topic/linux/">Linux</a></li>
	<li id="menu-item-577216" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-577216"><a href="https://www.linux.com/topic/networking/">Networking</a></li>
	<li id="menu-item-577217" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-577217"><a href="https://www.linux.com/topic/open-source/">Open Source</a></li>
	<li id="menu-item-577219" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-577219"><a href="https://www.linux.com/topic/security/">Security</a></li>
	<li id="menu-item-577221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-577221"><a href="https://www.linux.com/topic/system-administration/">System Administration</a></li>
</ul>
</li>
<li id="menu-item-577276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-577276"><a href="https://linux.com/">Audience<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-577235" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-577235"><a href="https://www.linux.com/audience/developers/">Developers</a></li>
	<li id="menu-item-577236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-577236"><a href="https://www.linux.com/audience/devops/">DevOps</a></li>
	<li id="menu-item-577237" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-577237"><a href="https://www.linux.com/audience/enterprise/">Enterprise</a></li>
	<li id="menu-item-579694" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-579694"><a href="https://www.linux.com/audience/enthusiast/">Enthusiast</a></li>
</ul>
</li>
<li id="menu-item-577257" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-577257"><a href="https://linux.com/">Resources<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-577289" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-577289"><a href="/tutorials">Tutorials</a></li>
	<li id="menu-item-577260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-577260"><a target="_blank" href="https://training.linuxfoundation.org/">Training</a></li>
	<li id="menu-item-577261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-577261"><a target="_blank" href="https://training.linuxfoundation.org/full-catalog/?_sft_product_type=certification">Certification</a></li>
	<li id="menu-item-577259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-577259"><a target="_blank" href="https://events.linuxfoundation.org/">Events</a></li>
	<li id="menu-item-577256" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-577256"><a target="_blank" href="https://forum.linuxfoundation.org/">Forums</a></li>
	<li id="menu-item-577274" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-577274"><a href="https://www.linux.com/qa/">Q&#038;A</a></li>
	<li id="menu-item-577268" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-577268"><a href="https://www.linux.com/what-is-linux/">What is Linux?</a></li>
</ul>
</li>
<li id="menu-item-577025" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-577025"><a href="https://www.linux.com/about/">About Us</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                <div class="td-login-register-link">
	                
	                </div>
	                
	                

                </div>
            </div>

            
            
            
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://www.linux.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 6
-->


<div class="td-header-wrap td-header-style-6 ">
    
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            <!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            
                            
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap ">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                
    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://www.linux.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>

<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
                    <a class="td-main-logo" href="https://www.linux.com/">
                <img src="https://www.linux.com/wp-content/uploads/2019/08/ldc-white-272.png" alt="Linux.com" title="Linux.com"/>
                <span class="td-visual-hidden">Linux.com</span>
            </a>
            </div>
    <div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-579695"><a href="https://linux.com/">Topic</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-577204"><a href="https://www.linux.com/topic/ai-ml/">AI/ML</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-577207"><a href="https://www.linux.com/topic/cloud/">Cloud</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-577208"><a href="https://www.linux.com/topic/desktop/">Desktop</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-577211"><a href="https://www.linux.com/topic/embedded-iot/">Embedded/IoT</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-577212"><a href="https://www.linux.com/topic/governance/">Governance</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-577213"><a href="https://www.linux.com/topic/hardware/">Hardware</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-577215"><a href="https://www.linux.com/topic/linux/">Linux</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-577216"><a href="https://www.linux.com/topic/networking/">Networking</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-577217"><a href="https://www.linux.com/topic/open-source/">Open Source</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-577219"><a href="https://www.linux.com/topic/security/">Security</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-577221"><a href="https://www.linux.com/topic/system-administration/">System Administration</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-577276"><a href="https://linux.com/">Audience</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-577235"><a href="https://www.linux.com/audience/developers/">Developers</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-577236"><a href="https://www.linux.com/audience/devops/">DevOps</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-577237"><a href="https://www.linux.com/audience/enterprise/">Enterprise</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-579694"><a href="https://www.linux.com/audience/enthusiast/">Enthusiast</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-577257"><a href="https://linux.com/">Resources</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-577289"><a href="/tutorials">Tutorials</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-577260"><a target="_blank" href="https://training.linuxfoundation.org/">Training</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-577261"><a target="_blank" href="https://training.linuxfoundation.org/full-catalog/?_sft_product_type=certification">Certification</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-577259"><a target="_blank" href="https://events.linuxfoundation.org/">Events</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-577256"><a target="_blank" href="https://forum.linuxfoundation.org/">Forums</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-577274"><a href="https://www.linux.com/qa/">Q&#038;A</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-577268"><a href="https://www.linux.com/what-is-linux/">What is Linux?</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-577025"><a href="https://www.linux.com/about/">About Us</a></li>
</ul></div></div>            </div>
        </div>
    </div>

    
</div>
            </div>

            
<div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-5 ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.linux.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Topic" class="entry-crumb" href="https://www.linux.com/topic/">Topic</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Cloud" class="entry-crumb" href="https://www.linux.com/topic/cloud/">Cloud</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Unikraft: Pushing Unikernels into the Mainstream</span></div></div>
            <div class="td-pb-row">
                                        <div class="td-pb-span12 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-582597" class="post-582597 post type-post status-publish format-standard has-post-thumbnail category-cloud category-featured category-high-performance category-open-source category-thelinuxfoundation" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="https://www.linux.com/topic/">Topic</a></li><li class="entry-category"><a  href="https://www.linux.com/topic/cloud/">Cloud</a></li><li class="entry-category"><a  href="https://www.linux.com/topic/high-performance/">High Performance</a></li><li class="entry-category"><a  href="https://www.linux.com/topic/open-source/">Open Source</a></li><li class="entry-category"><a  href="https://www.linux.com/thelinuxfoundation/">The Linux Foundation</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Unikraft: Pushing Unikernels into the Mainstream</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.linux.com/author/linuxdotcom/">Linux.com Editorial Staff</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-02-11T10:00:15-08:00" >February 11, 2021</time></span>                                        <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-582597">315</span></div>                </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-border td-ps-border-grey td-ps-notext td-ps-icon-color td-ps-text-color td-post-sharing-style16 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.linux.com%2Ffeatured%2Funikraft-pushing-unikernels-into-the-mainstream%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Unikraft%3A+Pushing+Unikernels+into+the+Mainstream&url=https%3A%2F%2Fwww.linux.com%2Ffeatured%2Funikraft-pushing-unikernels-into-the-mainstream%2F&via=Linux.com">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.linux.com/featured/unikraft-pushing-unikernels-into-the-mainstream/&amp;media=https://www.linux.com/wp-content/uploads/2021/02/unikraft.svg&description=Unikraft%3A+Pushing+Unikernels+into+the+Mainstream">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Unikraft%3A+Pushing+Unikernels+into+the+Mainstream %0A%0A https://www.linux.com/featured/unikraft-pushing-unikernels-into-the-mainstream/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.linux.com/featured/unikraft-pushing-unikernels-into-the-mainstream/&title=Unikraft%3A+Pushing+Unikernels+into+the+Mainstream">
                                        <div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div>
                                        <div class="td-social-but-text">Linkedin</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://www.linux.com/featured/unikraft-pushing-unikernels-into-the-mainstream/&title=Unikraft%3A+Pushing+Unikernels+into+the+Mainstream">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=Unikraft: Pushing Unikernels into the Mainstream&body=https://www.linux.com/featured/unikraft-pushing-unikernels-into-the-mainstream/">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content tagdiv-type">
            <p><span style="font-weight: 400;"><img loading="lazy" class="wp-image-582604 aligncenter" role="img" src="https://www.linux.com/wp-content/uploads/2021/02/unikraft.svg" alt="" width="602" height="242" /></span></p>
<p><span style="font-weight: 400;">Unikernels have been around for many years and are famous for providing excellent performance in boot times, throughput, and memory consumption, to name a few metrics [1]. Despite their apparent potential, unikernels have not yet seen a broad level of deployment due to three main drawbacks:</span></p>
<ul>
<li style="font-weight: 400;" aria-level="1"><b>Hard to build</b><span style="font-weight: 400;">: Putting a unikernel image together typically requires expert, manual work that needs redoing for each application. Also, many unikernel projects are not, and don’t aim to be, POSIX compliant, and so significant porting effort is required to have standard applications and frameworks run on them.</span></li>
<li style="font-weight: 400;" aria-level="1"><b>Hard to extract high performance</b><span style="font-weight: 400;">: Unikernel projects don’t typically expose high-performance APIs; extracting high performance often requires expert knowledge and modifications to the code.</span></li>
<li style="font-weight: 400;" aria-level="1"><b>Little or no tool ecosystem</b><span style="font-weight: 400;">: Assuming you have an image to run, deploying it and managing it is often a manual operation. There is little integration with major DevOps or orchestration frameworks.</span></li>
</ul>
<p><span style="font-weight: 400;">While not all unikernel projects suffer from all of these issues (e.g., some provide some level of POSIX compliance but the performance is lacking, others target a single programming language and so are relatively easy to build but their applicability is limited), we argue that no single project has been able to successfully address all of them, hindering any significant level of deployment. For the past three years, Unikraft (www.unikraft.org), a Linux Foundation project under the Xen Project’s auspices, has had the explicit aim to change this state of affairs to bring unikernels into the mainstream. </span></p>
<p><span style="font-weight: 400;">If you’re interested, read on, and please be sure to check out:</span></p>
<ul>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">The </span><a href="https://video.fosdem.org/2021/stands/unikraft/"><span style="font-weight: 400;">replay of our two FOSDEM talks</span></a><span style="font-weight: 400;"> [2,3] and the </span><a href="https://stands.fosdem.org/stands/unikraft/"><span style="font-weight: 400;">virtual stand </span></a></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Our website (unikraft.org) and source code (</span><a href="https://github.com/unikraft"><span style="font-weight: 400;">https://github.com/unikraft</span></a><span style="font-weight: 400;">).</span></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Our upcoming source code release, 0.5 Tethys (more information at </span><a href="http://www.unikraft.org/release/"><span style="font-weight: 400;">http://www.unikraft.org/release/</span></a><span style="font-weight: 400;">)</span></li>
<li style="font-weight: 400;" aria-level="1"><a href="http://www.unikraft.io"><span style="font-weight: 400;">unikraft.io</span></a><span style="font-weight: 400;">, for industrial partners interested in Unikraft PoCs (or <a href="mailto:info@unikraft.io">info@unikraft.io</a>)</span></li>
</ul>
<h2><span style="font-weight: 400;">High Performance</span></h2>
<p><span style="font-weight: 400;">To provide developers with the ability to obtain high performance easily, Unikraft exposes a set of composable, performance-oriented APIs. The figure below shows Unikraft’s architecture: all components are libraries with their own </span><b>Makefile</b><span style="font-weight: 400;"> and </span><b>Kconfig</b><span style="font-weight: 400;"> configuration files, and so can be added to the unikernel build independently of each other.</span></p>
<p><img loading="lazy" class="alignnone size-full wp-image-582599" src="https://www.linux.com/wp-content/uploads/2021/02/unikraft1.png" alt="" width="854" height="599" srcset="https://www.linux.com/wp-content/uploads/2021/02/unikraft1.png 854w, https://www.linux.com/wp-content/uploads/2021/02/unikraft1-300x210.png 300w, https://www.linux.com/wp-content/uploads/2021/02/unikraft1-768x539.png 768w, https://www.linux.com/wp-content/uploads/2021/02/unikraft1-696x488.png 696w, https://www.linux.com/wp-content/uploads/2021/02/unikraft1-599x420.png 599w, https://www.linux.com/wp-content/uploads/2021/02/unikraft1-100x70.png 100w" sizes="(max-width: 854px) 100vw, 854px" /></p>
<p><b>Figure 1. Unikraft ‘s fully modular architecture showing high-performance APIs</b></p>
<p><span style="font-weight: 400;">APIs are also micro-libraries that can be easily enabled or disabled via a Kconfig menu; Unikraft unikernels can compose which APIs to choose to best cater to an application’s needs. For example, an RCP-style application might turn off the </span><b>uksched</b><span style="font-weight: 400;"> API (</span><span style="font-weight: 400;">➃</span><span style="font-weight: 400;"> in the figure) to implement a high performance, run-to-completion event loop; similarly, an application developer can easily select an appropriate memory allocator (</span><span style="font-weight: 400;">➅</span><span style="font-weight: 400;">) to obtain maximum performance, or to use multiple different ones within the same unikernel (e.g., a simple, fast memory allocator for the boot code, and a standard one for the application itself). </span></p>
<table>
<tbody>
<tr>
<td><img loading="lazy" class="alignnone size-full wp-image-582600" src="https://www.linux.com/wp-content/uploads/2021/02/unikraft2.png" alt="" width="656" height="410" srcset="https://www.linux.com/wp-content/uploads/2021/02/unikraft2.png 656w, https://www.linux.com/wp-content/uploads/2021/02/unikraft2-300x188.png 300w" sizes="(max-width: 656px) 100vw, 656px" /></td>
<td><img loading="lazy" class="alignnone size-full wp-image-582601" src="https://www.linux.com/wp-content/uploads/2021/02/unikraft3.png" alt="" width="645" height="403" srcset="https://www.linux.com/wp-content/uploads/2021/02/unikraft3.png 645w, https://www.linux.com/wp-content/uploads/2021/02/unikraft3-300x187.png 300w" sizes="(max-width: 645px) 100vw, 645px" /></td>
</tr>
<tr>
<td><b>Figure 2. Unikraft memory consumption vs. other unikernel projects and Linux</b></td>
<td><b>Figure 3. Unikraft NGINX throughput versus other unikernels, Docker, and Linux/KVM.</b></td>
</tr>
</tbody>
</table>
<p>&nbsp;</p>
<p><span style="font-weight: 400;">These APIs, coupled with the fact that all Unikraft’s components are fully modular, results in high performance. Figure 2, for instance, shows Unikraft having lower memory consumption than other unikernel projects (HermiTux, Rump, OSv) and Linux (Alpine); and Figure 3 shows that Unikraft outperforms them in terms of NGINX requests per second, reaching 90K on a single CPU core.</span></p>
<p><span style="font-weight: 400;">Further, we are working on (1) a performance profiler tool to be able to quickly identify potential bottlenecks in Unikraft images and (2) a performance test tool that can automatically run a large set of performance experiments, varying different configuration options to figure out optimal configurations.</span></p>
<h2><span style="font-weight: 400;">Ease of Use, No Porting Required</span></h2>
<p><span style="font-weight: 400;">Forcing users to port applications to a unikernel to obtain high performance is a showstopper. Arguably, a system is only as good as the applications (or programming languages, frameworks, etc.) can run. Unikraft aims to achieve good POSIX compatibility; one way of doing so is supporting a </span><b>libc</b><span style="font-weight: 400;"> (e.g., <strong>musl)</strong>, along with a large set of Linux syscalls. </span></p>
<p><img loading="lazy" class="alignnone size-full wp-image-582602" src="https://www.linux.com/wp-content/uploads/2021/02/unikraft4.png" alt="" width="837" height="398" srcset="https://www.linux.com/wp-content/uploads/2021/02/unikraft4.png 837w, https://www.linux.com/wp-content/uploads/2021/02/unikraft4-300x143.png 300w, https://www.linux.com/wp-content/uploads/2021/02/unikraft4-768x365.png 768w, https://www.linux.com/wp-content/uploads/2021/02/unikraft4-696x331.png 696w" sizes="(max-width: 837px) 100vw, 837px" /></p>
<p><b>Figure 4. Only a certain percentage of syscalls are needed to support a wide range of applications</b></p>
<p><span style="font-weight: 400;">While there are over 300 of these, many of them are not needed to run a large set of applications; as shown in Figure 1 (taken from [5]). Having in the range of 145, for instance, is enough to support 50% of all libraries and applications in a Ubuntu distribution (many of which are irrelevant to unikernels, such as desktop applications). As of this writing, Unikraft supports over 130 syscalls and a number of mainstream applications (e.g., SQLite, Nginx, Redis), programming languages and runtime environments such as C/C++, Go, Python, Ruby, Web Assembly, and Lua, not to mention several different hypervisors (KVM, Xen, and Solo5) and ARM64 bare-metal support.</span></p>
<h2><span style="font-weight: 400;">Ecosystem and DevOps</span></h2>
<p><span style="font-weight: 400;">Another apparent downside of unikernel projects is the almost total lack of integration with existing, major DevOps and orchestration frameworks. Working towards the goal of integration, in the past year, we created the </span><b>kraft</b><span style="font-weight: 400;"> tool, allowing users to choose an application and a target platform simply (e.g., KVM on x86_64) and take care of building the image running it.</span></p>
<p><span style="font-weight: 400;">Beyond this, we have several sub-projects ongoing to support in the coming months:</span></p>
<ul>
<li style="font-weight: 400;" aria-level="1"><b>Kubernetes</b><span style="font-weight: 400;">: If you’re already using Kubernetes in your deployments, this work will allow you to deploy much leaner, fast Unikraft images </span><i><span style="font-weight: 400;">transparently.</span></i></li>
<li style="font-weight: 400;" aria-level="1"><b>Cloud Foundry</b><span style="font-weight: 400;">: Similarly, users relying on Cloud Foundry will be able to generate Unikraft images through it, once again transparently.</span></li>
<li style="font-weight: 400;" aria-level="1"><b>Prometheus</b><span style="font-weight: 400;">: Unikernels are also notorious for having very primitive or no means for monitoring running instances. Unikraft is targeting Prometheus support to provide a wide range of monitoring capabilities. </span></li>
</ul>
<p><span style="font-weight: 400;">In all, we believe Unikraft is getting closer to bridging the gap between unikernel promise and actual deployment. We are very excited about this year’s upcoming features and developments, so please feel free to drop us a line if you have any comments, questions, or suggestions at </span><a href="mailto:info@unikraft.io"><b>info@unikraft.io</b></a><span style="font-weight: 400;">.</span></p>
<p><em><strong>About the author: <a href="https://www.linkedin.com/in/felipe-huici-47a559127/">Dr. Felipe Huici</a> is Chief Researcher, Systems and Machine Learning Group, NEC Laboratories Europe GmbH</strong></em></p>
<h2><span style="font-weight: 400;">References</span></h2>
<p><span style="font-weight: 400;">[1] Unikernels Rethinking Cloud Infrastructure. </span><a href="http://unikernel.org/"><span style="font-weight: 400;">http://unikernel.org/</span></a></p>
<p><span style="font-weight: 400;">[2] Is the Time Ripe for Unikernels to Become Mainstream with Unikraft? FOSDEM 2021 Microkernel developer room. </span><a href="https://fosdem.org/2021/schedule/event/microkernel_unikraft/"><span style="font-weight: 400;">https://fosdem.org/2021/schedule/event/microkernel_unikraft/</span></a></p>
<p><span style="font-weight: 400;">[3] Severely Debloating Cloud Images with Unikraft. FOSDEM 2021 Virtualization and IaaS developer room. </span><a href="https://fosdem.org/2021/schedule/event/vai_cloud_images_unikraft/"><span style="font-weight: 400;">https://fosdem.org/2021/schedule/event/vai_cloud_images_unikraft/</span></a></p>
<p><span style="font-weight: 400;">[4] Welcome to the Unikraft Stand! </span><a href="https://stands.fosdem.org/stands/unikraft/"><span style="font-weight: 400;">https://stands.fosdem.org/stands/unikraft/</span></a></p>
<p><span style="font-weight: 400;">[5] A study of modern Linux API usage and compatibility: what to support when you&#8217;re supporting. Eurosys 2016. </span><a href="https://dl.acm.org/doi/10.1145/2901318.2901341"><span style="font-weight: 400;">https://dl.acm.org/doi/10.1145/2901318.2901341</span></a></p>
        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

                        <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.linux.com/news/getting-to-know-the-cryptocurrency-open-patent-alliance-copa/">Getting to Know the Cryptocurrency Open Patent Alliance (COPA)</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="author-box-wrap"><a href="https://www.linux.com/author/linuxdotcom/"><img width="96" height="96" src="https://www.linux.com/wp-content/uploads/2020/03/avatar-96x96.png" class="avatar avatar-96 photo" alt="" loading="lazy" srcset="https://www.linux.com/wp-content/uploads/2020/03/avatar-96x96.png 96w, https://www.linux.com/wp-content/uploads/2020/03/avatar-300x300.png 300w, https://www.linux.com/wp-content/uploads/2020/03/avatar-150x150.png 150w, https://www.linux.com/wp-content/uploads/2020/03/avatar-24x24.png 24w, https://www.linux.com/wp-content/uploads/2020/03/avatar-48x48.png 48w, https://www.linux.com/wp-content/uploads/2020/03/avatar.png 400w" sizes="(max-width: 96px) 100vw, 96px" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.linux.com/author/linuxdotcom/">Linux.com Editorial Staff</a></span></div><div class="td-author-description">The editorial team for Linux.com.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div>            <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Linux.com Editorial Staff"></span><meta itemprop="datePublished" content="2021-02-11T10:00:15-08:00"><meta itemprop="dateModified" content="2021-02-11T10:49:20-08:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.linux.com/featured/unikraft-pushing-unikernels-into-the-mainstream/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.linux.com/wp-content/uploads/2019/08/ldc-white-272.png"></span><meta itemprop="name" content="Linux.com"></span><meta itemprop="headline " content="Unikraft: Pushing Unikernels into the Mainstream"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.linux.com/wp-content/uploads/2021/02/unikraft.svg"><meta itemprop="width" content=""><meta itemprop="height" content=""></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td-related-full-width tdi_2_763 td_with_ajax_pagination td-pb-border-top td_block_template_4"  data-td-block-uid="tdi_2_763" ><script>var block_tdi_2_763 = new tdBlock();
block_tdi_2_763.id = "tdi_2_763";
block_tdi_2_763.atts = '{"limit":5,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td-related-full-width tdi_2_763","td_column_number":5,"block_type":"td_block_related_posts","live_filter_cur_post_id":582597,"live_filter_cur_post_author":"61","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_2_763","tdc_css_class_style":"tdi_2_763_rand_style"}';
block_tdi_2_763.td_column_number = "5";
block_tdi_2_763.block_type = "td_block_related_posts";
block_tdi_2_763.post_count = "5";
block_tdi_2_763.found_posts = "5779";
block_tdi_2_763.header_color = "";
block_tdi_2_763.ajax_pagination_infinite_stop = "";
block_tdi_2_763.max_num_pages = "1156";
tdBlocksArray.push(block_tdi_2_763);
</script><h4 class="td-related-title td-block-title"><a id="tdi_3_862" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_2_763" href="#">RELATED ARTICLES</a><a id="tdi_4_0ad" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_2_763" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_2_763 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.linux.com/news/getting-to-know-the-cryptocurrency-open-patent-alliance-copa/" rel="bookmark" class="td-image-wrap " title="Getting to Know the Cryptocurrency Open Patent Alliance (COPA)" ><img width="218" height="150" class="entry-thumb" src="https://www.linux.com/wp-content/uploads/2021/02/crop-copa-linuxdotcom-218x150.jpg"  srcset="https://www.linux.com/wp-content/uploads/2021/02/crop-copa-linuxdotcom-218x150.jpg 218w, https://www.linux.com/wp-content/uploads/2021/02/crop-copa-linuxdotcom-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Getting to Know the Cryptocurrency Open Patent Alliance (COPA)" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.linux.com/news/getting-to-know-the-cryptocurrency-open-patent-alliance-copa/" rel="bookmark" title="Getting to Know the Cryptocurrency Open Patent Alliance (COPA)">Getting to Know the Cryptocurrency Open Patent Alliance (COPA)</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.linux.com/news/understanding-open-governance-networks/" rel="bookmark" class="td-image-wrap " title="Understanding Open Governance Networks" ><img width="218" height="150" class="entry-thumb" src="https://www.linux.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png"  alt="" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.linux.com/news/understanding-open-governance-networks/" rel="bookmark" title="Understanding Open Governance Networks">Understanding Open Governance Networks</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.linux.com/news/linux-is-the-most-in-demand-skill-amongst-hiring-managers-heres-how-you-can-take-advantage/" rel="bookmark" class="td-image-wrap " title="Linux is the Most in Demand Skill Amongst Hiring Managers – Here’s How You Can Take Advantage" ><img width="218" height="150" class="entry-thumb" src="https://www.linux.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png"  alt="" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.linux.com/news/linux-is-the-most-in-demand-skill-amongst-hiring-managers-heres-how-you-can-take-advantage/" rel="bookmark" title="Linux is the Most in Demand Skill Amongst Hiring Managers – Here’s How You Can Take Advantage">Linux is the Most in Demand Skill Amongst Hiring Managers – Here’s How You Can Take Advantage</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.linux.com/featured/how-to-get-started-with-an-open-source-program-office/" rel="bookmark" class="td-image-wrap " title="How to get started with an Open Source Program Office" ><img width="218" height="111" class="entry-thumb" src="https://www.linux.com/wp-content/uploads/2019/08/opensource.jpg"  srcset="https://www.linux.com/wp-content/uploads/2019/08/opensource.jpg 1518w, https://www.linux.com/wp-content/uploads/2019/08/opensource-300x153.jpg 300w, https://www.linux.com/wp-content/uploads/2019/08/opensource-768x391.jpg 768w, https://www.linux.com/wp-content/uploads/2019/08/opensource-1024x521.jpg 1024w, https://www.linux.com/wp-content/uploads/2019/08/opensource-360x183.jpg 360w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="How to get started with an Open Source Program Office" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.linux.com/featured/how-to-get-started-with-an-open-source-program-office/" rel="bookmark" title="How to get started with an Open Source Program Office">How to get started with an Open Source Program Office</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.linux.com/news/linux-foundation-certifications-a-primer/" rel="bookmark" class="td-image-wrap " title="Linux Foundation Certifications: A Primer" ><img width="218" height="150" class="entry-thumb" src="https://www.linux.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png"  alt="" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.linux.com/news/linux-foundation-certifications-a-primer/" rel="bookmark" title="Linux Foundation Certifications: A Primer">Linux Foundation Certifications: A Primer</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_2_763" data-td_block_id="tdi_2_763"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_2_763" data-td_block_id="tdi_2_763"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
                            </div>
                        </div>
                                    </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->

	
	
            <div class="tdc-footer-wrap ">

                <!-- Footer -->
				
                <!-- Sub Footer -->
				    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                                    </div>

                <div class="td-pb-span td-sub-footer-copy">
                    Copyright © 2021 The Linux Foundation®. All rights reserved. The Linux Foundation has registered trademarks and uses trademarks. For a list of trademarks of The Linux Foundation, please see our <a href="https://www.linuxfoundation.org/trademark-usage">Trademark Usage</a> page. Linux is a registered trademark of Linus Torvalds.                </div>
            </div>
        </div>
    </div>
            </div><!--close td-footer-wrap-->
			
</div><!--close td-outer-wrap-->



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NXGNZW"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

    <!--

        Theme: Newspaper by tagDiv.com 2020
        Version: 10.3.9.1 (rara)
        Deploy mode: deploy
        
        uid: 6026238f2603f
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
.td-grid-style-2 .td-big-grid-post-0 .td-module-thumb a:last-child:before, .td-grid-style-3 .td-big-grid-post-0 .td-module-thumb a:last-child:before {
    background: linear-gradient(45deg, #4db2ec 0%, #4a8f5e 100%);
    
}

.td-grid-style-3 .td-module-thumb a:last-child:before {
    opacity: 0.2;
}
</style>

<script type='text/javascript' src='https://www.linux.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.4.0' id='mpp_gutenberg_tabs-js'></script>
<script type='text/javascript' id='leadin-script-loader-js-js-extra'>
/* <![CDATA[ */
var leadin_wordpress = {"userRole":"visitor","pageType":"post","leadinPluginVersion":"7.51.34"};
/* ]]> */
</script>
<script type='text/javascript' src='https://js.hs-scripts.com/8112310.js?integration=WordPress' async defer id='hs-script-loader'></script>
<script type='text/javascript' src='https://www.linux.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='https://www.linux.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://www.linux.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.9.1' id='td-site-min-js'></script>
<script type='text/javascript' src='https://www.linux.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://www.linux.com/wp-includes/js/wp-embed.min.js?ver=5.6.1' id='wp-embed-js'></script>

<!-- JS generated by theme -->

<script>
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[582597]");
                });
            
</script>


<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"981d6c8a9f","applicationID":"176909146","transactionName":"ZwZWMhNZXxcFABFaXF5MdQUVUV4KSxAMXVRcBmsSBFVBCAUXAGwG","queueTime":0,"applicationTime":511,"atts":"S0FVRFtDTBk=","errorBeacon":"bam-cell.nr-data.net","agent":""}</script></body>
</html>