<!DOCTYPE html>
<html  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# og: http://ogp.me/ns# article: http://ogp.me/ns/article# og: http://ogp.me/ns# book: http://ogp.me/ns/book# og: http://ogp.me/ns# profile: http://ogp.me/ns/profile# og: http://ogp.me/ns# video: http://ogp.me/ns/video# og: http://ogp.me/ns# product: http://ogp.me/ns/product# og: http://ogp.me/ns# content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ rdfs: http://www.w3.org/2000/01/rdf-schema# og: http://ogp.me/ns# sioc: http://rdfs.org/sioc/ns# og: http://ogp.me/ns# sioct: http://rdfs.org/sioc/types# og: http://ogp.me/ns# skos: http://www.w3.org/2004/02/skos/core# og: http://ogp.me/ns# xsd: http://www.w3.org/2001/XMLSchema# og: http://ogp.me/ns#">

<head>
  <meta charset="utf-8" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[f.now()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,t){s[t]=o(d+t,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),t.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(l+"tracer",[f.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[f.now(),r,o],n),o)try{return t.apply(this,arguments)}catch(e){throw c.emit("fn-err",[arguments,this,e],n),e}finally{c.emit("fn-end",[f.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){m[t]=o(l+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,f.now()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],4:[function(e,t,n){t.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o,i){if(!d.aborted||i){e&&e(n,r,o);for(var a=t(o),u=m(n),c=u.length,f=0;f<c;f++)u[f].apply(a,r);var p=s[y[n]];return p&&p.push([b,n,r,a]),a}}function l(e,t){v[e]=m(e).concat(t)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(n)}function g(e,t){f(e,function(e,n){t=t||"feature",y[n]=t,t in s||(s[t]=[])})}var v={},y={},b={on:l,emit:n,get:w,listeners:m,context:t,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},p={},d=t.exports=o();d.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!x++){var e=h.info=NREUM.info,t=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return s.abort();f(y,function(t,n){e[t]||(e[t]=n)}),c("mark",["onload",a()+h.offset],null,"api");var n=d.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===d.readyState&&i()}function i(){c("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),c=e("handle"),f=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1071.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=t.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),c("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
<script>
      dataLayer = [{"gtm.whitelist":["google","nonGooglePixels","nonGoogleScripts","nonGoogleIframes"],"gtm.blacklist":["customScripts","customPixels"],"loggedIn":false,"byline":"Jack  Wallen","publishDate":"July 27, 2018","contentType":"tutorial","contentSource":"Freelance","audience":["Developer"],"general":["Tools","Desktop"]}, {"event":"generalPush","general":"Tools"},{"event":"generalPush","general":"Desktop"}]
    </script><link rel="shortcut icon" href="https://www.linux.com/sites/all/themes/custom/lcom/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="description" content="Those that develop on Linux are likely familiar with Git. With good reason. Git is one of the most widely used and recognized version control systems on the planet. And for most, Git use tends to lean heavily on the terminal. After all, much of your development probably occurs at the command line, so why not interact with Git in the same manner?" />
<link rel="canonical" href="https://www.linux.com/learn/intro-to-linux/2018/7/three-graphical-clients-git-linux" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="shortlink" href="https://www.linux.com/learn/intro-to-linux/2018/7/three-graphical-clients-git-linux" />
<meta property="og:site_name" content="Linux.com | The source for Linux information" />
<meta property="og:type" content="website" />
<meta property="og:title" content="Three Graphical Clients for Git on Linux" />
<meta property="og:url" content="https://www.linux.com/learn/intro-to-linux/2018/7/three-graphical-clients-git-linux" />
<meta property="og:description" content="Those that develop on Linux are likely familiar with Git. With good reason. Git is one of the most widely used and recognized version control systems on the planet. And for most, Git use tends to lean heavily on the terminal. After all, much of your development probably occurs at the command line, so why not interact with Git in the same manner?" />
<meta property="og:updated_time" content="2018-07-27T13:27:27+00:00" />
<meta property="og:image" content="https://www.linux.com/sites/lcom/files/git-tools.jpg" />
<meta name="twitter:site" content="@linuxfoundation" />
<meta name="twitter:url" content="https://www.linux.com/learn/intro-to-linux/2018/7/three-graphical-clients-git-linux" />
<meta name="twitter:title" content="Three Graphical Clients for Git on Linux" />
<meta name="twitter:description" content="Those that develop on Linux are likely familiar with Git. With good reason. Git is one of the most widely used and recognized version control systems on the planet. And for most, Git use tends to lean heavily on the terminal. After all, much of your development probably occurs at the command line, so why not interact with Git in the same manner?" />
<meta name="twitter:image" content="https://www.linux.com/sites/lcom/files/git-tools.jpg" />
<meta property="article:published_time" content="2018-07-27T14:08:14+00:00" />
<meta property="article:modified_time" content="2018-07-27T13:27:27+00:00" />
<meta itemprop="name" content="Three Graphical Clients for Git on Linux" />
<meta itemprop="description" content="Those that develop on Linux are likely familiar with Git. With good reason. Git is one of the most widely used and recognized version control systems on the planet. And for most, Git use tends to lean heavily on the terminal. After all, much of your development probably occurs at the command line, so why not interact with Git in the same manner?" />
<meta itemprop="image" content="https://www.linux.com/sites/lcom/files/git-tools.jpg" />
  <title>Three Graphical Clients for Git on Linux | Linux.com | The source for Linux information</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <!--[if IEMobile]><meta http-equiv="cleartype" content="on"><![endif]-->

  <link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_kShW4RPmRstZ3SpIC-ZvVGNFVAi0WEMuCnI0ZkYIaFw.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_7miOmtwKPtgd4frsGApNDqsuxu7-w-bZX3bp__1R3Hc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_9Vl_VLDY_mG9a0XWmtaLcvJpPqX2n0i4MixjAQM_Cg4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_rEPbx6sv7SZVOmBDmnztD__Q3o_JnvfJ9CHjo3DEoqU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_rfBpH0rulzlEFmwl1X3jVidtFsXI4VmwHQsYdwvUFzU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_nQwtytNsztHNRD8oGYQyyja_LgjxLi44qLISIPyImuw.css" media="all" />
  <script>(function(h,o,t,j,a,r){
  h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
  h._hjSettings={hjid:"134680",hjsv:5};
  a=o.getElementsByTagName('head')[0];
  r=o.createElement('script');r.async=1;
  r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
  a.appendChild(r);
})(window,document,'//static.hotjar.com/c/hotjar-','.js?sv=');</script>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js"></script>
<script>window.jQuery || document.write("<script src='/sites/all/modules/contrib/jquery_update/replace/jquery/1.7/jquery.min.js'>\x3C/script>")</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_PdiuypZMI8o81AYEdTHwjRslVPEF69JFzr7Y9sMWt4s.js"></script>
<script>var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};</script>
<script src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_QiPjUmCnYVBK9Dnsm8OCnpnL_EN-Ho6tiELx-nRhl3o.js"></script>
<script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.10.2/jquery-ui.min.js"></script>
<script>window.jQuery.ui || document.write("<script src='/sites/all/modules/contrib/jquery_update/replace/ui/ui/minified/jquery-ui.min.js'>\x3C/script>")</script>
<script src="https://www.linux.com/sites/all/libraries/mediaelement/build/mediaelement-and-player.min.js?v=2.1.6"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js__bBogcF6zrob06qh5ifUeGh4t30mvORXZ2P3hX4c7sE.js"></script>
<script>var mapping = googletag.sizeMapping()
  .addSize([0, 0], [300, 250])
  .addSize([488, 0], [468, 60])
  .addSize([748, 0], [728, 90])
  .build();
googletag.slots["leaderboard1"] = googletag.defineSlot("/2972204/LF_ROS_728x90_468x60_300x250", [[728, 90], [468, 60], [300, 250]], "dfp-ad-leaderboard1")
  .addService(googletag.pubads())
  .defineSizeMapping(mapping);</script>
<script>var mapping = googletag.sizeMapping()
  .addSize([0, 0], [300, 250])
  .addSize([748, 0], [200, 200])
  .addSize([1028, 0], [300, 250])
  .build();
googletag.slots["box1"] = googletag.defineSlot("/2972204/LF_ROS_300x250_200x200", [[300, 250], [200, 200]], "dfp-ad-box1")
  .addService(googletag.pubads())
  .defineSizeMapping(mapping);</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_Xk8TsyNfILciPNmQPp9sl88cjH71DQWyeHE0MB62KO4.js"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_OVAOz6xKTt0o5QhoWFs7HJDiUhoqOR7FmnZl8WEbty4.js"></script>
<script>googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
});

googletag.enableServices();</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_YBDYs7heXRixjwSbdGrTzbuys9Ua3jHX0Te6thYuaJ4.js"></script>
<script>var _vwo_code=(function(){
var account_id=218604,
settings_tolerance=2000,
library_tolerance=1500,
use_existing_jquery=false,
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();</script>
<script>
    Drupal.behaviors.comment_pager_anchor = {
         attach: function(context, settings) {
      var comment_pager_links = jQuery('#js-linux-comments-wrapper .pager a');
      comment_pager_links.each(function(){
        this.href = this.href + '#comments';
      });
     }
    };
  </script>
<script src="https://www.linux.com/sites/lcom/files/js/js_psFEv24599FQgk0xMHpZaOx8v4Y2FkabRgXPNVENLNo.js"></script>
<script>window.a2a_config=window.a2a_config||{};window.da2a={done:false,html_done:false,script_ready:false,script_load:function(){var a=document.createElement('script'),s=document.getElementsByTagName('script')[0];a.type='text/javascript';a.async=true;a.src='https://static.addtoany.com/menu/page.js';s.parentNode.insertBefore(a,s);da2a.script_load=function(){};},script_onready:function(){da2a.script_ready=true;if(da2a.html_done)da2a.init();},init:function(){for(var i=0,el,target,targets=da2a.targets,length=targets.length;i<length;i++){el=document.getElementById('da2a_'+(i+1));target=targets[i];a2a_config.linkname=target.title;a2a_config.linkurl=target.url;if(el){a2a.init('page',{target:el});el.id='';}da2a.done=true;}da2a.targets=[];}};(function ($){Drupal.behaviors.addToAny = {attach: function (context, settings) {if (context !== document && window.da2a) {if(da2a.script_ready)a2a.init_all('page');da2a.script_load();}}}})(jQuery);a2a_config.callbacks=a2a_config.callbacks||[];a2a_config.callbacks.push({ready:da2a.script_onready});a2a_config.templates=a2a_config.templates||{};a2a_config.num_services = 5;
    a2a_config.prioritize = ["email", "facebook", "twitter", "linkedin", "pinterest", "google_plus"];</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_h1lDMTrnEZD5OYT82JLf5ycCK0cJAImbsG7ng0GSloQ.js"></script>
<script>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</script>
  </head>
<body class="html not-front not-logged-in one-sidebar sidebar-second page-node page-node- page-node-848063 node-type-tutorial section-learn page-panels" >
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-NXGNZW"
 height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/javascript">
(function(w,d,s,l,i){

  w[l]=w[l]||[];
  w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});
  var f=d.getElementsByTagName(s)[0];
  var j=d.createElement(s);
  var dl=l!='dataLayer'?'&l='+l:'';
  j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;
  j.type='text/javascript';
  j.async=true;
  f.parentNode.insertBefore(j,f);

})(window,document,'script','dataLayer','GTM-NXGNZW');
</script>
<!-- End Google Tag Manager -->
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<div id="page">

    <div class="region region-header-top">
    <div class="container">
      
<div id="block-dfp-leaderboard1" class="block block-dfp first last odd lf_header_leaderboard_ad">

    
	<div class="block__content">
	  <div id="dfp-ad-leaderboard1-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-leaderboard1" class="dfp-tag-wrapper">
  <div class="slug">Advertisement</div>  <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-leaderboard1");
    });
  </script>
</div>
</div>	</div>

</div>
    </div>
  </div>

  <header class="header" id="header" role="banner">

    <!-- Toggles -->
    <div class="header__toggles">
      <a id="nav__toggle" href="#"><span></span></a>
      <a id="search__toggle" href="#"><span></span></a>
    </div>

    <div class="header__inner">
      <div class="container header__container">

                  <div class="header__site-info" id="name-and-slogan">

                          <a href="/" title="Home" rel="home" class="header__logo" id="logo"><img src="https://www.linux.com/sites/all/themes/custom/lcom/logo.png" alt="Home" class="header__logo-image" /></a>
            
            
                          <div class="header__site-slogan" id="site-slogan">News for the Open Source Professional</div>
                      </div>
        
        
          <div class="header__region region region-header">
    
<div id="block-linux-user-login-logout-links" class="block block-linux-user first odd ">

    
	<div class="block__content">
	  <a href="/cas?destination=node/848063" rel="noindex, nofollow">Login / Create Account</a>	</div>

</div>

<div id="block-menu-menu-join-us" class="block block-menu even join-us" role="navigation">

    
	<div class="block__content">
	  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="https://www.facebook.com/TheLinuxFoundation" class="menu__link addthis-facebook" target="_blank">Facebook</a></li>
<li class="menu__item is-leaf leaf"><a href="https://twitter.com/linuxfoundation" class="menu__link addthis-twitter" target="_blank">Twitter</a></li>
<li class="menu__item is-leaf leaf"><a href="https://plus.google.com/105083814157272466314" class="menu__link addthis-googleplus" target="_blank">Google Plus</a></li>
<li class="menu__item is-leaf leaf"><a href="http://www.linkedin.com/groups?gid=48682" class="menu__link addthis-linkedin" target="_blank">LinkedIn</a></li>
<li class="menu__item is-leaf last leaf"><a href="/feeds" class="menu__link addthis-rss">Feeds</a></li>
</ul>	</div>

</div>

<div id="block-boxes-brought-lf" class="block block-boxes block-boxes-simple last odd lf-brought">

    
	<div class="block__content">
	  <div id='boxes-box-brought_lf' class='boxes-box'><div class="boxes-box-content">
      <p><span>Brought to you by</span> <a href="http://www.linuxfoundation.org"><img alt="Linux Foundation" src="/sites/all/themes/custom/lcom/images/lf/logo-header.png" /></a></p></div></div>	</div>

</div>
  </div>

      </div>

        
<nav class="main-menu" role="navigation">
  <div class="container">

    
    
    <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/news" class="menu__link">News</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/news/category/enterprise" class="menu__link">Enterprise</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/desktop" class="menu__link">Desktop</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/embeddedmobile" class="menu__link">Mobile &amp; Embedded</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/open-source-practices" class="menu__link">Open Source</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/linux-kernel" class="menu__link">Linux Kernel</a></li>
<li class="menu__item is-leaf leaf"><a href="/devops" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf"><a href="/networking" class="menu__link">Networking</a></li>
<li class="menu__item is-leaf last leaf"><a href="/cloud" class="menu__link">Cloud Computing</a></li>
</ul></li>
<li class="menu__item is-leaf leaf"><a href="/tutorials" class="menu__link">Tutorials</a></li>
<li class="menu__item is-leaf leaf"><a href="/blogs/linux-foundation" class="menu__link expanded">Open Source Pro</a></li>
<li class="menu__item is-expanded expanded"><span class="menu__link nolink">Learn</span><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/what-is-linux" class="menu__link">What is Linux?</a></li>
<li class="menu__item is-leaf leaf"><a href="/learn/training" class="menu__link">Training</a></li>
<li class="menu__item is-leaf leaf"><a href="/certification" class="menu__link">Certification</a></li>
<li class="menu__item is-leaf leaf"><a href="/events" class="menu__link">Events</a></li>
<li class="menu__item is-leaf last leaf"><a href="/blog/upcoming-free-webinars-linux-foundation" class="menu__link">Webinars</a></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/community" class="menu__link">Community</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/community/participate" class="menu__link">Participate</a></li>
<li class="menu__item is-leaf leaf"><a href="/answers" class="menu__link">Q&amp;A</a></li>
<li class="menu__item is-leaf leaf"><a href="/forum" class="menu__link">Forums</a></li>
<li class="menu__item is-leaf last leaf"><a href="/community/blogs" class="menu__link">Blogs</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded"><span class="menu__link nolink">Resources</span><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/resources/newsletter" class="menu__link">Newsletter</a></li>
<li class="menu__item is-leaf leaf"><a href="/distributions" class="menu__link">Distributions</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/publications" class="menu__link">Publications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/infographics" class="menu__link">Infographics</a></li>
<li class="menu__item is-leaf leaf"><a href="/photos" class="menu__link">Photos</a></li>
<li class="menu__item is-leaf leaf"><a href="/videos" class="menu__link">Videos</a></li>
<li class="menu__item is-leaf last leaf"><a href="/linux-and-open-source-jobs" class="menu__link">Jobs</a></li>
</ul></li>
</ul>
  </div>
</nav><!-- /#navigation -->

<div id="block-views-ed07b1def74a71b1f939ef53b3d18ead" class="block block-views last even search-block">

  <div class="container">
        
    <a id="search__toggle_desktop" href="#"><span></span></a>

    <div class="block__content">
      <form action="/search" method="get" id="views-exposed-form-linux-search-node-panel-pane-1" accept-charset="UTF-8"><div><div class="views-exposed-form">
  <div class="views-exposed-widgets clearfix">
          <div id="edit-keyword-wrapper" class="views-exposed-widget views-widget-filter-search_api_views_fulltext">
                        <div class="views-widget">
          <div class="form-item form-type-textfield form-item-keyword">
 <input type="text" id="edit-keyword" name="keyword" value="" size="30" maxlength="128" class="form-text required error" />
</div>
        </div>
              </div>
                    <div class="views-exposed-widget views-submit-button">
      <input type="submit" id="edit-submit-linux-search-node" name="" value="Search" class="form-submit" />    </div>
      </div>
</div>
</div></form>    </div>
  </div>

</div>

    </div>
  </header>

  
  <div id="main">
    <div class="container">
      <div id="content" class="column" role="main">
                        <a id="main-content"></a>
                                                                


<div class="lcom-stacked__header"><div class="panel-pane pane-views-panes pane-real-author-name-linked-panel-pane-1 node-author"  >
  
      
  
  <div id="view-id-real_author_name_linked-panel_pane_1" class="view view-real-author-name-linked view-id-real_author_name_linked view-display-id-panel_pane_1 view-dom-id-9a65b3b52d89e5095c34d18c5c9e952e">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-linux-name">        <div class="field-content"><a href="/users/jlwallen">Jack  Wallen</a></div>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-node-created node-date"  >
  
      
  
  July 27, 2018
  
  </div>
</div><div class="lcom-stacked__main"><div class="panel-pane pane-node-title"  >
  
      
  
  <h1>Three Graphical Clients for Git on Linux</h1>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-image"  >
  
      
  
  <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><div id="file-9315" class="file file-image file-image-jpeg">

        <h2 class="element-invisible"><a href="/files/images/git-toolsjpg">git-tools.jpg</a></h2>
    
  
  <div class="content">
    <img typeof="foaf:Image" src="https://www.linux.com/sites/lcom/files/styles/rendered_file/public/git-tools.jpg?itok=Be56iPT0" alt="Git tools" title="Git tools" /><div class="group-file-info field-group-div"><div class="field field-name-field-caption field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even">Learn how these three Git GUI tools can enhance your development workflow.</div></div></div><div class="field field-name-field-license field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/licenses/category/creative-commons-zero" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Creative Commons Zero</a></div></div></div><div class="field field-name-field-source field-type-link-field field-label-hidden"><div class="field-items"><div class="field-item even">Pixabay</div></div></div></div>  </div>

  
</div>
</div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-body"  >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>Those that develop on Linux are likely familiar with <a href="https://git-scm.com/">Git</a>. With good reason. Git is one of the most widely used and recognized version control systems on the planet. And for most, Git use tends to lean heavily on the terminal. After all, much of your development probably occurs at the command line, so why not interact with Git in the same manner? </p>
<p>In some instances, however, having a GUI tool to work with can make your workflow slightly more efficient (at least for those that tend to depend upon a GUI). To that end, what options do you have for Git GUI tools? Fortunately, we found some that are worthy of your time and (in some cases) money. I want to highlight three such Git clients that run on the Linux operating system. Out of these three, you should be able to find one that meets all of your needs. <br class="kix-line-break" />I am going to assume you understand how Git and repositories like GitHub function, <a href="https://www.linux.com/learn/intro-to-linux/2018/7/introduction-using-git">which I covered previously</a>, so I won’t be taking the time for any how-tos with these tools. Instead, this will be an introduction, so you (the developer) know these tools are available for your development tasks.</p>
<p>A word of warning: Not all of these tools are free, and some are released under proprietary licenses. However, they all work quite well on the Linux platform and make interacting with GitHub a breeze.</p>
<p>With that said, let’s look at some outstanding Git GUIs.</p>
<h3>SmartGit</h3>
<p><a href="https://www.syntevo.com/smartgit/">SmartGit</a> is a proprietary tool that’s free for non-commercial usage. If you plan on employing SmartGit in a commercial environment, the license cost is $99 USD per year for one license or $5.99 per month. There are other upgrades (such as Distributed Reviews and SmartSynchronize), which are both $15 USD per licence. You can download either the source or a .deb package for installation. I tested SmartGit on Ubuntu 18.04 and it worked without issue.</p>
<p>But why would you want to use SmartGit? There are plenty of reasons. First and foremost, SmartGit makes it incredibly easy to integrate with the likes of GitHub and Subversion servers. Instead of spending your valuable time attempting to configure the GUI to work with your remote accounts, SmartGit takes the pain out of that task. The SmartGit GUI (Figure 1) is also very well designed to be uncluttered and intuitive.</p>
<p><div class="media media-element-container media-default"><div id="file-9313" class="file file-image file-image-jpeg">

        <h2 class="element-invisible"><a href="/files/images/gitgui1jpg">gitgui_1.jpg</a></h2>
    
  
  <div class="content">
    <img class="media-element file-default" data-delta="3" typeof="Image" src="https://www.linux.com/sites/lcom/files/styles/rendered_file/public/gitgui_1.jpg?itok=LEZ_PYIf" alt="SmartGit" title="SmartGit" /><div class="group-file-info field-group-div"><div class="field field-name-field-caption field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even">Figure 1: The SmartGit UI helps to simplify your workflow.</div></div></div><div class="field field-name-field-license field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/licenses/category/used-permission" typeof="Concept" property="prefLabel" datatype="">Used with permission</a></div></div></div></div>  </div>

  
</div>
</div></p>
<p>After installing SmartGit, I had it connected with my personal GitHub account in seconds. The default toolbar makes working with a repository, incredibly simple. Push, pull, check out, merge, add branches, cherry pick, revert, rebase, reset — all of Git’s most popular features are there to use. Outside of supporting most of the standard Git and GitHub functions/features, SmartGit is very stable. At least when using the tool on the Ubuntu desktop, you feel like you’re working with an application that was specifically designed and built for Linux. </p>
<p>SmartGit is probably one of the best tools that makes working with even advanced Git features easy enough for any level of user. To learn more about SmartGit, take a look at the <a href="http://www.syntevo.com/doc/display/SG/Manual">extensive documentation</a>.</p>
<h3>GitKraken</h3>
<p><a href="https://www.gitkraken.com/">GitKraken</a> is another proprietary GUI tool that makes working with both Git and GitHub an experience you won’t regret. Where SmartGit has a very simplified UI, GitKraken has a beautifully designed interface that offers a bit more feature-wise at the ready. There is a free version of GitKraken available (and you can test the full-blown paid version with a 15 day trial period). After the the trial period ends, you can continue using the free version, but for non-commercial use only. </p>
<p>For those who want to get the most out of their development workflow, GitKraken might be the tool to choose. This particular take on the Git GUI features the likes of visual interactions, resizable commit graphs, drag and drop, seamless integration (with GitHub, GitLab, and BitBucket), easy in-app tasks, in-app merge tools, fuzzy finder, gitflow support, 1-click undo &amp; redo, keyboard shortcuts, file history &amp; blame, submodules, light &amp; dark themes, git hooks support, git LFS, and much more. But the one feature that many users will appreciate the most is the incredibly well-designed interface (Figure 2).</p>
<p><div class="media media-element-container media-default"><div id="file-9311" class="file file-image file-image-jpeg">

        <h2 class="element-invisible"><a href="/files/images/gitgui2jpg">gitgui_2.jpg</a></h2>
    
  
  <div class="content">
    <img class="media-element file-default" data-delta="2" typeof="Image" src="https://www.linux.com/sites/lcom/files/styles/rendered_file/public/gitgui_2.jpg?itok=Y8crSLhf" alt="GitKraken" title="GitKraken" /><div class="group-file-info field-group-div"><div class="field field-name-field-caption field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even">Figure 2: The GitKraken interface is tops.</div></div></div><div class="field field-name-field-license field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/licenses/category/used-permission" typeof="Concept" property="prefLabel" datatype="">Used with permission</a></div></div></div></div>  </div>

  
</div>
</div></p>
<p>Outside of the amazing interface, one of the things that sets GitKraken above the rest of the competition is how easy it makes working with multiple remote repositories and multiple profiles. The one caveat to using GitKraken (besides it being proprietary) is the cost. If you’re looking at using GitKraken for commercial use, the license costs are:</p>
<ul><li>
<p>$49 per user per year for individual</p>
</li>
<li>
<p>$39 per user per year for 10+ users</p>
</li>
<li>
<p>$29 per user per year for 100+ users</p>
</li>
</ul><p>The Pro accounts allow you to use both the Git Client and the Glo Boards (which is the GitKraken project management tool) commercially. The Glo Boards are an especially interesting feature as they allow you to sync your Glo Board to GitHub Issues. Glo Boards are sharable and include search &amp; filters, issue tracking, markdown support, file attachments, @mentions, card checklists, and more. All of this can be accessed from within the GitKraken GUI.<br class="kix-line-break" />GitKraken is available for Linux as either an installable .deb file, or source. </p>
<h3>Git Cola</h3>
<p><a href="https://git-cola.github.io/">Git Cola</a> is our free, open source entry in the list. Unlike both GitKraken and Smart Git, Git Cola is a pretty bare bones, no-nonsense Git client. Git Cola is written in Python with a GTK interface, so no matter what distribution and desktop combination you use, it should integrate seamlessly. And because it’s open source, you should find it in your distribution's package manager. So installation is nothing more than a matter of opening your distribution’s app store, searching for “Git Cola” and installing. You can also install from the command line like so:</p>
<pre>
sudo apt install git-cola</pre><p>Or:</p>
<pre>
sudo dnf install git-cola</pre><p>The Git Cola interface is pretty simple (Figure 3). In fact, you won’t find much in the way of too many bells and whistles, as Git Cola is all about the basics. </p>
<p><div class="media media-element-container media-default"><div id="file-9309" class="file file-image file-image-jpeg">

        <h2 class="element-invisible"><a href="/files/images/gitgui3jpg">gitgui_3.jpg</a></h2>
    
  
  <div class="content">
    <img class="media-element file-default" data-delta="1" typeof="Image" src="https://www.linux.com/sites/lcom/files/styles/rendered_file/public/gitgui_3.jpg?itok=bS9OYPQo" alt="Git Cola" title="Git Cola" /><div class="group-file-info field-group-div"><div class="field field-name-field-caption field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even">Figure 3: The Git Cola interface is a much simpler affair.</div></div></div><div class="field field-name-field-license field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/licenses/category/used-permission" typeof="Concept" property="prefLabel" datatype="">Used with permission</a></div></div></div></div>  </div>

  
</div>
</div></p>
<p>Because of Git Cola’s return to basics, there will be times when you must interface with the terminal. However, for many Linux users this won’t be a deal breaker (as most are developing within the terminal anyway). Git Cola does include features like:</p>
<ul><li>
<p>Multiple subcommands</p>
</li>
<li>
<p>Custom window settings</p>
</li>
<li>
<p>Configurable and environment variables</p>
</li>
<li>
<p>Language settings</p>
</li>
<li>
<p>Supports custom GUI settings</p>
</li>
<li>
<p>Keyboard shortcuts</p>
</li>
</ul><p>Although Git Cola does support connecting to remote repositories, the integration to the likes of Github isn’t nearly as intuitive as it is on either GitKraken or SmartGit. But if you’re doing most of your work locally, Git Cola is an outstanding tool that won’t get in between you and Git.</p>
<p>Git Cola also comes with an advanced (Directed Acyclic Graph) DAG visualizer, called Git Dag. This tool allows you to get a visual representation of your branches. You start Git Dag either separately from Git Cola or within Git Cola from the View &gt; DAG menu entry. Git DAG is a very powerful tool, which helps to make Git Cola one of the top open source Git GUIs on the market.</p>
<h3>There’s more where that came from</h3>
<p>There are plenty more Git GUI tools available. However, from these three tools you can do some serious work. Whether you’re looking for a tool with all the bells and whistles (regardless of license) or if you’re a strict GPL user, one of these should fit the bill.</p>
<p><em>Learn more about Linux through the free <a href="https://training.linuxfoundation.org/linux-courses/system-administration-training/introduction-to-linux">"Introduction to Linux" </a>course from The Linux Foundation and edX.</em></p></div></div></div>
  
  </div>
<div class="panel-pane pane-node-links"  >
  
      
  
  <ul class="links inline"><li class="addtoany first"><span><span class="a2a_kit a2a_target addtoany_list" id="da2a_1">
      
      <a class="a2a_dd addtoany_share_save" href="https://www.addtoany.com/share#url=https%3A%2F%2Fwww.linux.com%2Flearn%2Fintro-to-linux%2F2018%2F7%2Fthree-graphical-clients-git-linux&amp;title=Three%20Graphical%20Clients%20for%20Git%20on%20Linux"></a>
      <a class="a2a_button_email"></a>
    <a class="a2a_button_facebook"></a>
    <a class="a2a_button_twitter"></a>
    <a class="a2a_button_linkedin"></a>
    <a class="a2a_button_pinterest"></a>
    <a class="a2a_button_google_plus"></a>
    </span>
    <script type="text/javascript">
<!--//--><![CDATA[//><!--
if(window.da2a)da2a.script_load();
//--><!]]>
</script></span></li>
<li class="comment_forbidden"><span><a href="/user/login?destination=node/848063%23comment-form">Log in</a> or <a href="/user/register?destination=node/848063%23comment-form">register</a> to post comments</span></li>
<li class="print_html"><a href="/print/848063" title="Display a printer-friendly version of this page." class="print-page" rel="nofollow">Print This</a></li>
<li class="flag-imagex_node_like last"><span><span class="flag-wrapper flag-imagex-node-like flag-imagex-node-like-848063">
      <a href="/flag/flag/imagex_node_like/848063?destination=node/848063&amp;token=e759919b5680c0cf23b5d550207a9699" title="" class="flag flag-action flag-link-toggle" rel="nofollow">Like</a><span class="flag-throbber">&nbsp;</span>
          (<span class="flag-counter">1 like</span>)
  </span>
</span></li>
</ul>
  
  </div>
<div class="panel-pane pane-custom pane-1"  >
  
      
  
  <p><a class="node__comment-count" href="#comments">1 Comments</a></p>

  
  </div>
</div><div class="lcom-stacked__footer"><div class="panel-pane pane-panels-mini pane-comment-minipanel"  >
  
      
  
  <div class="panel-display parrot-panels minipanels minipanel-one-column clearfix" id="mini-panel-comment_minipanel">
  <div class="minipanel-one-wrapper fullwidth">
    <div class="region region-minipanel-one-main">
      <div class="region-inner clearfix">
        <div class="panel-pane pane-node-comments"  id="comments" >
  
        <h2 class="pane-title">
      Comments    </h2>
    
  
  <form action="/learn/intro-to-linux/2018/7/three-graphical-clients-git-linux" method="post" id="linux-voting-comment-sort-form" accept-charset="UTF-8"><div><a name='comments'></a>
<div id="js-linux-comments-wrapper"><a id="comment-20715"></a>
<article class="comment first last odd first last odd clearfix" about="/comment/20715#comment-20715" typeof="sioc:Post sioct:Comment">

  <header>
    <p class="submitted">
            <span property="dc:date dc:created" content="2018-07-27T08:59:04-07:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/victorhck" title="View user profile." class="username" xml:lang="" about="/users/victorhck" typeof="sioc:UserAccount" property="foaf:name" datatype="">victorhck</a> | <time pubdate datetime="2018-07-27T15:59:04+00:00">July 27, 2018</time></span>      <a href="/comment/20715#comment-20715" class="permalink" rel="bookmark">Permalink</a>    </p>

            
      </header>

  <span rel="sioc:reply_of" resource="/learn/intro-to-linux/2018/7/three-graphical-clients-git-linux" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>gtk and qgit are my options:</p>
<ul><li><a href="https://victorhckinthefreeworld.com/2018/04/24/tutorial-de-gitk-navega-graficamente-por-repositorios-git/">https://victorhckinthefreeworld.com/2018/04/24/tutorial-de-gitk-navega-g...</a></li>
<li><a href="https://victorhckinthefreeworld.com/2014/09/06/qgit-una-interfaz-grafica-para-manejar-tus-repositorios-de-git/?relatedposts_hit=1&amp;relatedposts_origin=7009&amp;relatedposts_position=1">https://victorhckinthefreeworld.com/2014/09/06/qgit-una-interfaz-grafica...</a></li>
</ul><p>Hapy hacking!</p></div></div></div>
  
  <ul class="links inline"><li class="comment_forbidden first"><span><a href="/user/login?destination=node/848063%23comment-form">Log in</a> or <a href="/user/register?destination=node/848063%23comment-form">register</a> to post comments</span></li>
<li class="like last"><span><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-like rate-8f041a223ff690d554593c228e4c0fdc rate-comment-20715-1-1" id="rate-comment-20715-1-1"><a class="rate-button rate-like-inactive rate-inactive" id="rate-button-1" rel="nofollow" href="/learn/intro-to-linux/2018/7/three-graphical-clients-git-linux?rate=DpSuFw1T7tyX52sWxm8U5ewtesc-RMg6MTYKpRSkOLk" title="Like">Like</a></div></span></li>
</ul></article>
</div><input type="hidden" name="form_build_id" value="form-rsWg1cd263tsuPmI1QttJ03C2yeyuuwLKVgmQGGKQW4" />
<input type="hidden" name="form_id" value="linux_voting_comment_sort_form" />
<input type="hidden" name="honeypot_time" value="1532843957|pt1yApWaARp7gzNQ62QUXuUHNUJN9behw7W_hvuFLAQ" />
<div class="url-textfield"><div class="form-item form-type-textfield form-item-url">
  <label for="edit-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-url" name="url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div></div></form>
  
  </div>
      </div>
    </div>
  </div>
</div>

  
  </div>
</div><a href="/popup/nojs" class="ctools-use-modal ctools-modal-subscription-modal-style element-invisible" title="">Click Here!</a>      </div>

      
              <aside class="sidebars">
                      <section class="region region-sidebar-second column sidebar">
    
<div id="block-dfp-box1" class="block block-dfp first odd ">

    
	<div class="block__content">
	  <div id="dfp-ad-box1-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-box1" class="dfp-tag-wrapper">
  <div class="slug">Advertisement</div>  <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-box1");
    });
  </script>
</div>
</div>	</div>

</div>

<section id="block-views-training-block-1" class="block block-views even lf-training-block">

    	<header>
	    <h2 class="block__title block-title">Training</h2>
		</header>
	  
	<div class="block__content">
	  <div id="view-id-training-block_1" class="view view-training view-id-training view-display-id-block_1 view-dom-id-d8f49e436893f4fc963dcbe14b28a005">
            <div class="view-header">
      <div class="see_all_button"><a href="/learn/training">See all</a></div>
    </div>
  
  
  
      <div class="view-content">
          <ul>          <li class="views-row views-row-1 views-row-odd views-row-first">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfd430-developing-linux-device-drivers-17">LFD430 Developing Linux Device Drivers</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2018-07-30T00:00:00+00:00">July 30, 2018</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/development-training/developing-linux-device-drivers">Learn more</a></div>  </div></li>
          <li class="views-row views-row-2 views-row-even">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfd401-developing-applications-linux-20">LFD401 Developing Applications for Linux</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2018-07-30T00:00:00+00:00">July 30, 2018</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/development-training/developing-applications-for-linux">Learn more</a></div>  </div></li>
          <li class="views-row views-row-3 views-row-odd views-row-last">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfs426-linux-performance-tuning-18">LFS426 Linux Performance Tuning</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2018-08-06T00:00:00+00:00">August 6, 2018</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/system-administration-training/linux-performance-tuning">Learn more</a></div>  </div></li>
      </ul>    </div>
  
  
  
  
  
  
</div>	</div>

</section>

<section id="block-linux-blocks-pardot-newsletter-signup-form" class="block block-linux-blocks odd ">

    	<header>
	    <h2 class="block__title block-title">Newsletter</h2>
		</header>
	  
	<div class="block__content">
	  <iframe src="//go.pardot.com/l/6342/2011-03-24/1ATL" width="100%" height="420px" type="text/html" frameborder="0" allowTransparency="true" style="border: 0"></iframe>	</div>

</section>

<section id="block-views-linux-jobs-related-jobs-block" class="block block-views last even ">

    	<header>
	    <h2 class="block__title block-title">Related Jobs</h2>
		</header>
	  
	<div class="block__content">
	  <div id="view-id-linux_jobs-related_jobs_block" class="view view-linux-jobs view-id-linux_jobs view-display-id-related_jobs_block view-dom-id-2d5dee51cedb2c1b88bf38d716d4dad9">
        
  
  
      <div class="view-empty">
      <div id="view-id-linux_jobs-all_jobs_block" class="view view-linux-jobs view-id-linux_jobs view-display-id-all_jobs_block view-dom-id-da97e41f9868f826bbc0b074c0971115">
        
  
  
  
  
  
  
  
  
</div>    </div>
  
  
  
  
  
  
</div>	</div>

</section>
  </section>
        </aside>
      
    </div>
  </div>

  
    <footer id="footer" class="region region-footer">
  	<div class="container">
    	
<div id="block-menu-block-1" class="block block-menu-block first odd lf-footer-primary-menu footer-menu" role="navigation">

    
	<div class="block__content">
	  <div class="menu-block-wrapper menu-block-1 menu-name-main-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-expanded first expanded menu-mlid-1275"><a href="/news" class="menu__link">News</a><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1281"><a href="/news/category/enterprise" class="menu__link">Enterprise</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1282"><a href="/news/category/desktop" class="menu__link">Desktop</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1283"><a href="/news/category/embeddedmobile" class="menu__link">Mobile &amp; Embedded</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1284"><a href="/news/category/open-source-practices" class="menu__link">Open Source</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1285"><a href="/news/category/linux-kernel" class="menu__link">Linux Kernel</a></li>
<li class="menu__item is-leaf leaf menu-mlid-5595"><a href="/devops" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf menu-mlid-5596"><a href="/networking" class="menu__link">Networking</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-5597"><a href="/cloud" class="menu__link">Cloud Computing</a></li>
</ul></li>
<li class="menu__item is-leaf leaf menu-mlid-1276"><a href="/tutorials" class="menu__link">Tutorials</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1277"><a href="/blogs/linux-foundation" class="menu__link expanded">Open Source Pro</a></li>
<li class="menu__item is-expanded expanded menu-mlid-1278"><span class="menu__link nolink">Learn</span><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1292"><a href="/what-is-linux" class="menu__link">What is Linux?</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1293"><a href="/learn/training" class="menu__link">Training</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1294"><a href="/certification" class="menu__link">Certification</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1295"><a href="/events" class="menu__link">Events</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1296"><a href="/blog/upcoming-free-webinars-linux-foundation" class="menu__link">Webinars</a></li>
</ul></li>
<li class="menu__item is-expanded expanded menu-mlid-1279"><a href="/community" class="menu__link">Community</a><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1297"><a href="/community/participate" class="menu__link">Participate</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1298"><a href="/answers" class="menu__link">Q&amp;A</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1299"><a href="/forum" class="menu__link">Forums</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1300"><a href="/community/blogs" class="menu__link">Blogs</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded menu-mlid-1280"><span class="menu__link nolink">Resources</span><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1301"><a href="/resources/newsletter" class="menu__link">Newsletter</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1303"><a href="/distributions" class="menu__link">Distributions</a></li>
<li class="menu__item is-leaf leaf menu-mlid-3808"><a href="/resources/publications" class="menu__link">Publications</a></li>
<li class="menu__item is-leaf leaf menu-mlid-3809"><a href="/resources/infographics" class="menu__link">Infographics</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1286"><a href="/photos" class="menu__link">Photos</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1287"><a href="/videos" class="menu__link">Videos</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-10188"><a href="/linux-and-open-source-jobs" class="menu__link">Jobs</a></li>
</ul></li>
</ul></div>
	</div>

</div>

<div id="block-menu-menu-footer" class="block block-menu even lf-footer-about-menu footer-menu" role="navigation">

    
	<div class="block__content">
	  <ul class="menu"><li class="menu__item is-expanded first last expanded"><a href="/about" class="menu__link">About Linux.com</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/terms-of-use" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.linuxfoundation.org/privacy/" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/editorial-policy" class="menu__link">Editorial Policy</a></li>
<li class="menu__item is-leaf last leaf"><a href="/contact" class="menu__link">Contact</a></li>
</ul></li>
</ul>	</div>

</div>

<div id="block-boxes-about-lf" class="block block-boxes block-boxes-simple odd lf-about">

    
	<div class="block__content">
	  <div id='boxes-box-about_lf' class='boxes-box'><div class="boxes-box-content">
        <p><a href="http://www.linuxfoundation.org"><img alt="Linux Foundation" src="/sites/all/themes/custom/lcom/images/lf/logo-footer.png" /></a></p>
        <p>The Linux Foundation is a non-profit consortium enabling collaboration and innovation through an open source development model.</p>
        <p><a href="http://www.linuxfoundation.org" class="more">Learn More</a></p></div></div>	</div>

</div>

<div id="block-linux-blocks-linux-accelerated-by" class="block block-linux-blocks even ">

    
	<div class="block__content">
	  <div class="row"><p>Accelerated by</p></div><div class="row"><a href="http://www.fastly.com"><img typeof="foaf:Image" src="https://www.linux.com/sites/all/themes/custom/lcom/images/fastly-logo.png" width="60px" alt="Fastly" title="Fastly" /></a></div><div class="row"><a href="http://www.dnsmadeeasy.com"><img class="dns-made-easy-logo" typeof="foaf:Image" src="https://www.linux.com/sites/all/themes/custom/lcom/images/dns-made-easy-logo.png" width="100px" alt="DNS Made Easy" title="DNS Made Easy" /></a></div>	</div>

</div>

<div id="block-boxes-copyright-infos" class="block block-boxes block-boxes-simple odd lf-copyright">

    
	<div class="block__content">
	  <div id='boxes-box-copyright_infos' class='boxes-box'><div class="boxes-box-content"><p>&copy; 2016 The Linux Foundation</p></div></div>	</div>

</div>

<div id="block-block-3" class="block block-block last even ">

    
	<div class="block__content">
	  <!-- Google Analytics -->
<!--<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-831873-8', 'auto');
ga('send', 'pageview');
</script>-->
<!-- End Google Analytics -->	</div>

</div>
  	</div>
  </footer>

</div>


  <script src="https://www.linux.com/sites/lcom/files/js/js_EIY91SVu4Ez1BN8UI_1XQnC6AJTb65-lR4DGrCwCjos.js"></script>
<script>da2a.targets=[
{title:"Three Graphical Clients for Git on Linux",url:"https:\/\/www.linux.com\/learn\/intro-to-linux\/2018\/7\/three-graphical-clients-git-linux"}];
da2a.html_done=true;if(da2a.script_ready&&!da2a.done)da2a.init();da2a.script_load();</script>
<script defer="defer" src="https://www.fastly-insights.com/insights.js?k=d45c0551-a6a5-45e3-90c5-0c474e341570&amp;sample=0.5"></script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"e16628c6a8","applicationID":"46970583","transactionName":"NQZRYBdVDEFXVxAPWgxMclcRXQ1cGUQFAVA9DlJaBFMHQGlaCwJQPRVaURJrElNRUQ==","queueTime":0,"applicationTime":1165,"atts":"GUFSFl9PH08=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
