<!DOCTYPE html>
<html  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# og: http://ogp.me/ns# article: http://ogp.me/ns/article# og: http://ogp.me/ns# book: http://ogp.me/ns/book# og: http://ogp.me/ns# profile: http://ogp.me/ns/profile# og: http://ogp.me/ns# video: http://ogp.me/ns/video# og: http://ogp.me/ns# product: http://ogp.me/ns/product# og: http://ogp.me/ns# content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ rdfs: http://www.w3.org/2000/01/rdf-schema# og: http://ogp.me/ns# sioc: http://rdfs.org/sioc/ns# og: http://ogp.me/ns# sioct: http://rdfs.org/sioc/types# og: http://ogp.me/ns# skos: http://www.w3.org/2004/02/skos/core# og: http://ogp.me/ns# xsd: http://www.w3.org/2001/XMLSchema# og: http://ogp.me/ns#">

<head>
  <meta charset="utf-8" />
<script>
      dataLayer = [{"gtm.whitelist":["google","nonGooglePixels","nonGoogleScripts","nonGoogleIframes"],"gtm.blacklist":["customScripts","customPixels"],"loggedIn":false,"byline":"Eric Brown","publishDate":"August 17, 2018","contentType":"imagex_news","contentSource":"Freelance","general":["Embedded"],"collaborativeProjects":["Zephyr"]}, {"event":"generalPush","general":"Embedded"},{"event":"collaborativeProjectsPush","collaborativeProject":"Zephyr"}]
    </script><link rel="shortcut icon" href="https://www.linux.com/sites/all/themes/custom/lcom/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="description" content="The Linux Foundation’s Zephyr Project, which is developing the open source Zephyr real-time operating system (RTOS) for microcontrollers, announced six new members, including RISC-V members Antmicro and SiFive. The project also announced expanded support for developer boards." />
<link rel="canonical" href="https://www.linux.com/news/2018/8/zephyr-project-embraces-risc-v-new-members-and-expanded-board-support" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="shortlink" href="https://www.linux.com/news/2018/8/zephyr-project-embraces-risc-v-new-members-and-expanded-board-support" />
<meta property="og:site_name" content="Linux.com | The source for Linux information" />
<meta property="og:type" content="website" />
<meta property="og:title" content="Zephyr Project Embraces RISC-V with New Members and Expanded Board Support" />
<meta property="og:url" content="https://www.linux.com/news/2018/8/zephyr-project-embraces-risc-v-new-members-and-expanded-board-support" />
<meta property="og:description" content="The Linux Foundation’s Zephyr Project, which is developing the open source Zephyr real-time operating system (RTOS) for microcontrollers, announced six new members, including RISC-V members Antmicro and SiFive. The project also announced expanded support for developer boards." />
<meta property="og:updated_time" content="2018-08-17T18:37:03+00:00" />
<meta property="og:image" content="https://www.linux.com/sites/lcom/files/zephyr-miroslava-459955-unsplash_0.jpg" />
<meta name="twitter:site" content="@linuxfoundation" />
<meta name="twitter:url" content="https://www.linux.com/news/2018/8/zephyr-project-embraces-risc-v-new-members-and-expanded-board-support" />
<meta name="twitter:title" content="Zephyr Project Embraces RISC-V with New Members and Expanded Board Support" />
<meta name="twitter:description" content="The Linux Foundation’s Zephyr Project, which is developing the open source Zephyr real-time operating system (RTOS) for microcontrollers, announced six new members, including RISC-V members Antmicro and SiFive. The project also announced expanded support for developer boards." />
<meta name="twitter:image" content="https://www.linux.com/sites/lcom/files/zephyr-miroslava-459955-unsplash_0.jpg" />
<meta property="article:published_time" content="2018-08-17T12:06:20+00:00" />
<meta property="article:modified_time" content="2018-08-17T18:37:03+00:00" />
<meta itemprop="name" content="Zephyr Project Embraces RISC-V with New Members and Expanded Board Support" />
<meta itemprop="description" content="The Linux Foundation’s Zephyr Project, which is developing the open source Zephyr real-time operating system (RTOS) for microcontrollers, announced six new members, including RISC-V members Antmicro and SiFive. The project also announced expanded support for developer boards." />
<meta itemprop="image" content="https://www.linux.com/sites/lcom/files/zephyr-miroslava-459955-unsplash_0.jpg" />
  <title>Zephyr Project Embraces RISC-V with New Members and Expanded Board Support | Linux.com | The source for Linux information</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <!--[if IEMobile]><meta http-equiv="cleartype" content="on"><![endif]-->

  <link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_kShW4RPmRstZ3SpIC-ZvVGNFVAi0WEMuCnI0ZkYIaFw.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_7miOmtwKPtgd4frsGApNDqsuxu7-w-bZX3bp__1R3Hc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_XW-lOa7cj7oUUdmEUvbB6oUFqnqQgMi0uKEZyah0J20.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_VJJ45mjP6ywKVkfo0Io3-PB1zoNauDbwu2REXjBP9AU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_rfBpH0rulzlEFmwl1X3jVidtFsXI4VmwHQsYdwvUFzU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.linux.com/sites/lcom/files/css/css_nQwtytNsztHNRD8oGYQyyja_LgjxLi44qLISIPyImuw.css" media="all" />
  <script>(function(h,o,t,j,a,r){
  h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
  h._hjSettings={hjid:"134680",hjsv:5};
  a=o.getElementsByTagName('head')[0];
  r=o.createElement('script');r.async=1;
  r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
  a.appendChild(r);
})(window,document,'//static.hotjar.com/c/hotjar-','.js?sv=');</script>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js"></script>
<script>window.jQuery || document.write("<script src='/sites/all/modules/contrib/jquery_update/replace/jquery/1.7/jquery.min.js'>\x3C/script>")</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_PdiuypZMI8o81AYEdTHwjRslVPEF69JFzr7Y9sMWt4s.js"></script>
<script>var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};</script>
<script src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_QiPjUmCnYVBK9Dnsm8OCnpnL_EN-Ho6tiELx-nRhl3o.js"></script>
<script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.10.2/jquery-ui.min.js"></script>
<script>window.jQuery.ui || document.write("<script src='/sites/all/modules/contrib/jquery_update/replace/ui/ui/minified/jquery-ui.min.js'>\x3C/script>")</script>
<script src="https://www.linux.com/sites/all/libraries/mediaelement/build/mediaelement-and-player.min.js?v=2.1.6"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js__bBogcF6zrob06qh5ifUeGh4t30mvORXZ2P3hX4c7sE.js"></script>
<script>var mapping = googletag.sizeMapping()
  .addSize([0, 0], [300, 250])
  .addSize([488, 0], [468, 60])
  .addSize([748, 0], [728, 90])
  .build();
googletag.slots["leaderboard1"] = googletag.defineSlot("/2972204/LF_ROS_728x90_468x60_300x250", [[728, 90], [468, 60], [300, 250]], "dfp-ad-leaderboard1")
  .addService(googletag.pubads())
  .defineSizeMapping(mapping);</script>
<script>var mapping = googletag.sizeMapping()
  .addSize([0, 0], [300, 250])
  .addSize([748, 0], [200, 200])
  .addSize([1028, 0], [300, 250])
  .build();
googletag.slots["box1"] = googletag.defineSlot("/2972204/LF_ROS_300x250_200x200", [[300, 250], [200, 200]], "dfp-ad-box1")
  .addService(googletag.pubads())
  .defineSizeMapping(mapping);</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_Xk8TsyNfILciPNmQPp9sl88cjH71DQWyeHE0MB62KO4.js"></script>
<script src="https://www.linux.com/sites/lcom/files/js/js_OVAOz6xKTt0o5QhoWFs7HJDiUhoqOR7FmnZl8WEbty4.js"></script>
<script>googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
});

googletag.enableServices();</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_YBDYs7heXRixjwSbdGrTzbuys9Ua3jHX0Te6thYuaJ4.js"></script>
<script>var _vwo_code=(function(){
var account_id=218604,
settings_tolerance=2000,
library_tolerance=1500,
use_existing_jquery=false,
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_PYNGGfTB8Qxjxb-2RN9ZA9DVLz07EObe5pCuqFNAS54.js"></script>
<script>window.a2a_config=window.a2a_config||{};window.da2a={done:false,html_done:false,script_ready:false,script_load:function(){var a=document.createElement('script'),s=document.getElementsByTagName('script')[0];a.type='text/javascript';a.async=true;a.src='https://static.addtoany.com/menu/page.js';s.parentNode.insertBefore(a,s);da2a.script_load=function(){};},script_onready:function(){da2a.script_ready=true;if(da2a.html_done)da2a.init();},init:function(){for(var i=0,el,target,targets=da2a.targets,length=targets.length;i<length;i++){el=document.getElementById('da2a_'+(i+1));target=targets[i];a2a_config.linkname=target.title;a2a_config.linkurl=target.url;if(el){a2a.init('page',{target:el});el.id='';}da2a.done=true;}da2a.targets=[];}};(function ($){Drupal.behaviors.addToAny = {attach: function (context, settings) {if (context !== document && window.da2a) {if(da2a.script_ready)a2a.init_all('page');da2a.script_load();}}}})(jQuery);a2a_config.callbacks=a2a_config.callbacks||[];a2a_config.callbacks.push({ready:da2a.script_onready});a2a_config.templates=a2a_config.templates||{};a2a_config.num_services = 5;
    a2a_config.prioritize = ["email", "facebook", "twitter", "linkedin", "pinterest", "google_plus"];</script>
<script src="https://www.linux.com/sites/lcom/files/js/js_h1lDMTrnEZD5OYT82JLf5ycCK0cJAImbsG7ng0GSloQ.js"></script>
<script>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</script>
  </head>
<body class="html not-front not-logged-in one-sidebar sidebar-second page-node page-node- page-node-857935 node-type-imagex-news section-news page-panels" >
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-NXGNZW"
 height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/javascript">
(function(w,d,s,l,i){

  w[l]=w[l]||[];
  w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});
  var f=d.getElementsByTagName(s)[0];
  var j=d.createElement(s);
  var dl=l!='dataLayer'?'&l='+l:'';
  j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;
  j.type='text/javascript';
  j.async=true;
  f.parentNode.insertBefore(j,f);

})(window,document,'script','dataLayer','GTM-NXGNZW');
</script>
<!-- End Google Tag Manager -->
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<div id="page">

    <div class="region region-header-top">
    <div class="container">
      
<div id="block-dfp-leaderboard1" class="block block-dfp first last odd lf_header_leaderboard_ad">

    
	<div class="block__content">
	  <div id="dfp-ad-leaderboard1-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-leaderboard1" class="dfp-tag-wrapper">
  <div class="slug">Advertisement</div>  <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-leaderboard1");
    });
  </script>
</div>
</div>	</div>

</div>
    </div>
  </div>

  <header class="header" id="header" role="banner">

    <!-- Toggles -->
    <div class="header__toggles">
      <a id="nav__toggle" href="#"><span></span></a>
      <a id="search__toggle" href="#"><span></span></a>
    </div>

    <div class="header__inner">
      <div class="container header__container">

                  <div class="header__site-info" id="name-and-slogan">

                          <a href="/" title="Home" rel="home" class="header__logo" id="logo"><img src="https://www.linux.com/sites/all/themes/custom/lcom/logo.png" alt="Home" class="header__logo-image" /></a>
            
            
                          <div class="header__site-slogan" id="site-slogan">News for the Open Source Professional</div>
                      </div>
        
        
          <div class="header__region region region-header">
    
<div id="block-linux-user-login-logout-links" class="block block-linux-user first odd ">

    
	<div class="block__content">
	  <a href="/cas?destination=node/857935" rel="noindex, nofollow">Login / Create Account</a>	</div>

</div>

<div id="block-menu-menu-join-us" class="block block-menu even join-us" role="navigation">

    
	<div class="block__content">
	  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="https://www.facebook.com/TheLinuxFoundation" class="menu__link addthis-facebook" target="_blank">Facebook</a></li>
<li class="menu__item is-leaf leaf"><a href="https://twitter.com/linuxfoundation" class="menu__link addthis-twitter" target="_blank">Twitter</a></li>
<li class="menu__item is-leaf leaf"><a href="https://plus.google.com/105083814157272466314" class="menu__link addthis-googleplus" target="_blank">Google Plus</a></li>
<li class="menu__item is-leaf leaf"><a href="http://www.linkedin.com/groups?gid=48682" class="menu__link addthis-linkedin" target="_blank">LinkedIn</a></li>
<li class="menu__item is-leaf last leaf"><a href="/feeds" class="menu__link addthis-rss">Feeds</a></li>
</ul>	</div>

</div>

<div id="block-boxes-brought-lf" class="block block-boxes block-boxes-simple last odd lf-brought">

    
	<div class="block__content">
	  <div id='boxes-box-brought_lf' class='boxes-box'><div class="boxes-box-content">
      <p><span>Brought to you by</span> <a href="http://www.linuxfoundation.org"><img alt="Linux Foundation" src="/sites/all/themes/custom/lcom/images/lf/logo-header.png" /></a></p></div></div>	</div>

</div>
  </div>

      </div>

        
<nav class="main-menu" role="navigation">
  <div class="container">

    
    
    <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/news" class="menu__link">News</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/news/category/enterprise" class="menu__link">Enterprise</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/desktop" class="menu__link">Desktop</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/embeddedmobile" class="menu__link">Mobile &amp; Embedded</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/open-source-practices" class="menu__link">Open Source</a></li>
<li class="menu__item is-leaf leaf"><a href="/news/category/linux-kernel" class="menu__link">Linux Kernel</a></li>
<li class="menu__item is-leaf leaf"><a href="/devops" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf"><a href="/networking" class="menu__link">Networking</a></li>
<li class="menu__item is-leaf last leaf"><a href="/cloud" class="menu__link">Cloud Computing</a></li>
</ul></li>
<li class="menu__item is-leaf leaf"><a href="/tutorials" class="menu__link">Tutorials</a></li>
<li class="menu__item is-leaf leaf"><a href="/blogs/linux-foundation" class="menu__link expanded">Open Source Pro</a></li>
<li class="menu__item is-expanded expanded"><span class="menu__link nolink">Learn</span><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/what-is-linux" class="menu__link">What is Linux?</a></li>
<li class="menu__item is-leaf leaf"><a href="/learn/training" class="menu__link">Training</a></li>
<li class="menu__item is-leaf leaf"><a href="/certification" class="menu__link">Certification</a></li>
<li class="menu__item is-leaf leaf"><a href="/events" class="menu__link">Events</a></li>
<li class="menu__item is-leaf last leaf"><a href="/blog/upcoming-free-webinars-linux-foundation" class="menu__link">Webinars</a></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/community" class="menu__link">Community</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/community/participate" class="menu__link">Participate</a></li>
<li class="menu__item is-leaf leaf"><a href="/answers" class="menu__link">Q&amp;A</a></li>
<li class="menu__item is-leaf leaf"><a href="/forum" class="menu__link">Forums</a></li>
<li class="menu__item is-leaf last leaf"><a href="/community/blogs" class="menu__link">Blogs</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded"><span class="menu__link nolink">Resources</span><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/resources/newsletter" class="menu__link">Newsletter</a></li>
<li class="menu__item is-leaf leaf"><a href="/distributions" class="menu__link">Distributions</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/publications" class="menu__link">Publications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/infographics" class="menu__link">Infographics</a></li>
<li class="menu__item is-leaf leaf"><a href="/photos" class="menu__link">Photos</a></li>
<li class="menu__item is-leaf leaf"><a href="/videos" class="menu__link">Videos</a></li>
<li class="menu__item is-leaf last leaf"><a href="/linux-and-open-source-jobs" class="menu__link">Jobs</a></li>
</ul></li>
</ul>
  </div>
</nav><!-- /#navigation -->

<div id="block-views-ed07b1def74a71b1f939ef53b3d18ead" class="block block-views last even search-block">

  <div class="container">
        
    <a id="search__toggle_desktop" href="#"><span></span></a>

    <div class="block__content">
      <form action="/search" method="get" id="views-exposed-form-linux-search-node-panel-pane-1" accept-charset="UTF-8"><div><div class="views-exposed-form">
  <div class="views-exposed-widgets clearfix">
          <div id="edit-keyword-wrapper" class="views-exposed-widget views-widget-filter-search_api_views_fulltext">
                        <div class="views-widget">
          <div class="form-item form-type-textfield form-item-keyword">
 <input type="text" id="edit-keyword" name="keyword" value="" size="30" maxlength="128" class="form-text required error" />
</div>
        </div>
              </div>
                    <div class="views-exposed-widget views-submit-button">
      <input type="submit" id="edit-submit-linux-search-node" name="" value="Search" class="form-submit" />    </div>
      </div>
</div>
</div></form>    </div>
  </div>

</div>

    </div>
  </header>

  
  <div id="main">
    <div class="container">
      <div id="content" class="column" role="main">
                        <a id="main-content"></a>
                                                                


<div class="lcom-stacked__header"><div class="panel-pane pane-entity-field pane-user-field-profile-image node-author-image"  >
  
      
  
  <div class="field field-name-field-profile-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/users/ericstephenbrown"><img typeof="foaf:Image" src="https://www.linux.com/sites/lcom/files/styles/author_profile_image_24x24/public/profile_image/42808.jpg?itok=PHrTCuUY" width="30" height="30" alt="" /></a></div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-real-author-name-linked-panel-pane-1 node-author"  >
  
      
  
  <div id="view-id-real_author_name_linked-panel_pane_1" class="view view-real-author-name-linked view-id-real_author_name_linked view-display-id-panel_pane_1 view-dom-id-093da9ab468a4b5b16ae7d40a8954f0b">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-linux-name">        <div class="field-content"><a href="/users/ericstephenbrown">Eric Brown</a></div>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-node-created node-date"  >
  
      
  
  August 17, 2018
  
  </div>
</div><div class="lcom-stacked__main"><div class="panel-pane pane-node-title"  >
  
      
  
  <h1>Zephyr Project Embraces RISC-V with New Members and Expanded Board Support</h1>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-image"  >
  
      
  
  <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><div id="file-9441" class="file file-image file-image-jpeg">

        <h2 class="element-invisible"><a href="/files/images/zephyr-miroslava-459955-unsplashjpg-0">zephyr-miroslava-459955-unsplash.jpg</a></h2>
    
  
  <div class="content">
    <img typeof="foaf:Image" src="https://www.linux.com/sites/lcom/files/styles/rendered_file/public/zephyr-miroslava-459955-unsplash_0.jpg?itok=mTHN_i0m" alt="Zephyr" title="Zephyr" /><div class="group-file-info field-group-div"><div class="field field-name-field-caption field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even">Zephyr is now certified to run 100 boards spanning ARM, x86, ARC, NIOS II, XTENSA, and RISCV32 architectures.</div></div></div><div class="field field-name-field-license field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/licenses/category/creative-commons-zero" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Creative Commons Zero</a></div></div></div><div class="field field-name-field-source field-type-link-field field-label-hidden"><div class="field-items"><div class="field-item even">Unsplash</div></div></div></div>  </div>

  
</div>
</div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-body"  >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><span><span>The Linux Foundation’s Zephyr Project, which is developing the open source </span><a href="https://www.linux.com/blog/event/elce/2017/12/why-zephyr-project-uses-vendor-hals"><span>Zephyr</span></a><span> real-time operating system (RTOS) for microcontrollers, </span><a href="https://www.zephyrproject.org/news/announcements/"><span>announced six new members, including RISC-V members Antmicro and SiFive</span></a><span>. The project also announced expanded support for developer boards. Zephyr is now certified to run 100 boards spanning </span><span>ARM, x86, ARC, NIOS II, XTENSA, and RISCV32 architectures.</span></span></p>
<p><span><span>Antmicro, SiFive, and </span><a href="http://www.devicetone.com/2018/03/11/devicetone-joins-linux-foundations-zephyr-project/"><span>DeviceTone</span></a><span>, which makes IoT-savvy smart clients, have signed up as Silver members, joining </span><span>Oticon, runtime.io, Synopsys, and Texas Instruments. The other three new members -- Beijing University of Posts and Telecommunications, The Institute of Communication and Computer Systems (ICCS), and Northeastern University – have joined the Vancouver Hack Space as Associate members. </span></span></p>
<p><span><span>The Platinum member leadership of Intel, Linaro, Nordic Semiconductor, and NXP remains the same. NXP, which has returned to an independent course after </span><a href="https://www.reuters.com/article/us-nxp-semicondtrs-m-a-qualcomm/qualcomm-ends-44-billion-nxp-bid-after-failing-to-win-china-approval-idUSKBN1KF193"><span>Qualcomm dropped its $44 billion bid</span></a><span>, supplied one of the first Zephyr dev boards – its Kinetis-based </span><span>FRDM-K64F (Freedom-K64F) – </span><span>joining two Arduino boards and Intel’s Galileo Gen 2. Like Nordic, NXP is a leading microcontroller unit (MCU) chipmaker in addition to producing Linux-friendly Cortex-A SoCs like the i.MX8.</span></span></p>
<h3><span><span>RTOSes go open source</span></span></h3>
<p><span><span>Zephyr is still a toddler compared to more established open source RTOS projects like industry leader FreeRTOS, and the newer Arm Mbed, which has the advantage of being sponsored by the IP giant behind Cortex-M MCUs. Yet, the growing migration from proprietary to open source RTOSes signals good times for everyone.</span></span></p>
<p><span><span>“There is a major shift going on the RTOS space with so many things driving the increase in preference for open source choices,” said Thea Aldrich, the </span><span>Zephyr Project’s new Evangelist and Developer Advocate, in an interview with Linux.com. “</span><span>In a lot of ways, we’re seeing the same factors and motivations at play as happened with Linux many years ago. I am the most excited to see the movement on the low end.”</span></span></p>
<h3><span><span>RISC-V alignment</span></span></h3>
<p><span><span>The decision to align Zephyr with similarly future-looking open source projects like RISC-V appears to be a sound strategic move. “Antmicro and SiFive bring a lot of excitement and energy and great perspective to Zephyr,” said Aldrich.</span></span></p>
<p><span><span>With SiFive, the Zephyr Project now has the premiere RISC-V hardware player on board. SiFive created the first MCU-class RISC-V SoC with its open source </span><a href="http://linuxgizmos.com/first-socs-based-on-open-source-risc-v-run-linux/"><span>Freedom E300</span></a><span>, which powers its Arduino-compatible </span><a href="http://linuxgizmos.com/first-open-source-risc-v-chips-arrive-in-arduino-board/"><span>HiFive1</span></a><span> and </span><a href="http://linuxgizmos.com/arduino-cinque-board-taps-sifive-risc-v-soc-and-an-esp32-wireless-chip/"><span>Arduino Cinque</span></a><span> boards. The company also produced the first Linux-friendly RISC-V SoC with its Freedom U540, the SoC that powers its </span><a href="https://www.linux.com/blog/event/elc-open-iot/2018/2/first-linux-based-risc-v-board-prepares-take"><span>HiFive Unleashed</span></a><span> SBC. (SiFive will soon have RISC-V-on-Linux competition from an India-based project called </span><a href="http://linuxgizmos.com/linux-boots-on-new-shakti-risc-v-chip/"><span>Shakti</span></a><span>.)</span></span></p>
<p><span><span>Antmicro is the official maintainer of RISC-V in the Zephyr Project and is active in the RISC-V community. Its open source </span><a href="https://renode.io/"><span>Renode</span></a><span> IoT development framework is integrated in the Mi-V platform of Microsemi, the leading RISC-V soft-core vendor</span><span>. Antmicro has also developed a variety of custom software-based implementations of RISC-V for commercial customers.</span></span></p>
<p><span><span>Antmicro and SiFive announced a </span><a href="https://antmicro.com/blog/2018/08/antmicro-sifive-press-release/"><span>partnership</span></a><span> in which SiFive will provide Renode to its customers as part of “a comprehensive solution covering build, debug and test in multi-node systems.” The announcement touts Renode’s ability to simulate an entire SoC for RISC-V developers, not just the CPU.</span></span></p>
<p><span><span>Zephyr now supports RISC-V on QEMU, as well as the SiFive HiFive1, Microsemi’s FPGA-based, soft-core </span><a href="http://docs.zephyrproject.org/boards/riscv32/m2gl025_miv/doc/m2g1025_miv.html"><span>M2GL025 Mi-V</span></a><span> board, and the </span><a href="http://docs.zephyrproject.org/boards/boards.html"><span>Zedboard Pulpino</span></a><span>. The latter is an implementation of PULP’s open source </span><a href="https://github.com/pulp-platform/pulpino/tree/master/fpga"><span>PULPino</span></a><span> RISC-V soft core that runs on the venerable Xilinx Zynq based </span><a href="http://linuxgizmos.com/community-supported-sbc-runs-linux-on-arm-fpga-soc/"><span>ZedBoard</span></a><span>.</span></span></p>
<p><span><span>Other development boards on the Zephyr dev board list include boards based on MCUs from Microchip, Nordic, NXP, ST, and others, as well as the BBC Microbit and </span><a href="http://linuxgizmos.com/96boards-goes-cortex-m4-with-iot-edition-and-carbon-sbc/"><span>96Boards Carbon</span></a><span>. Supported SBCs that primarily run Linux, but can also run Zephyr on their MCU companion chips, include the MinnowBoard Max, Udoo Neo, and UP Squared. </span></span></p>
<h3><span><span>Zephyr 1.13 on track</span></span></h3>
<p><span><span>The Zephyr Project is now prepping a </span><a href="https://github.com/zephyrproject-rtos/zephyr/projects/9"><span>1.13</span></a><span> build due in September, following the usual three-month release cycle. The release adds support for Precision Time Protocol PTP and </span><a href="http://linuxgizmos.com/spdx-v2-simplifies-open-source-license-dependency-tracking/"><span>SPDX</span></a><span> license tracking, among other features. Zephyr 1.13 continues to expand upon Zephyr’s “safety and security certifications and features,” says Aldrich, a former Eclipse Foundation Developer Advocate.  </span></span></p>
<p><span><span>Aldrich first encountered Zephyr when she found it to be an ideal platform for <a href="https://www.zephyrproject.org/meet-thea-aldrich/">tracking her cattle with sensors</a> on a small ranch in Texas. “</span><span>Zephyr fits in really nicely as the operating system for sensors and other devices way out on the edge,” she says.</span></span></p>
<p><span><span>Zephyr has other advantages such as its foundation on the latest open source components and its support for the latest wireless and sensor devices. Aldrich was particularly attracted to the Zephyr Project’s independence and transparent open source governance.</span></span></p>
<p><span><span>“There are a lot of choices for open source RTOSes and each has its own strengths and weaknesses,” continued Aldrich, “We have a lot of really strong aspects of our project but the community and how we operate is what comes to mind first. It's a truly collaborative effort. For us, open source is more than a license. We’ve made it transparent how technical decisions are made and community input is incorporated.”</span></span></p>
<p><span><span>Join us at </span><a href="https://events.linuxfoundation.org/events/elc-openiot-europe-2018/"><span>Open Source Summit + Embedded Linux Conference Europe</span></a><span> in Edinburgh, UK on October 22-24, 2018, for 100+ sessions on Linux, Cloud, Containers, AI, Community, and more.</span></span></p>
<p><iframe frameborder="0" height="150" src="https://www2.thelinuxfoundation.org/l/6342/2018-04-05/3z7t95" style="border:0;" width="100%"></iframe></p>
</div></div></div>
  
  </div>
<div class="panel-pane pane-node-links"  >
  
      
  
  <ul class="links inline"><li class="addtoany first"><span><span class="a2a_kit a2a_target addtoany_list" id="da2a_1">
      
      <a class="a2a_dd addtoany_share_save" href="https://www.addtoany.com/share#url=https%3A%2F%2Fwww.linux.com%2Fnews%2F2018%2F8%2Fzephyr-project-embraces-risc-v-new-members-and-expanded-board-support&amp;title=Zephyr%20Project%20Embraces%20RISC-V%20with%20New%20Members%20and%20Expanded%20Board%20Support"></a>
      <a class="a2a_button_email"></a>
    <a class="a2a_button_facebook"></a>
    <a class="a2a_button_twitter"></a>
    <a class="a2a_button_linkedin"></a>
    <a class="a2a_button_pinterest"></a>
    <a class="a2a_button_google_plus"></a>
    </span>
    <script type="text/javascript">
<!--//--><![CDATA[//><!--
if(window.da2a)da2a.script_load();
//--><!]]>
</script></span></li>
<li class="comment_forbidden"></li>
<li class="print_html"><a href="/print/857935" title="Display a printer-friendly version of this page." class="print-page" rel="nofollow">Print This</a></li>
<li class="flag-imagex_node_like last"><span><span class="flag-wrapper flag-imagex-node-like flag-imagex-node-like-857935">
      <a href="/flag/flag/imagex_node_like/857935?destination=node/857935&amp;token=3801911262505a05a685eaf308857a35" title="" class="flag flag-action flag-link-toggle" rel="nofollow">Like</a><span class="flag-throbber">&nbsp;</span>
          (<span class="flag-counter">0 likes</span>)
  </span>
</span></li>
</ul>
  
  </div>
</div><a href="/popup/nojs" class="ctools-use-modal ctools-modal-subscription-modal-style element-invisible" title="">Click Here!</a>      </div>

      
              <aside class="sidebars">
                      <section class="region region-sidebar-second column sidebar">
    
<div id="block-dfp-box1" class="block block-dfp first odd ">

    
	<div class="block__content">
	  <div id="dfp-ad-box1-wrapper" class="dfp-tag-wrapper">
<div  id="dfp-ad-box1" class="dfp-tag-wrapper">
  <div class="slug">Advertisement</div>  <script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-box1");
    });
  </script>
</div>
</div>	</div>

</div>

<section id="block-views-training-block-1" class="block block-views even lf-training-block">

    	<header>
	    <h2 class="block__title block-title">Training</h2>
		</header>
	  
	<div class="block__content">
	  <div id="view-id-training-block_1" class="view view-training view-id-training view-display-id-block_1 view-dom-id-ee8ce15bf2d6655cd97f73be4763a8b4">
            <div class="view-header">
      <div class="see_all_button"><a href="/learn/training">See all</a></div>
    </div>
  
  
  
      <div class="view-content">
          <ul>          <li class="views-row views-row-1 views-row-odd views-row-first">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfs458-kubernetes-administration-3">LFS458 Kubernetes Administration</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2018-08-20T00:00:00+00:00">August 20, 2018</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/system-administration-training/kubernetes-administration">Learn more</a></div>  </div></li>
          <li class="views-row views-row-2 views-row-even">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfs301-linux-system-administration-26">LFS301 Linux System Administration</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2018-08-20T00:00:00+00:00">August 20, 2018</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/system-administration-training/linux-system-administration">Learn more</a></div>  </div></li>
          <li class="views-row views-row-3 views-row-odd views-row-last">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/training/lfd440-27august2018-enea">LFD440 27August2018 ENEA</a></span>  </div>  
          <div class="field-content meta"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2018-08-27T00:00:00+00:00">August 27, 2018</span></div>    
  <div class="links">        <div class="learn-more"><a href="https://training.linuxfoundation.org/linux-courses/development-training/linux-kernel-debugging-and-security">Learn more</a></div>  </div></li>
      </ul>    </div>
  
  
  
  
  
  
</div>	</div>

</section>

<section id="block-linux-blocks-pardot-newsletter-signup-form" class="block block-linux-blocks odd ">

    	<header>
	    <h2 class="block__title block-title">Newsletter</h2>
		</header>
	  
	<div class="block__content">
	  <iframe src="//go.pardot.com/l/6342/2011-03-24/1ATL" width="100%" height="420px" type="text/html" frameborder="0" allowTransparency="true" style="border: 0"></iframe>	</div>

</section>

<section id="block-views-linux-jobs-related-jobs-block" class="block block-views last even ">

    	<header>
	    <h2 class="block__title block-title">Related Jobs</h2>
		</header>
	  
	<div class="block__content">
	  <div id="view-id-linux_jobs-related_jobs_block" class="view view-linux-jobs view-id-linux_jobs view-display-id-related_jobs_block view-dom-id-73b0c289b9632d617b88a9c934fe17c2">
        
  
  
      <div class="view-empty">
      <div id="view-id-linux_jobs-all_jobs_block" class="view view-linux-jobs view-id-linux_jobs view-display-id-all_jobs_block view-dom-id-a6a3750d53df8dc8770d126434460fa5">
        
  
  
  
  
  
  
  
  
</div>    </div>
  
  
  
  
  
  
</div>	</div>

</section>
  </section>
        </aside>
      
    </div>
  </div>

  
    <footer id="footer" class="region region-footer">
  	<div class="container">
    	
<div id="block-menu-block-1" class="block block-menu-block first odd lf-footer-primary-menu footer-menu" role="navigation">

    
	<div class="block__content">
	  <div class="menu-block-wrapper menu-block-1 menu-name-main-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-expanded first expanded menu-mlid-1275"><a href="/news" class="menu__link">News</a><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1281"><a href="/news/category/enterprise" class="menu__link">Enterprise</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1282"><a href="/news/category/desktop" class="menu__link">Desktop</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1283"><a href="/news/category/embeddedmobile" class="menu__link">Mobile &amp; Embedded</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1284"><a href="/news/category/open-source-practices" class="menu__link">Open Source</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1285"><a href="/news/category/linux-kernel" class="menu__link">Linux Kernel</a></li>
<li class="menu__item is-leaf leaf menu-mlid-5595"><a href="/devops" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf menu-mlid-5596"><a href="/networking" class="menu__link">Networking</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-5597"><a href="/cloud" class="menu__link">Cloud Computing</a></li>
</ul></li>
<li class="menu__item is-leaf leaf menu-mlid-1276"><a href="/tutorials" class="menu__link">Tutorials</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1277"><a href="/blogs/linux-foundation" class="menu__link expanded">Open Source Pro</a></li>
<li class="menu__item is-expanded expanded menu-mlid-1278"><span class="menu__link nolink">Learn</span><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1292"><a href="/what-is-linux" class="menu__link">What is Linux?</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1293"><a href="/learn/training" class="menu__link">Training</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1294"><a href="/certification" class="menu__link">Certification</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1295"><a href="/events" class="menu__link">Events</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1296"><a href="/blog/upcoming-free-webinars-linux-foundation" class="menu__link">Webinars</a></li>
</ul></li>
<li class="menu__item is-expanded expanded menu-mlid-1279"><a href="/community" class="menu__link">Community</a><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1297"><a href="/community/participate" class="menu__link">Participate</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1298"><a href="/answers" class="menu__link">Q&amp;A</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1299"><a href="/forum" class="menu__link">Forums</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1300"><a href="/community/blogs" class="menu__link">Blogs</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded menu-mlid-1280"><span class="menu__link nolink">Resources</span><ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-1301"><a href="/resources/newsletter" class="menu__link">Newsletter</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1303"><a href="/distributions" class="menu__link">Distributions</a></li>
<li class="menu__item is-leaf leaf menu-mlid-3808"><a href="/resources/publications" class="menu__link">Publications</a></li>
<li class="menu__item is-leaf leaf menu-mlid-3809"><a href="/resources/infographics" class="menu__link">Infographics</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1286"><a href="/photos" class="menu__link">Photos</a></li>
<li class="menu__item is-leaf leaf menu-mlid-1287"><a href="/videos" class="menu__link">Videos</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-10188"><a href="/linux-and-open-source-jobs" class="menu__link">Jobs</a></li>
</ul></li>
</ul></div>
	</div>

</div>

<div id="block-menu-menu-footer" class="block block-menu even lf-footer-about-menu footer-menu" role="navigation">

    
	<div class="block__content">
	  <ul class="menu"><li class="menu__item is-expanded first last expanded"><a href="/about" class="menu__link">About Linux.com</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/terms-of-use" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.linuxfoundation.org/privacy/" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/editorial-policy" class="menu__link">Editorial Policy</a></li>
<li class="menu__item is-leaf last leaf"><a href="/contact" class="menu__link">Contact</a></li>
</ul></li>
</ul>	</div>

</div>

<div id="block-boxes-about-lf" class="block block-boxes block-boxes-simple odd lf-about">

    
	<div class="block__content">
	  <div id='boxes-box-about_lf' class='boxes-box'><div class="boxes-box-content">
        <p><a href="http://www.linuxfoundation.org"><img alt="Linux Foundation" src="/sites/all/themes/custom/lcom/images/lf/logo-footer.png" /></a></p>
        <p>The Linux Foundation is a non-profit consortium enabling collaboration and innovation through an open source development model.</p>
        <p><a href="http://www.linuxfoundation.org" class="more">Learn More</a></p></div></div>	</div>

</div>

<div id="block-linux-blocks-linux-accelerated-by" class="block block-linux-blocks even ">

    
	<div class="block__content">
	  <div class="row"><p>Accelerated by</p></div><div class="row"><a href="http://www.fastly.com"><img typeof="foaf:Image" src="https://www.linux.com/sites/all/themes/custom/lcom/images/fastly-logo.png" width="60px" alt="Fastly" title="Fastly" /></a></div><div class="row"><a href="http://www.dnsmadeeasy.com"><img class="dns-made-easy-logo" typeof="foaf:Image" src="https://www.linux.com/sites/all/themes/custom/lcom/images/dns-made-easy-logo.png" width="100px" alt="DNS Made Easy" title="DNS Made Easy" /></a></div>	</div>

</div>

<div id="block-boxes-copyright-infos" class="block block-boxes block-boxes-simple odd lf-copyright">

    
	<div class="block__content">
	  <div id='boxes-box-copyright_infos' class='boxes-box'><div class="boxes-box-content"><p>&copy; 2016 The Linux Foundation</p></div></div>	</div>

</div>

<div id="block-block-3" class="block block-block last even ">

    
	<div class="block__content">
	  <!-- Google Analytics -->
<!--<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-831873-8', 'auto');
ga('send', 'pageview');
</script>-->
<!-- End Google Analytics -->	</div>

</div>
  	</div>
  </footer>

</div>


  <script src="https://www.linux.com/sites/lcom/files/js/js_EIY91SVu4Ez1BN8UI_1XQnC6AJTb65-lR4DGrCwCjos.js"></script>
<script>da2a.targets=[
{title:"Zephyr Project Embraces RISC-V with New Members and Expanded Board Support",url:"https:\/\/www.linux.com\/news\/2018\/8\/zephyr-project-embraces-risc-v-new-members-and-expanded-board-support"}];
da2a.html_done=true;if(da2a.script_ready&&!da2a.done)da2a.init();da2a.script_load();</script>
<script defer="defer" src="https://www.fastly-insights.com/insights.js?k=d45c0551-a6a5-45e3-90c5-0c474e341570&amp;sample=0.5"></script>
</body>
</html>
