December 3, 2009

Debian Security Advisory 1946 belpic - cryptographic weakness

Article Source Debian Security Advisories
December 3, 2009, 4:00 pm

It was discovered that belpic, the belgian eID PKCS11 library, does not properly check the result of an OpenSSL function for verifying cryptographic signatures, which could be used to bypass the certificate validation.

For the oldstable distribution (etch), this problem has been fixed in version 2.5.9-7.etch.1.

For the stable distribution (lenny), this problem has been fixed in version 2.6.0-6, which was already included in the lenny release.

For the testing distribution (squeeze) and the unstable distribution (sid), this problem has been fixed in version 2.6.0-6.

We recommend that you upgrade your belpic packages...

Read More

Click Here!